summaryrefslogtreecommitdiff
path: root/packages/meta
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-14 06:10:54 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-14 06:10:54 +0000
commita4f0089c5bf7d37257b244fb08de5e756498c6cd (patch)
tree11c58b923af4a2c34ade87e2db7ffb690ce73bb9 /packages/meta
parent5a048cc09baf8498736e25699ca85b3c69a01adb (diff)
slugos: move to ixp4xx-kernel, change nslu2 to more generic ixp4xx in conf
- rather than build nslu2-kernel or nas100d-kernel slugos-image now builds ixp4xx-kernel, the generic kernel. ixp4xx is now used as the normal MACHINE override, even though MACHINE itself is still set to nslu2 or nas100d (or ixp4xx).
Diffstat (limited to 'packages/meta')
-rw-r--r--packages/meta/slugos-image.bb5
-rw-r--r--packages/meta/slugos-imagename.bb7
2 files changed, 5 insertions, 7 deletions
diff --git a/packages/meta/slugos-image.bb b/packages/meta/slugos-image.bb
index 1fa67bb9d3..df3103fd79 100644
--- a/packages/meta/slugos-image.bb
+++ b/packages/meta/slugos-image.bb
@@ -37,6 +37,11 @@ IMAGE_POSTPROCESS_COMMAND += "${PACK_IMAGE}"
PACK_IMAGE_DEPENDS = ""
EXTRA_IMAGEDEPENDS += "${PACK_IMAGE_DEPENDS}"
+# This hack removes '${MACHINE}' from the end of the arch.conf for ipk,
+# preventing _mach.ipk (with no byte sex) taking precedence over everything
+# else.
+IMAGE_POSTPROCESS_COMMAND += "sed '$d' '${IMAGE_ROOTFS}/etc/ipkg/arch.conf';"
+
# These depends define native utilities - they do not get put in the flash and
# are not required to build the image.
IMAGE_TOOLS = ""
diff --git a/packages/meta/slugos-imagename.bb b/packages/meta/slugos-imagename.bb
index 35578442c2..a6967a6208 100644
--- a/packages/meta/slugos-imagename.bb
+++ b/packages/meta/slugos-imagename.bb
@@ -26,10 +26,3 @@ do_stage() {
}
do_build() {
}
-
-python () {
- # Don't build slugos images unless the configuration is set up
- # for an image build!
- if bb.data.getVar("SLUGOS_IMAGENAME", d, 1) == '':
- raise bb.parse.SkipPackage("absent SlugOS configuration")
-}