summaryrefslogtreecommitdiff
path: root/packages/meta
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-27 13:40:44 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-27 13:40:44 +0000
commit9680f4a242b63233f8d15646ac6f5f7e04695468 (patch)
tree2622c4e71687de077565df0a623e25b8f63cf016 /packages/meta
parentae05fa2fe9dbda08a39afcd6d32eb6deed317e58 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2004/12/27 14:28:28+01:00 dyndns.org!reenoo Merge oe-devel@oe-devel.bkbits.net:openembedded into sugarcube.dyndns.org:/home2/oe/bakery/openembedded 2004/12/27 14:28:11+01:00 dyndns.org!reenoo vlc-gpe: fix FILES. package .desktop file. 2004/12/27 14:00:41+01:00 uni-frankfurt.de!mickeyl opie cvs stuff is now 1.1.8+cvs- 2004/12/27 13:53:14+01:00 uni-frankfurt.de!mickeyl openzaurus 3.5.3 uses opie 1.1.8 and qte 2.3.9 BKrev: 41d010dc7G8fBE-Qnk0n_kXXQwxqPw
Diffstat (limited to 'packages/meta')
-rw-r--r--packages/meta/openslug-image.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/meta/openslug-image.bb b/packages/meta/openslug-image.bb
index e69de29bb2..cc4bf61184 100644
--- a/packages/meta/openslug-image.bb
+++ b/packages/meta/openslug-image.bb
@@ -0,0 +1,33 @@
+PR = "r2"
+
+IMAGE_BASENAME = "openslug"
+
+IMAGE_LINGUAS = ""
+USE_DEVFS = "1"
+
+OPENSLUG_HIDDEN_PACKAGES = "ipkg-native ipkg-utils-native fakeroot-native patcher-native virtual/armeb-linux-uclibc-gcc \
+ virtual/libc makedevs-native mtd-utils-native slugimage-native nslu2-linksys-firmware nslu2-switchbox-firmware "
+
+DEPENDS = "base-files base-passwd-3.5.7 \
+ busybox dropbear hotplug initscripts netbase \
+ sysvinit tinylogin lrzsz portmap \
+ ixp4xx-csr ixp425-eth \
+ ipkg-collateral ipkg ipkg-link \
+ ${OPENSLUG_EXTRA_DEPENDS}"
+
+IPKG_INSTALL = "base-files base-passwd \
+ busybox dropbear hotplug initscripts netbase \
+ update-modules sysvinit tinylogin lrzsz portmap \
+ ixp4xx-csr ixp425-eth \
+ ipkg-collateral ipkg ipkg-link \
+ ${OPENSLUG_EXTRA_INSTALL}"
+
+inherit image_ipk
+
+python () {
+ # Don't build openslug images unless we're targeting an nslu2
+ mach = bb.data.getVar("MACHINE", d, 1)
+ dist = bb.data.getVar("DISTRO", d, 1)
+ if mach != 'nslu2' or dist != 'openslug':
+ raise bb.parse.SkipPackage("OpenSlug only builds for the Linksys NSLU2")
+}