summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-08-30 10:22:42 +0000
committerKoen Kooi <koen@openembedded.org>2006-08-30 10:22:42 +0000
commitb0e7d9796b0affcd3bf49987f4965a527cb0e5a9 (patch)
treec49533b9dfcd335335957f7c341e71ffa363f290 /packages/linux
parent5b7b79c16d9547471842bc26719b3c4bfa75181e (diff)
hh-pxa-2.6 2.6.16 hh5: unbreak do_configure for EABI, add proper COMPATIBLE_MACHINES and do a version check for good measure
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/handhelds-pxa-2.6_2.6.16-hh5.bb43
1 files changed, 35 insertions, 8 deletions
diff --git a/packages/linux/handhelds-pxa-2.6_2.6.16-hh5.bb b/packages/linux/handhelds-pxa-2.6_2.6.16-hh5.bb
index 555ec411ee..a5cc4073e4 100644
--- a/packages/linux/handhelds-pxa-2.6_2.6.16-hh5.bb
+++ b/packages/linux/handhelds-pxa-2.6_2.6.16-hh5.bb
@@ -1,33 +1,60 @@
SECTION = "kernel"
DESCRIPTION = "handhelds.org Linux kernel for PXA based devices."
-MAINTAINER = "Greg Gilbert <greg@treke.net>"
LICENSE = "GPL"
-DEFAULT_PREFERENCE = "-1"
-
COMPATIBLE_HOST = "arm.*-linux"
-COMPATIBLE_MACHINE = '(h3900|h2200|h4000|ipaq-pxa270)'
+COMPATIBLE_MACHINE = '(h3900|h2200|h4000|h5xxx|htcuniversal|ipaq-pxa270)'
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-pxa-${PV}"
SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
- file://ide_not_removable-r0.patch;patch=1 \
- file://block-pio.patch;patch=1 \
file://defconfig"
S = "${WORKDIR}/kernel26"
inherit kernel
+FILES_kernel-image_ipaq-pxa270 = ""
+ALLOW_EMPTY_ipaq_pxa270 = 1
+FILES_kernel-image_htcuniversal = ""
+ALLOW_EMPTY_htcuniversal = 1
+
+
+
K_MAJOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[0]}"
K_MINOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[1]}"
K_MICRO = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[2]}"
HHV = "${@bb.data.getVar('PV',d,1).split('-')[1].split('hh')[-1]}"
KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + float(bb.data.getVar('HHV',d,1)))}"
+
do_configure() {
- install -m 0644 ${WORKDIR}/defconfig ${S}/.config || die "No default configuration for ${MACHINE} available."
- yes '' | oe_runmake oldconfig
+
+ if [ `grep EXTRAVERSION Makefile | grep hh | awk '{print $3}' | sed s/-hh//` != ${HHV} ]; then
+ die "-hh version mismatch"
+ fi
+
+ rm -f ${S}/.config
+
+ if [ ! -e ${WORKDIR}/defconfig ]; then
+ die "No default configuration for ${MACHINE} available."
+ fi
+
+
+ if [ "${TARGET_OS}" == "linux-gnueabi" ]; then
+ echo "CONFIG_AEABI=y" >> ${S}/.config
+ echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
+ else
+ echo "# CONFIG_AEABI is not set" >> ${S}/.config
+ echo "# CONFIG_OABI_COMPAT is not set" >> ${S}/.config
+ fi
+
+ sed -e '/CONFIG_AEABI/d' \
+ -e '/CONFIG_OABI_COMPAT=/d' \
+ '${WORKDIR}/defconfig' >>'${S}/.config'
+
+ yes '' | oe_runmake oldconfig
+
}
do_deploy() {