summaryrefslogtreecommitdiff
path: root/packages/libxine/libxine_1.0.0-beta12.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/libxine/libxine_1.0.0-beta12.bb
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/libxine/libxine_1.0.0-beta12.bb')
-rw-r--r--packages/libxine/libxine_1.0.0-beta12.bb90
1 files changed, 90 insertions, 0 deletions
diff --git a/packages/libxine/libxine_1.0.0-beta12.bb b/packages/libxine/libxine_1.0.0-beta12.bb
index e69de29bb2..6f3558c095 100644
--- a/packages/libxine/libxine_1.0.0-beta12.bb
+++ b/packages/libxine/libxine_1.0.0-beta12.bb
@@ -0,0 +1,90 @@
+LICENSE = GPL
+DESCRIPTION = "libxine is a library for multimedia players. \
+It plays back CDs, DVDs, and VCDs. It also decodes multimedia \
+files like AVI, MOV, WMV, and MP3 from local disk drives, \
+and displays multimedia streamed over the Internet. It interprets \
+many of the most common multimedia formats available - \
+and some of the most uncommon formats, too."
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "zlib libogg tremor libmad"
+PR = "r4"
+
+inherit autotools pkgconfig binconfig gettext
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/xine/xine-lib-1-beta12.tar.gz \
+ file://full.patch;patch=1 \
+ file://libvorbis.patch;patch=1 \
+ file://demux_ogg.patch;patch=1 \
+ file://configure.ac.patch;patch=1 \
+ file://vo_scale.patch;patch=1 \
+ file://oss.patch;patch=1;pnum=0 \
+ file://fix-oss-plugin.patch;patch=1 \
+ file://mpegvideo-static-inlining.patch;patch=1 \
+ file://fix-syntax-xine-vorbis-decoder.patch;patch=1 \
+ file://fftscope-static-inlining.patch;patch=1"
+S = "${WORKDIR}/xine-lib-1-beta12"
+
+SOV = "1.0.6"
+
+do_configure() {
+ ./autogen.sh --host ${TARGET_SYS} --build ${BUILD_SYS} \
+ --enable-shared --disable-static --prefix=${prefix} \
+ --with-zlib-path=${STAGING_DIR}/${HOST_SYS} --with-vorbis-prefix=${STAGING_DIR}/${HOST_SYS} \
+ --disable-oggtest --with-ogg-prefix=${STAGING_DIR}/${HOST_SYS} --without-x \
+ --disable-iconv --without-arts --without-sdl \
+ --disable-aalib
+}
+
+do_compile() {
+ oe_runmake LIBTOOL=${STAGING_BINDIR}/${TARGET_PREFIX}libtool OGG_LIBS=${STAGING_LIBDIR}/libogg.so
+}
+
+do_stage() {
+ oe_runmake -e LIBTOOL=${STAGING_BINDIR}/${TARGET_PREFIX}libtool \
+ -C src install-data \
+ 'prefix=${STAGING_DIR}' 'exec_prefix=${STAGING_DIR}' \
+ 'libdir=${STAGING_LIBDIR}' \
+ 'includedir=${STAGING_INCDIR}'
+
+ oe_runmake -e LIBTOOL=${STAGING_BINDIR}/${TARGET_PREFIX}libtool \
+ -C include install-data \
+ 'prefix=${STAGING_DIR}' 'exec_prefix=${STAGING_DIR}' \
+ 'libdir=${STAGING_LIBDIR}' \
+ 'includedir=${STAGING_INCDIR}'
+
+ for plugin in `find ${S}/src -type f -name xineplug*.la`; do
+ dir=`dirname $plugin`
+ libname=`basename $plugin|sed -e's,\.la,,'`
+ oe_libinstall -so -C $dir $libname ${STAGING_LIBDIR}/xine/plugins/1.0.0
+ done
+
+ oe_libinstall -so -C src/xine-engine libxine ${STAGING_LIBDIR}
+}
+
+do_install() {
+ oe_runmake -e LIBTOOL=${STAGING_BINDIR}/${TARGET_PREFIX}libtool \
+ -C src install-data \
+ 'prefix=${D}' 'exec_prefix=${D}' 'libdir=${D}/${libdir}' \
+ 'includedir=${D}/${includedir}'
+
+ oe_runmake -e LIBTOOL=${STAGING_BINDIR}/${TARGET_PREFIX}libtool \
+ -C include install-data \
+ 'prefix=${D}' 'exec_prefix=${D}' 'libdir=${D}/${libdir}' \
+ 'includedir=${D}/${includedir}'
+
+ for plugin in `find ${S}/src -type f -name xineplug*.la`; do
+ dir=`dirname $plugin`
+ libname=`basename $plugin|sed -e's,\.la,,'`
+ oe_libinstall -so -C $dir $libname ${D}/${libdir}/xine/plugins/1.0.0
+ done
+
+ oe_libinstall -so -C src/xine-engine libxine ${D}/${libdir}
+}
+
+python populate_packages_prepend () {
+ plugins_dir = bb.data.expand('${libdir}/xine/plugins/1.0.0/', d)
+
+ do_split_packages(d, plugins_dir, file_regex='^xineplug_(.*).so$', output_pattern='libxine-plugin-%s', description='Xine plugin - %s')
+}
+