summaryrefslogtreecommitdiff
path: root/packages/icu/files/use-g++-for-linking.patch
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-03-07 13:05:07 +0000
committerJohn Lee <john_lee@openmoko.org>2008-03-07 13:05:07 +0000
commit0b098d35b319ed6c00f363cb0d4fd447d7fb8d57 (patch)
treea830bf983a66688f5648cd83e362c4fea2f48f6b /packages/icu/files/use-g++-for-linking.patch
parent06fb90eb31b0b85a5c5c7adf185ce2515c5b1220 (diff)
parentd3bbd28f22fbd8e9d097081fa128ae18197f36e1 (diff)
merge of '26501141207c84e31e0f43c5795a15c0f16dbce5'
and '86618f966282489d43b51fbf0ee93b954ac615ae'
Diffstat (limited to 'packages/icu/files/use-g++-for-linking.patch')
-rw-r--r--packages/icu/files/use-g++-for-linking.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/packages/icu/files/use-g++-for-linking.patch b/packages/icu/files/use-g++-for-linking.patch
new file mode 100644
index 0000000000..4702abc065
--- /dev/null
+++ b/packages/icu/files/use-g++-for-linking.patch
@@ -0,0 +1,67 @@
+---
+ tools/genccode/Makefile.in | 2 +-
+ tools/gencmn/Makefile.in | 2 +-
+ tools/genrb/Makefile.in | 2 +-
+ tools/pkgdata/Makefile.in | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+--- source.orig/tools/genccode/Makefile.in
++++ source/tools/genccode/Makefile.in
+@@ -76,11 +76,11 @@ check-local: all-local
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ $(TARGET) : $(OBJECTS)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+
+ %.$(SECTION): $(srcdir)/%.$(SECTION).in
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+--- source.orig/tools/gencmn/Makefile.in
++++ source/tools/gencmn/Makefile.in
+@@ -76,11 +76,11 @@ check-local: all-local
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ $(TARGET) : $(OBJECTS)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+ %.$(SECTION): $(srcdir)/%.$(SECTION).in
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+--- source.orig/tools/genrb/Makefile.in
++++ source/tools/genrb/Makefile.in
+@@ -84,11 +84,11 @@ Makefile: $(srcdir)/Makefile.in $(top_b
+
+ $(TARGET) : $(OBJECTS)
+ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+ $(DERB) : $(DERB_OBJ)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+
+ # This line is needed to serialize builds when the gmake -j option is used.
+ $(TARGET_STUB_NAME).$(SECTION): $(DERB_STUB_NAME).$(SECTION)
+
+--- source.orig/tools/pkgdata/Makefile.in
++++ source/tools/pkgdata/Makefile.in
+@@ -81,11 +81,11 @@ check-local: all-local
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ $(TARGET) : $(OBJECTS)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+
+ %.$(SECTION): $(srcdir)/%.$(SECTION).in
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status