summaryrefslogtreecommitdiff
path: root/packages/gxine/gxine_0.4.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/gxine/gxine_0.4.1.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/gxine/gxine_0.4.1.bb')
-rw-r--r--packages/gxine/gxine_0.4.1.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/packages/gxine/gxine_0.4.1.bb b/packages/gxine/gxine_0.4.1.bb
index e69de29bb2..1743d4cdb8 100644
--- a/packages/gxine/gxine_0.4.1.bb
+++ b/packages/gxine/gxine_0.4.1.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "gxine is a front-end for libxine."
+SECTION = "x11/multimedia"
+LICENSE = "GPL"
+MAINTAINER = "Chris Lord <cwiiis@handhelds.org>"
+DEPENDS = "gtk+ libxine"
+PR = "r1"
+
+DEFAULT_PREFERENCE = "-1"
+
+# Long list of RDEPENDS required to playback mp3/ogg audio and mpeg/mpeg4 video
+RDEPENDS = "libxine-plugin-vo-out-xshm \
+ libxine-plugin-vo-out-none \
+ libxine-plugin-ao-out-esd \
+ libxine-plugin-ao-out-none \
+ libxine-plugin-inp-file \
+ libxine-plugin-inp-http \
+ libxine-plugin-inp-net \
+ libxine-plugin-inp-mms \
+ libxine-plugin-decode-mad \
+ libxine-plugin-decode-vorbis \
+ libxine-plugin-decode-image \
+ libxine-plugin-decode-ff \
+ libxine-plugin-dmx-audio \
+ libxine-plugin-dmx-mpeg \
+ libxine-plugin-dmx-mpeg-block \
+ libxine-plugin-dmx-mpeg-elem \
+ libxine-plugin-dmx-mpeg-pes \
+ libxine-plugin-dmx-mpeg-ts \
+ libxine-plugin-dmx-ogg \
+ libxine-plugin-dmx-image \
+ libxine-plugin-dmx-avi"
+
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/xine/${PN}-${PV}.tar.gz \
+ file://disable-browser-plugin.patch;patch=1"
+
+EXTRA_OECONF = " --includedir=${STAGING_INCDIR} \
+ --libdir=${STAGING_LIBDIR} \
+ --disable-xinetest \
+ --with-xine-prefix=${STAGING_DIR}/${HOST_SYS}"
+
+LDFLAGS += -lxine
+
+inherit autotools pkgconfig
+