summaryrefslogtreecommitdiff
path: root/packages/glib-2.0/glib-2.0_2.12.3.bb
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-11-18 16:55:13 +0000
committerHolger Freyther <zecke@selfish.org>2006-11-18 16:55:13 +0000
commit56b7d78a034187f66e08f3b3e2de55bd878cf9b5 (patch)
treed6f4033c0064f41c2205502d10c651e8710c96aa /packages/glib-2.0/glib-2.0_2.12.3.bb
parent9e61974759ef6e4ff9538a33bab0e82b1b4381dd (diff)
Micro-Optimisation decreasing initial parsing time by 10%
python () {} and python __anonymous () {} are as the same says functions without a name. They get executed when the main bb file is completely parsed. This is used to set information like FILESDIR. This is a python method so it gets evaled which means compiled and executed a lot of times. By moving the code of the anonfunc into a proper method this is only compiled once. The result is is the 10% speed up when parsing. Reindent anonfuncs and new defs without tabs and four spaces
Diffstat (limited to 'packages/glib-2.0/glib-2.0_2.12.3.bb')
-rw-r--r--packages/glib-2.0/glib-2.0_2.12.3.bb5
1 files changed, 1 insertions, 4 deletions
diff --git a/packages/glib-2.0/glib-2.0_2.12.3.bb b/packages/glib-2.0/glib-2.0_2.12.3.bb
index 064f2f7f96..90904d0b54 100644
--- a/packages/glib-2.0/glib-2.0_2.12.3.bb
+++ b/packages/glib-2.0/glib-2.0_2.12.3.bb
@@ -24,10 +24,7 @@ S = "${WORKDIR}/glib-${PV}"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {