summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc_3.4.0.bb
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2005-03-09 20:49:56 +0000
committerChris Larson <clarson@kergoth.com>2005-03-09 20:49:56 +0000
commit3c52388dc164fee1d85ca17e648d7e5a1d2d8125 (patch)
tree4d0767078615e5781eef3efa92aa7500c3c2a345 /packages/gcc/gcc_3.4.0.bb
parentd59c59b5922e1fd3d31c9951df3c23e69b7193f4 (diff)
Gcc 3.4.x:
Bump PR. Set --with-sysroot for the target gcc build, which fixes the "missing syslimits.h" problem. Gcc packaging updates: split out gcov and cpp, package the /lib/cpp symlink, and rename the -c++ and -f77 packages. BKrev: 422f6174mry97gr8W2Ii-XVLw9aRRQ
Diffstat (limited to 'packages/gcc/gcc_3.4.0.bb')
-rw-r--r--packages/gcc/gcc_3.4.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/gcc/gcc_3.4.0.bb b/packages/gcc/gcc_3.4.0.bb
index e69de29bb2..635c8c3ef4 100644
--- a/packages/gcc/gcc_3.4.0.bb
+++ b/packages/gcc/gcc_3.4.0.bb
@@ -0,0 +1,24 @@
+PR = "r4"
+DESCRIPTION = "The GNU cc and gcc C compilers."
+HOMEPAGE = "http://www.gnu.org/software/gcc/"
+SECTION = "devel"
+LICENSE = "GPL"
+MAINTAINER = "Gerald Britton <gbritton@doomcom.org>"
+
+inherit autotools gettext
+
+include gcc-package.inc
+
+SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
+ file://gcc34-reverse-compare.patch;patch=1 \
+ file://gcc34-arm-ldm.patch;patch=1 \
+ file://gcc34-arm-ldm-peephole.patch;patch=1 \
+ file://gcc34-arm-tune.patch;patch=1 \
+ file://gcc-3.4.1-uclibc-100-conf.patch;patch=1 \
+ file://gcc-3.4.1-uclibc-200-locale.patch;patch=1 \
+ file://gcc-3.4.0-arm-lib1asm.patch;patch=1 \
+ file://gcc-3.4.0-arm-nolibfloat.patch;patch=1 \
+ file://gcc-3.4.0-arm-bigendian.patch;patch=1 \
+ file://gcc-3.4.0-arm-bigendian-uclibc.patch;patch=1"
+
+include gcc3-build.inc