summaryrefslogtreecommitdiff
path: root/packages/freeze/freeze.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-26 01:56:54 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-26 01:56:54 +0000
commit0636e261a937973904916973a80cdc139c1a0769 (patch)
treef8b70a36a759e030393d1b7a63827e61707a1c81 /packages/freeze/freeze.bb
parentf00bfb5d43172cceb5855fdf37ca9d01cd53ffe6 (diff)
Support for freezing BBFILES and reading BBFILES from a conf file.
Diffstat (limited to 'packages/freeze/freeze.bb')
-rw-r--r--packages/freeze/freeze.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/packages/freeze/freeze.bb b/packages/freeze/freeze.bb
new file mode 100644
index 0000000000..f65855872f
--- /dev/null
+++ b/packages/freeze/freeze.bb
@@ -0,0 +1,53 @@
+# freeze finds all the bitbake files used by the stuff
+# currently built in ${TMPDIR}/work and writes those
+# files into frozen-bbfiles.conf, then it writes the
+# directories containing the files into frozen-packages.conf
+#
+# The two files define (just) the BBFILES variable.
+#
+# The path names in the BBFILES variable are of the form:
+#
+# ${PKGDIR}/packages/directory/bbfile.bb
+# ${PKGDIR}/packages/directory/*.bb
+#
+# as appropriate, directory is the sub-directory of 'packages'.
+#
+DESCRIPTION = "Freeze the bitbake files in the build"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "console/networking"
+PRIORITY = "optional"
+LICENSE = "MIT"
+PR = "r0"
+
+INHIBIT_DEFAULT_DEPS = "1"
+PATCH_DEPENDS = ""
+ALLOW_EMPTY = 1
+PACKAGES = ""
+
+SRC_URI = "file://freeze"
+
+do_configure() {
+}
+do_compile() {
+}
+do_install() {
+}
+do_stage() {
+}
+
+do_build[nostamp] = 1
+do_build() {
+ # export FROZEN_DIR=<place to write conf files>
+ # export PACKAGE_DIR=<location of openembedded package source>
+ # freeze {directories}
+ set -x
+ if test -d "${PKGDIR}/packages"
+ then
+ FROZEN_DIR="${FROZEN_DIR}" DISTRO="${DISTRO}" \
+ sh "${WORKDIR}/freeze" "${TMPDIR}/work"
+ else
+ oenote "\$PKGDIR/packages ($PKGDIR/packages) not found"
+ oefatal "\$PKGDIR must be defined for freeze to work"
+ fi
+ set +x
+}