summaryrefslogtreecommitdiff
path: root/packages/freesmartphone/illume-theme-freesmartphone_git.bb
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2008-08-08 22:01:58 +0000
committerPhilip Balister <philip@balister.org>2008-08-08 22:01:58 +0000
commite9938336c173acad89726fa60605abba7c23d57f (patch)
tree2f9ec804e06669659653a1c8049639f4b6c31b7e /packages/freesmartphone/illume-theme-freesmartphone_git.bb
parent1f651e7bfd7409c8db96d530b74b31af2a79cf15 (diff)
parentda481e02805d3a9ec6e4cd70b6cbeb76d0af6fdb (diff)
merge of '05dd48c35e7fc8bd8ec725a975682953f4e2eb8b'
and 'e5d51ef06db323f64e81b4277041a3eb479eda1b'
Diffstat (limited to 'packages/freesmartphone/illume-theme-freesmartphone_git.bb')
-rw-r--r--packages/freesmartphone/illume-theme-freesmartphone_git.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/packages/freesmartphone/illume-theme-freesmartphone_git.bb b/packages/freesmartphone/illume-theme-freesmartphone_git.bb
index 2d881214a0..3beffce09e 100644
--- a/packages/freesmartphone/illume-theme-freesmartphone_git.bb
+++ b/packages/freesmartphone/illume-theme-freesmartphone_git.bb
@@ -2,11 +2,16 @@ DESCRIPTION = "Illume theme for the freesmartphone.org project"
HOMEPAGE = "http://illume.projects.openmoko.org/"
LICENSE = "MIT/BSD"
PV = "0.0+gitr${SRCREV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "${FREESMARTPHONE_GIT}/artwork.git;protocol=git;branch=master"
S = "${WORKDIR}/git/illume"
+do_compile() {
+ cd illume && ./build.sh && cd ..
+ cd illume_init && ./build.sh && cd ..
+}
+
do_install() {
install -d ${D}${sysconfdir}/enlightenment
install -d ${D}${datadir}/enlightenment/data/themes/
@@ -15,8 +20,8 @@ do_install() {
# Make illume the default profile
echo 'E_PROFILE="-profile illume"' > ${D}${sysconfdir}/enlightenment/default_profile
- install -m 0644 ${S}/illume.edj ${D}${datadir}/enlightenment/data/themes/
- install -m 0644 ${S}/illume_init.edj ${D}${datadir}/enlightenment/data/init/
+ install -m 0644 ${S}/illume/illume.edj ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/illume_init/illume_init.edj ${D}${datadir}/enlightenment/data/init/
}
RPROVIDES_${PN} = "illume-theme"