summaryrefslogtreecommitdiff
path: root/packages/esmart
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-08 16:44:41 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-08 16:44:41 +0000
commitf0b70c2b466aac9bcf1026f87ec3baf7e7dc0c5e (patch)
tree449c3e5dcd34e8ec867a622ec0213ee9bd92c83c /packages/esmart
parent9707ef90ba9f1bdb4d9292bf4c241bf0c9716217 (diff)
EFL Update, Part II:
- epeg - epsilon - esmart
Diffstat (limited to 'packages/esmart')
-rw-r--r--packages/esmart/.mtn2git_empty0
-rw-r--r--packages/esmart/esmart_0.9.0.004.bb29
-rw-r--r--packages/esmart/files/.mtn2git_empty0
-rw-r--r--packages/esmart/files/compile-fix.patch16
4 files changed, 45 insertions, 0 deletions
diff --git a/packages/esmart/.mtn2git_empty b/packages/esmart/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/esmart/.mtn2git_empty
diff --git a/packages/esmart/esmart_0.9.0.004.bb b/packages/esmart/esmart_0.9.0.004.bb
new file mode 100644
index 0000000000..582090643a
--- /dev/null
+++ b/packages/esmart/esmart_0.9.0.004.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "ESmart is a collection of smart Evas objects"
+SECTION = "e/libs"
+LICENSE = "MIT"
+DEPENDS = "eet evas-x11 ecore-x11 epsilon embryo imlib2 jpeg libtool"
+HOMEPAGE = "http://www.enlightenment.org"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+
+SRC_URI = "http://enlightenment.freedesktop.org/files/esmart-${PV}.tar.gz \
+ file://compile-fix.patch;patch=1"
+S = "${WORKDIR}/esmart-${PV}"
+
+inherit autotools pkgconfig binconfig
+
+headers = "esmart_container/Esmart_Container.h \
+ esmart_draggies/Esmart_Draggies.h \
+ esmart_file_dialog/Esmart_File_Dialog.h \
+ esmart_textarea/Esmart_Textarea.h \
+ esmart_thumb/Esmart_Thumb.h \
+ esmart_trans_x11/Esmart_Trans_X11.h"
+
+do_stage() {
+ for i in ${headers}; do
+ install -m 0644 ${S}/src/lib/$i ${STAGING_INCDIR}/
+ done
+ oe_libinstall -C src/lib libsmart ${STAGING_LIBDIR}/
+}
+
+PACKAGES = "esmart-dev esmart-doc esmart"
+FILES_${PN}-dev += "${bindir}/esmart-config ${bindir}/esmart"
diff --git a/packages/esmart/files/.mtn2git_empty b/packages/esmart/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/esmart/files/.mtn2git_empty
diff --git a/packages/esmart/files/compile-fix.patch b/packages/esmart/files/compile-fix.patch
new file mode 100644
index 0000000000..08ca835aa7
--- /dev/null
+++ b/packages/esmart/files/compile-fix.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- esmart-0.9.0.004/src/lib/esmart_container/esmart_container.c~compile-fix
++++ esmart-0.9.0.004/src/lib/esmart_container/esmart_container.c
+@@ -30,7 +30,7 @@
+ return _sort_func(o, oo);
+ }
+
+-void esmart_container_sort(Evas_Object *container, int (*func)(Evas_Object *, Evas_Object *$))
++void esmart_container_sort(Evas_Object *container, int (*func)(Evas_Object *, Evas_Object *))
+ {
+ Container *cont;
+