summaryrefslogtreecommitdiff
path: root/packages/epsilon
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-08 16:44:41 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-08 16:44:41 +0000
commitf0b70c2b466aac9bcf1026f87ec3baf7e7dc0c5e (patch)
tree449c3e5dcd34e8ec867a622ec0213ee9bd92c83c /packages/epsilon
parent9707ef90ba9f1bdb4d9292bf4c241bf0c9716217 (diff)
EFL Update, Part II:
- epeg - epsilon - esmart
Diffstat (limited to 'packages/epsilon')
-rw-r--r--packages/epsilon/epsilon_0.3.0.004.bb (renamed from packages/epsilon/epsilon_cvs.bb)15
-rw-r--r--packages/epsilon/files/.mtn2git_empty0
-rw-r--r--packages/epsilon/files/compile-fix.patch15
3 files changed, 25 insertions, 5 deletions
diff --git a/packages/epsilon/epsilon_cvs.bb b/packages/epsilon/epsilon_0.3.0.004.bb
index 02719d605f..74086afd32 100644
--- a/packages/epsilon/epsilon_cvs.bb
+++ b/packages/epsilon/epsilon_0.3.0.004.bb
@@ -6,12 +6,12 @@ To provide the best possible performance Epsilon can even integrate \
with Epeg directly to harness it's speed."
SECTION = "e/libs"
LICENSE = "GPL"
-DEPENDS = "epeg libpng imlib2"
-PV = "${CVSDATE}"
-PR = "r1"
+DEPENDS = "epeg libpng virtual/imlib2"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/libs/epsilon"
-S = "${WORKDIR}/epsilon"
+SRC_URI = "http://enlightenment.freedesktop.org/files/epsilon-${PV}.tar.gz \
+ file://compile-fix.patch;patch=1"
+S = "${WORKDIR}/epsilon-${PV}"
inherit autotools pkgconfig binconfig
@@ -19,3 +19,8 @@ do_stage () {
oe_libinstall -C src/lib libepsilon ${STAGING_LIBDIR}/
install -m 0644 ${S}/src/lib/Epsilon.h ${STAGING_INCDIR}/
}
+
+PACKAGES = "epsilon-examples epsilon-dev epsilon"
+FILES_${PN}-dev += "${bindir}/epsilon-config"
+FILES_epsilon-examples = "${bindir}/epsilon"
+
diff --git a/packages/epsilon/files/.mtn2git_empty b/packages/epsilon/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/epsilon/files/.mtn2git_empty
diff --git a/packages/epsilon/files/compile-fix.patch b/packages/epsilon/files/compile-fix.patch
new file mode 100644
index 0000000000..1c42cc59c4
--- /dev/null
+++ b/packages/epsilon/files/compile-fix.patch
@@ -0,0 +1,15 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- epsilon-0.3.0.004/src/lib/exiftags/exif.c~compile-fix
++++ epsilon-0.3.0.004/src/lib/exiftags/exif.c
+@@ -48,7 +48,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <errno.h>
+-#include <math.h>
+ #include <float.h>
+ #include <ctype.h>
+