summaryrefslogtreecommitdiff
path: root/packages/e17/engage_20060128.bb
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2006-01-30 08:18:38 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-30 08:18:38 +0000
commit56435559deae7a21e210bd654706aef415904fc4 (patch)
tree9fdc9421531049c3ad132b2c71e2cd6d4fc3b237 /packages/e17/engage_20060128.bb
parent9f00cacbccf02db56cb4e134a8dcecb6d13205d9 (diff)
efl, e17: update CVS versions again, fix cpp issues
- evas is left at 20060113 because it changed that day and breaks ecore - cpp and gcc paths are hard-coded to /usr/bin/ to fix some issues with OE's binaries in use with edje
Diffstat (limited to 'packages/e17/engage_20060128.bb')
-rw-r--r--packages/e17/engage_20060128.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/e17/engage_20060128.bb b/packages/e17/engage_20060128.bb
new file mode 100644
index 0000000000..bd925a969c
--- /dev/null
+++ b/packages/e17/engage_20060128.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Engage is the E17 icon dock"
+DEPENDS = "evas-x11 ecore-x11 esmart-x11 imlib2-x11 edje ewl e"
+LICENSE = "MIT"
+SECTION = "e/apps"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+PR = "r2"
+
+SRC_URI = "cvs://anonymous@thinktux.net/root;module=misc/engage;date=${PV} \
+ file://no-local-includes.patch;patch=1"
+S = "${WORKDIR}/engage"
+
+inherit autotools pkgconfig binconfig
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc"
+
+do_prepsources () {
+ make clean distclean || true
+}
+addtask prepsources after do_fetch before do_unpack
+
+FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir} ${sbindir}"
+