summaryrefslogtreecommitdiff
path: root/packages/dsplink/ti-codec-combos_3.16.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/dsplink/ti-codec-combos_3.16.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/dsplink/ti-codec-combos_3.16.bb')
-rw-r--r--packages/dsplink/ti-codec-combos_3.16.bb100
1 files changed, 0 insertions, 100 deletions
diff --git a/packages/dsplink/ti-codec-combos_3.16.bb b/packages/dsplink/ti-codec-combos_3.16.bb
deleted file mode 100644
index 941856d09d..0000000000
--- a/packages/dsplink/ti-codec-combos_3.16.bb
+++ /dev/null
@@ -1,100 +0,0 @@
-DESCRIPTION = "Codec combos for omap3530"
-DEPENDS = "ti-codec-engine"
-LICENCE = "unknown"
-
-require ti-paths.inc
-
-SRC_URI = "http://software-dl.ti.com/sdo/sdo_apps_public_sw/omap3530_dvsdk_combos_tspa/omap3530_dvsdk_combos_tspa-3_16-Linux-x86.bin \
- "
-
-S = "${WORKDIR}/omap3530_dvsdk_combos_3_16"
-
-# Yes, the xdc stuff still breaks with a '.' in PWD
-PV = "316"
-PR = "r13"
-
-TARGET = "all"
-
-export CE_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine/packages;${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine/cetools"
-
-# Needed for now since makefile in latest package assumes this is set
-export CODEC_INSTALL_DIR="${S}"
-
-# Helper function to run the binary installer and unpack the tar.gz in the same place as it was before - this could be optimised later
-do_accept_license() {
- export HOME="${WORKDIR}"
- chmod +x ${WORKDIR}/omap3530_dvsdk_combos_tspa-3_16-Linux-x86.bin
- ${WORKDIR}/omap3530_dvsdk_combos_tspa-3_16-Linux-x86.bin --mode silent --prefix ${S}_install
- cd "${S}_install"
- tar -xzvf omap3530_dvsdk_combos_tspa_3_16.tar.gz
- if [ -d ${S} ] ; then
- rm -rf ${S}
- fi
- mv omap3530_dvsdk_combos_tspa_3_16 ${S}
-}
-
-addtask accept_license after do_unpack before do_configure
-
-do_compile() {
-
- # For now, remove the reference to Rules.make and swap prod for eval, since this only has eval libs included
- sed -i \
- -e '/Rules.make/d' \
- -e 's:$(FC_INSTALL_DIR)/packages;::g' \
- -e 's:$(XDAIS_INSTALL_DIR)/packages;::g' \
- -e 's:$(FC_INSTALL_DIR)/fctools/packages;::g' \
- -e 's:$(BIOSUTILS_INSTALL_DIR)/packages;::g' \
- -e 's:$(CMEM_INSTALL_DIR)/packages;::g' \
- -e 's:$(LINK_INSTALL_DIR)/packages;::g' \
- -e 's:$(LPM_INSTALL_DIR)/packages;::g' \
- -e s:prod:eval:g \
- ${S}/Makefile
-
- # Fix-up config.bld to swap out hardcoded references to tools paths
- sed -i -e s:/opt/dmsw/cg6x_6_0_16:${TITOOLSDIR}/${TICGTOOLSDIR}:g \
- ${S}/config.bld
-
- # Add make target to allow package to be prepared for building (normally this package is a binary release)
- echo "makebuildable:
- \$(XDC) .make -PR .
-" >> ${S}/Makefile
-
- oe_runmake makebuildable
- oe_runmake clean
- oe_runmake
-}
-
-do_install () {
- echo oe_runmake install
-
- install -d ${D}/${datadir}/ti-codec-combos
-
- cd ${S}
-
- # grab the server executables
- for i in $(find . -name "*.x64P") ; do
- install ${i} ${D}/${datadir}/ti-codec-combos
- done
-
- # copy the generated data sheets as well for reference
- #for i in $(find . -name "*.DataSheet.*") ; do
-
- # infact, just copy all the html files (including the server datasheets) from the distro
- # - this includes top level html (with codec versions) + some qualiTI codec test reports
- for i in $(find . -name "*.html") ; do
- install ${i} ${D}/${datadir}/ti-codec-combos
- done
-
-}
-
-do_stage () {
- install -d ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-combos
- cp -pPrf ${S}/* ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-combos
-}
-
-FILES_ti-codec-combos = "${datadir}/ti-codec-combos/*"
-
-INHIBIT_PACKAGE_STRIP = "1"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-