summaryrefslogtreecommitdiff
path: root/packages/device-mapper/device-mapper_1.01.04.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-08-27 10:24:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-27 10:24:32 +0000
commitaa444ace286f8a0686d17ee42efcf2e61fcfdab0 (patch)
tree07c7cb33ab63ea09768eb92056964f6f2f90a8d6 /packages/device-mapper/device-mapper_1.01.04.bb
parentc9310255bcef16e59907891f5ef65a897bd52297 (diff)
Device-mapper: Add it, courtesy Dan J Williams
Diffstat (limited to 'packages/device-mapper/device-mapper_1.01.04.bb')
-rw-r--r--packages/device-mapper/device-mapper_1.01.04.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/device-mapper/device-mapper_1.01.04.bb b/packages/device-mapper/device-mapper_1.01.04.bb
new file mode 100644
index 0000000000..64d66b965e
--- /dev/null
+++ b/packages/device-mapper/device-mapper_1.01.04.bb
@@ -0,0 +1,28 @@
+SECTION = "libs"
+DESCRIPTION = "The Device-mapper is a new component of the linux kernel \
+that supports logical volume management. It is required by LVM2 and EVMS. \
+The original LVM (included in stock 2.4 kernels) does not use it."
+MAINTAINER = "Dan Williams <dan.j.williams@gmail.com>"
+LICENSE = "GPL"
+PR = "r2"
+
+S = "${WORKDIR}/${PN}.${PV}"
+
+SRC_URI = "ftp://sources.redhat.com/pub/dm/device-mapper.${PV}.tgz \
+ file://devmap-mknod-busybox.patch;patch=1"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "devmap_mknod.sh"
+INITSCRIPT_PARAMS = "defaults"
+
+do_stage () {
+ install -m 0644 lib/libdevmapper.h ${STAGING_INCDIR} || die "failed to install libdevmapper.h"
+ oe_libinstall -a -so -C lib/ioctl libdevmapper ${STAGING_LIBDIR}
+}
+
+do_install() {
+ autotools_do_install
+ oe_runmake install_static_lib
+ install -D -m 755 ${S}/scripts/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
+}