summaryrefslogtreecommitdiff
path: root/packages/busybox
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2004-12-26 00:47:19 +0000
committerRod Whitby <rod@whitby.id.au>2004-12-26 00:47:19 +0000
commit60501ecd3fe71fd3821489dd749238678e2bdd98 (patch)
treefaeb48696042f353e6a13eafdae4046cdaa15f69 /packages/busybox
parent01c0bc2e7cb8e6ddf63f513181210762335208d0 (diff)
Merge bk://nslu2-linux@nslu2-linux.bkbits.net/openembedded
into home.(none):/home/slug/openembedded 2004/12/26 11:16:53+10:30 (none)!rwhitby Unslung 3.15-alpha, with an improved switchbox, and confirmation dialogs for maintenance mode BKrev: 41ce0a17xiLVTaQgH7jrrEudgkOddw
Diffstat (limited to 'packages/busybox')
-rw-r--r--packages/busybox/slingbox-1.00/defconfig334
-rw-r--r--packages/busybox/switchbox-1.00/defconfig21
-rw-r--r--packages/busybox/switchbox-1.00/linuxrc26
-rw-r--r--packages/busybox/switchbox_1.00.bb4
4 files changed, 359 insertions, 26 deletions
diff --git a/packages/busybox/slingbox-1.00/defconfig b/packages/busybox/slingbox-1.00/defconfig
index e69de29bb2..54b8f05ed4 100644
--- a/packages/busybox/slingbox-1.00/defconfig
+++ b/packages/busybox/slingbox-1.00/defconfig
@@ -0,0 +1,334 @@
+#
+# Automatically generated make config: don't edit
+#
+HAVE_DOT_CONFIG=y
+
+#
+# General Configuration
+#
+# CONFIG_FEATURE_BUFFERS_USE_MALLOC is not set
+CONFIG_FEATURE_BUFFERS_GO_ON_STACK=y
+# CONFIG_FEATURE_BUFFERS_GO_IN_BSS is not set
+CONFIG_FEATURE_VERBOSE_USAGE=y
+# CONFIG_FEATURE_INSTALLER is not set
+# CONFIG_LOCALE_SUPPORT is not set
+# CONFIG_FEATURE_DEVFS is not set
+# CONFIG_FEATURE_DEVPTS is not set
+# CONFIG_FEATURE_CLEAN_UP is not set
+# CONFIG_FEATURE_SUID is not set
+# CONFIG_SELINUX is not set
+
+#
+# Build Options
+#
+# CONFIG_STATIC is not set
+CONFIG_LFS=y
+USING_CROSS_COMPILER=y
+CROSS_COMPILER_PREFIX="armv5b-softfloat-linux-"
+EXTRA_CFLAGS_OPTIONS=""
+
+#
+# Installation Options
+#
+CONFIG_INSTALL_NO_USR=y
+PREFIX="/"
+
+#
+# Archival Utilities
+#
+# CONFIG_AR is not set
+CONFIG_BUNZIP2=y
+# CONFIG_CPIO is not set
+# CONFIG_DPKG is not set
+# CONFIG_DPKG_DEB is not set
+CONFIG_GUNZIP=y
+CONFIG_FEATURE_GUNZIP_UNCOMPRESS=y
+CONFIG_GZIP=y
+# CONFIG_RPM2CPIO is not set
+# CONFIG_RPM is not set
+CONFIG_TAR=y
+CONFIG_FEATURE_TAR_CREATE=y
+CONFIG_FEATURE_TAR_BZIP2=y
+# CONFIG_FEATURE_TAR_FROM is not set
+CONFIG_FEATURE_TAR_GZIP=y
+CONFIG_FEATURE_TAR_COMPRESS=y
+CONFIG_FEATURE_TAR_OLDGNU_COMPATABILITY=y
+CONFIG_FEATURE_TAR_GNU_EXTENSIONS=y
+CONFIG_FEATURE_TAR_LONG_OPTIONS=y
+CONFIG_UNCOMPRESS=y
+CONFIG_UNZIP=y
+
+#
+# Common options for cpio and tar
+#
+# CONFIG_FEATURE_UNARCHIVE_TAPE is not set
+
+#
+# Coreutils
+#
+# CONFIG_BASENAME is not set
+# CONFIG_CAL is not set
+# CONFIG_CAT is not set
+# CONFIG_CHGRP is not set
+# CONFIG_CHMOD is not set
+# CONFIG_CHOWN is not set
+CONFIG_CHROOT=y
+# CONFIG_CMP is not set
+# CONFIG_CP is not set
+# CONFIG_CUT is not set
+# CONFIG_DATE is not set
+# CONFIG_DD is not set
+# CONFIG_DF is not set
+CONFIG_DIRNAME=y
+# CONFIG_DOS2UNIX is not set
+CONFIG_DU=y
+# CONFIG_ECHO is not set
+# CONFIG_ENV is not set
+CONFIG_EXPR=y
+# CONFIG_FALSE is not set
+# CONFIG_FOLD is not set
+CONFIG_HEAD=y
+CONFIG_FEATURE_FANCY_HEAD=y
+# CONFIG_HOSTID is not set
+# CONFIG_ID is not set
+# CONFIG_INSTALL is not set
+# CONFIG_LENGTH is not set
+# CONFIG_LN is not set
+# CONFIG_LOGNAME is not set
+# CONFIG_LS is not set
+CONFIG_MD5SUM=y
+# CONFIG_MKDIR is not set
+# CONFIG_MKFIFO is not set
+# CONFIG_MKNOD is not set
+# CONFIG_MV is not set
+# CONFIG_OD is not set
+# CONFIG_PRINTF is not set
+# CONFIG_PWD is not set
+# CONFIG_REALPATH is not set
+# CONFIG_RM is not set
+CONFIG_RMDIR=y
+# CONFIG_SEQ is not set
+# CONFIG_SHA1SUM is not set
+# CONFIG_SLEEP is not set
+CONFIG_SORT=y
+# CONFIG_STTY is not set
+# CONFIG_SYNC is not set
+CONFIG_TAIL=y
+CONFIG_FEATURE_FANCY_TAIL=y
+# CONFIG_TEE is not set
+# CONFIG_TEST is not set
+# CONFIG_TOUCH is not set
+# CONFIG_TR is not set
+# CONFIG_TRUE is not set
+# CONFIG_TTY is not set
+# CONFIG_UNAME is not set
+CONFIG_UNIQ=y
+# CONFIG_USLEEP is not set
+# CONFIG_UUDECODE is not set
+# CONFIG_UUENCODE is not set
+# CONFIG_WATCH is not set
+# CONFIG_WC is not set
+# CONFIG_WHO is not set
+# CONFIG_WHOAMI is not set
+# CONFIG_YES is not set
+
+#
+# Common options for md5sum, sha1sum
+#
+CONFIG_FEATURE_MD5_SHA1_SUM_CHECK=y
+
+#
+# Console Utilities
+#
+# CONFIG_CHVT is not set
+# CONFIG_CLEAR is not set
+# CONFIG_DEALLOCVT is not set
+# CONFIG_DUMPKMAP is not set
+# CONFIG_LOADFONT is not set
+# CONFIG_LOADKMAP is not set
+# CONFIG_OPENVT is not set
+# CONFIG_RESET is not set
+# CONFIG_SETKEYCODES is not set
+
+#
+# Debian Utilities
+#
+# CONFIG_MKTEMP is not set
+# CONFIG_PIPE_PROGRESS is not set
+# CONFIG_READLINK is not set
+# CONFIG_RUN_PARTS is not set
+# CONFIG_START_STOP_DAEMON is not set
+# CONFIG_WHICH is not set
+
+#
+# Editors
+#
+CONFIG_AWK=y
+# CONFIG_PATCH is not set
+CONFIG_SED=y
+# CONFIG_VI is not set
+
+#
+# Finding Utilities
+#
+# CONFIG_FIND is not set
+CONFIG_GREP=y
+CONFIG_FEATURE_GREP_EGREP_ALIAS=y
+# CONFIG_FEATURE_GREP_CONTEXT is not set
+# CONFIG_XARGS is not set
+
+#
+# Init Utilities
+#
+# CONFIG_INIT is not set
+# CONFIG_HALT is not set
+# CONFIG_POWEROFF is not set
+# CONFIG_REBOOT is not set
+# CONFIG_MESG is not set
+
+#
+# Login/Password Management Utilities
+#
+# CONFIG_USE_BB_PWD_GRP is not set
+# CONFIG_ADDGROUP is not set
+# CONFIG_DELGROUP is not set
+# CONFIG_ADDUSER is not set
+# CONFIG_DELUSER is not set
+# CONFIG_GETTY is not set
+# CONFIG_LOGIN is not set
+# CONFIG_PASSWD is not set
+# CONFIG_SU is not set
+# CONFIG_SULOGIN is not set
+# CONFIG_VLOCK is not set
+
+#
+# Miscellaneous Utilities
+#
+# CONFIG_ADJTIMEX is not set
+# CONFIG_CROND is not set
+# CONFIG_CRONTAB is not set
+# CONFIG_DC is not set
+# CONFIG_DEVFSD is not set
+# CONFIG_LAST is not set
+# CONFIG_HDPARM is not set
+# CONFIG_MAKEDEVS is not set
+# CONFIG_MT is not set
+# CONFIG_RX is not set
+CONFIG_STRINGS=y
+# CONFIG_TIME is not set
+# CONFIG_WATCHDOG is not set
+
+#
+# Linux Module Utilities
+#
+# CONFIG_INSMOD is not set
+# CONFIG_LSMOD is not set
+# CONFIG_MODPROBE is not set
+# CONFIG_RMMOD is not set
+
+#
+# Networking Utilities
+#
+# CONFIG_FEATURE_IPV6 is not set
+# CONFIG_ARPING is not set
+# CONFIG_FTPGET is not set
+# CONFIG_FTPPUT is not set
+# CONFIG_HOSTNAME is not set
+# CONFIG_HTTPD is not set
+# CONFIG_IFCONFIG is not set
+# CONFIG_IFUPDOWN is not set
+# CONFIG_INETD is not set
+# CONFIG_IP is not set
+# CONFIG_IPCALC is not set
+# CONFIG_IPADDR is not set
+# CONFIG_IPLINK is not set
+# CONFIG_IPROUTE is not set
+# CONFIG_IPTUNNEL is not set
+# CONFIG_NAMEIF is not set
+CONFIG_NC=y
+# CONFIG_NETSTAT is not set
+# CONFIG_NSLOOKUP is not set
+# CONFIG_PING is not set
+# CONFIG_ROUTE is not set
+# CONFIG_TELNET is not set
+# CONFIG_TELNETD is not set
+# CONFIG_TFTP is not set
+# CONFIG_TRACEROUTE is not set
+# CONFIG_VCONFIG is not set
+# CONFIG_WGET is not set
+# CONFIG_FEATURE_WGET_STATUSBAR is not set
+# CONFIG_FEATURE_WGET_AUTHENTICATION is not set
+# CONFIG_FEATURE_WGET_IP6_LITERAL is not set
+
+#
+# udhcp Server/Client
+#
+# CONFIG_UDHCPD is not set
+# CONFIG_UDHCPC is not set
+
+#
+# Process Utilities
+#
+CONFIG_FREE=y
+# CONFIG_KILL is not set
+# CONFIG_PIDOF is not set
+# CONFIG_PS is not set
+# CONFIG_RENICE is not set
+# CONFIG_TOP is not set
+# CONFIG_UPTIME is not set
+# CONFIG_SYSCTL is not set
+
+#
+# Another Bourne-like Shell
+#
+# CONFIG_FEATURE_SH_IS_ASH is not set
+# CONFIG_FEATURE_SH_IS_HUSH is not set
+# CONFIG_FEATURE_SH_IS_LASH is not set
+# CONFIG_FEATURE_SH_IS_MSH is not set
+CONFIG_FEATURE_SH_IS_NONE=y
+# CONFIG_ASH is not set
+# CONFIG_HUSH is not set
+# CONFIG_LASH is not set
+# CONFIG_MSH is not set
+
+#
+# System Logging Utilities
+#
+# CONFIG_SYSLOGD is not set
+# CONFIG_LOGGER is not set
+
+#
+# Linux System Utilities
+#
+# CONFIG_DMESG is not set
+# CONFIG_FBSET is not set
+# CONFIG_FDFLUSH is not set
+# CONFIG_FDFORMAT is not set
+# CONFIG_FDISK is not set
+CONFIG_FREERAMDISK=y
+# CONFIG_FSCK_MINIX is not set
+# CONFIG_MKFS_MINIX is not set
+# CONFIG_GETOPT is not set
+CONFIG_HEXDUMP=y
+# CONFIG_HWCLOCK is not set
+# CONFIG_LOSETUP is not set
+# CONFIG_MKSWAP is not set
+# CONFIG_MORE is not set
+CONFIG_PIVOT_ROOT=y
+# CONFIG_RDATE is not set
+# CONFIG_SWAPONOFF is not set
+CONFIG_MOUNT=y
+CONFIG_NFSMOUNT=y
+CONFIG_UMOUNT=y
+# CONFIG_FEATURE_MOUNT_FORCE is not set
+
+#
+# Common options for mount/umount
+#
+CONFIG_FEATURE_MOUNT_LOOP=y
+# CONFIG_FEATURE_MTAB_SUPPORT is not set
+
+#
+# Debugging Options
+#
+# CONFIG_DEBUG is not set
diff --git a/packages/busybox/switchbox-1.00/defconfig b/packages/busybox/switchbox-1.00/defconfig
index a757d731cd..d2587d30ce 100644
--- a/packages/busybox/switchbox-1.00/defconfig
+++ b/packages/busybox/switchbox-1.00/defconfig
@@ -95,19 +95,19 @@ CONFIG_MD5SUM=y
CONFIG_MKDIR=y
# CONFIG_MKFIFO is not set
# CONFIG_MKNOD is not set
-# CONFIG_MV is not set
+CONFIG_MV=y
# CONFIG_OD is not set
# CONFIG_PRINTF is not set
-# CONFIG_PWD is not set
+CONFIG_PWD=y
# CONFIG_REALPATH is not set
CONFIG_RM=y
-# CONFIG_RMDIR is not set
+CONFIG_RMDIR=y
# CONFIG_SEQ is not set
# CONFIG_SHA1SUM is not set
CONFIG_SLEEP=y
# CONFIG_SORT is not set
# CONFIG_STTY is not set
-# CONFIG_SYNC is not set
+CONFIG_SYNC=y
# CONFIG_TAIL is not set
# CONFIG_TEE is not set
CONFIG_TEST=y
@@ -168,7 +168,7 @@ CONFIG_FEATURE_VI_YANKMARK=y
# Finding Utilities
#
# CONFIG_FIND is not set
-# CONFIG_GREP is not set
+CONFIG_GREP=y
# CONFIG_XARGS is not set
#
@@ -224,7 +224,7 @@ CONFIG_FEATURE_2_4_MODULES=y
CONFIG_FEATURE_2_6_MODULES=y
# CONFIG_LSMOD is not set
# CONFIG_MODPROBE is not set
-# CONFIG_RMMOD is not set
+CONFIG_RMMOD=y
#
# Networking Utilities
@@ -270,10 +270,11 @@ CONFIG_FEATURE_WGET_STATUSBAR=y
#
# Process Utilities
#
-# CONFIG_FREE is not set
-# CONFIG_KILL is not set
+CONFIG_FREE=y
+CONFIG_KILL=y
+CONFIG_KILLALL=y
# CONFIG_PIDOF is not set
-# CONFIG_PS is not set
+CONFIG_PS=y
# CONFIG_RENICE is not set
# CONFIG_TOP is not set
# CONFIG_UPTIME is not set
@@ -328,7 +329,7 @@ CONFIG_FEATURE_COMMAND_TAB_COMPLETION=y
# CONFIG_FDFORMAT is not set
# CONFIG_FDISK is not set
# FDISK_SUPPORT_LARGE_DISKS is not set
-# CONFIG_FREERAMDISK is not set
+CONFIG_FREERAMDISK=y
# CONFIG_FSCK_MINIX is not set
# CONFIG_MKFS_MINIX is not set
# CONFIG_GETOPT is not set
diff --git a/packages/busybox/switchbox-1.00/linuxrc b/packages/busybox/switchbox-1.00/linuxrc
index 6361636b67..82e8c1139b 100644
--- a/packages/busybox/switchbox-1.00/linuxrc
+++ b/packages/busybox/switchbox-1.00/linuxrc
@@ -11,30 +11,28 @@ if [ -z "$mounted" ] && /bin/mount -rt jffs2 /dev/mtdblock4 /mnt/tmpmnt ; then
if [ -f /mnt/tmpmnt/.recovery ] ; then
mounted=
elif [ -f /mnt/tmpmnt/.ramdisk ] ; then
- /bin/dd if=/dev/zero of=/dev/ram1 bs=1k count=10k
+ /bin/dd if=/dev/zero of=/dev/ram1 bs=1k count=12k
/bin/mkdir /lib
/bin/ln -s /mnt/tmpmnt/lib/* /lib
/bin/mkdir /usr/bin
/bin/ln -s /mnt/tmpmnt/usr/bin/mke2fs /usr/bin
/bin/ln -s /mnt/tmpmnt/usr/bin/find /usr/bin
/bin/ln -s /mnt/tmpmnt/usr/bin/cpio /usr/bin
- /usr/bin/mke2fs -m 0 /dev/ram1 10240
- /bin/mkdir /mnt/tmpmnt2
- /bin/mount -t ext2 /dev/ram1 /mnt/tmpmnt2
- ( cd /mnt/tmpmnt ; /usr/bin/find . -print0 -mount | /usr/bin/cpio -p -0 -d -m -u /mnt/tmpmnt2 )
- /bin/cp /mnt/tmpmnt2/home/httpd/html/Management/upgrade.cgi /mnt/tmpmnt2/home/httpd/html/Management/upgrade-real.cgi
- /bin/echo "#!/bin/sh" > /mnt/tmpmnt2/home/httpd/html/Management/upgrade.cgi
- /bin/echo >> /mnt/tmpmnt2/home/httpd/html/Management/upgrade.cgi
+ /usr/bin/mke2fs -m 0 /dev/ram1 12288
+ /bin/mount -t ext2 /dev/ram1 /mnt/repair
+ ( cd /mnt/tmpmnt ; /usr/bin/find . -print0 -mount | /usr/bin/cpio -p -0 -d -m -u /mnt/repair )
+ /bin/cp /mnt/repair/home/httpd/html/Management/upgrade.cgi /mnt/repair/home/httpd/html/Management/upgrade-real.cgi
+ /bin/echo "#!/bin/sh" > /mnt/repair/home/httpd/html/Management/upgrade.cgi
+ /bin/echo >> /mnt/repair/home/httpd/html/Management/upgrade.cgi
/bin/echo "/bin/mount -t ramfs none /upload -o size=8196 2>/dev/null" \
- >> /mnt/tmpmnt2/home/httpd/html/Management/upgrade.cgi
+ >> /mnt/repair/home/httpd/html/Management/upgrade.cgi
/bin/echo "/bin/dd if=/dev/zero of=/upload/free-ram bs=1k count=8k 2>/dev/null" \
- >> /mnt/tmpmnt2/home/httpd/html/Management/upgrade.cgi
+ >> /mnt/repair/home/httpd/html/Management/upgrade.cgi
/bin/echo "/bin/umount /upload 2>/dev/null" \
- >> /mnt/tmpmnt2/home/httpd/html/Management/upgrade.cgi
+ >> /mnt/repair/home/httpd/html/Management/upgrade.cgi
/bin/echo "exec /home/httpd/html/Management/upgrade-real.cgi" \
- >> /mnt/tmpmnt2/home/httpd/html/Management/upgrade.cgi
- /bin/umount /mnt/tmpmnt2
- /bin/rm -rf /mnt/tmpmnt2
+ >> /mnt/repair/home/httpd/html/Management/upgrade.cgi
+ /bin/umount /mnt/repair
/bin/echo "Root filesystem will be mounted from /dev/ram1 (a copy of /dev/mtdblock4) ..."
/bin/echo "0x0101" > /proc/sys/kernel/real-root-dev
mounted=/mnt/tmpmnt
diff --git a/packages/busybox/switchbox_1.00.bb b/packages/busybox/switchbox_1.00.bb
index 026a6ab299..91ca91f348 100644
--- a/packages/busybox/switchbox_1.00.bb
+++ b/packages/busybox/switchbox_1.00.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.busybox.net"
LICENSE = "GPL"
SECTION = "base"
PRIORITY = "required"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://defconfig \
@@ -47,5 +47,5 @@ do_compile () {
do_install () {
oe_runmake 'PREFIX=${D}' install
install -m 0755 ${WORKDIR}/linuxrc ${D}/
- mkdir -p ${D}/proc ${D}/mnt/tmpmnt
+ mkdir -p ${D}/proc ${D}/mnt/tmpmnt ${D}/mnt/repair
}