summaryrefslogtreecommitdiff
path: root/packages/busybox
diff options
context:
space:
mode:
authorDavid Karlstrom <daka@thg.se>2005-07-25 03:08:38 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-25 03:08:38 +0000
commit1d8513fe56e71891216c4d37ab76a9967fc70032 (patch)
tree79026b0d4da49b445748056b27f75214ebdccbb5 /packages/busybox
parent89f67549b36651ad5aed97d4a877bb145f472d1d (diff)
Check for existance of 'test' before assuming it isn't there and alias test to 'busybox test'.
When building a rootfs the previos implementation cased a few serious (non-fatal) errors showing up with tinderbox.
Diffstat (limited to 'packages/busybox')
-rw-r--r--packages/busybox/busybox_1.00.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/packages/busybox/busybox_1.00.bb b/packages/busybox/busybox_1.00.bb
index 056213c82c..f6d03fe69f 100644
--- a/packages/busybox/busybox_1.00.bb
+++ b/packages/busybox/busybox_1.00.bb
@@ -10,7 +10,7 @@ HOMEPAGE = "http://www.busybox.net"
LICENSE = "GPL"
SECTION = "base"
PRIORITY = "required"
-PR = "r28"
+PR = "r29"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://add-getkey-applet.patch;patch=1 \
@@ -132,7 +132,7 @@ pkg_postinst_${PN} () {
# If we are not making an image we create links for the utilities that doesn't exist
# so the update-alternatives script will get the utilities it needs
# (update-alternatives have no problem replacing links later anyway)
- alias test='busybox test'
+ test -n 2> /dev/null || alias test='busybox test'
if test "x$D" = "x"; then while read link; do if test ! -h "$link"; then case "$link" in /*/*/*) to="../../bin/busybox";; /bin/*) to="busybox";; /*/*) to="../bin/busybox";; esac; busybox ln -s $to $link; fi; done </etc/busybox.links; fi
# This adds the links, remember that this has to work when building an image too, hence the $D