summaryrefslogtreecommitdiff
path: root/packages/binutils/binutils-cross_2.17.50.0.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-05-14 18:13:55 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-14 18:13:55 +0000
commit71e7ac0d631082111da2c1962c8530e71acd2595 (patch)
tree8cc784782191d8c8fd3822e98f2385c657f0d5e6 /packages/binutils/binutils-cross_2.17.50.0.1.bb
parente7bfc136e4b50cc0aca22482e4153b09c53ffe2f (diff)
binutils(-cross): add 2.17.50.0.1 snapshot
from the changelog: 1. Update from binutils 2006 0427. 2. Fix an objcopy regression (PR 2593). 3. Reduce ar memory usage (PR 2467). 4. Allow application specific ELF sections (PR 2537). 5. Fix an i386 TLS linker bug (PR 2513). 6. Speed up ia64 linker by 1300X in some cases (PR 2442). 7. Check illegal immediate register operand in i386 assembler (PR 2533). 8. Fix a strings bug (PR 2584). 9. Better handle corrupted ELF files (PR 2257). 10. Fix a MIPS linker bug (PR 2267).
Diffstat (limited to 'packages/binutils/binutils-cross_2.17.50.0.1.bb')
-rw-r--r--packages/binutils/binutils-cross_2.17.50.0.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/binutils/binutils-cross_2.17.50.0.1.bb b/packages/binutils/binutils-cross_2.17.50.0.1.bb
new file mode 100644
index 0000000000..7e165271d7
--- /dev/null
+++ b/packages/binutils/binutils-cross_2.17.50.0.1.bb
@@ -0,0 +1,32 @@
+SECTION = "devel"
+include binutils_${PV}.bb
+inherit cross
+DEPENDS += "flex-native bison-native"
+PROVIDES = "virtual/${TARGET_PREFIX}binutils"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/binutils-${PV}"
+PACKAGES = ""
+EXTRA_OECONF = "--with-sysroot=${CROSS_DIR}/${TARGET_SYS} \
+ --program-prefix=${TARGET_PREFIX}"
+
+do_stage () {
+ oe_runmake install
+
+ # We don't really need these, so we'll remove them...
+ rm -rf ${CROSS_DIR}/lib/ldscripts
+ rm -rf ${CROSS_DIR}/share/info
+ rm -rf ${CROSS_DIR}/share/locale
+ rm -rf ${CROSS_DIR}/share/man
+ rmdir ${CROSS_DIR}/share || :
+ rmdir ${CROSS_DIR}/${libdir}/gcc-lib || :
+ rmdir ${CROSS_DIR}/${libdir} || :
+ rmdir ${CROSS_DIR}/${prefix} || :
+
+ # We want to move this into the target specific location
+ mkdir -p ${CROSS_DIR}/${TARGET_SYS}/lib
+ mv -f ${CROSS_DIR}/lib/libiberty.a ${CROSS_DIR}/${TARGET_SYS}/lib
+ rmdir ${CROSS_DIR}/lib || :
+}
+
+do_install () {
+ :
+}