summaryrefslogtreecommitdiff
path: root/packages/binutils/binutils-2.17/501-avr32-fix-pool-alignment.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-02-04 11:44:10 +0000
committerKoen Kooi <koen@openembedded.org>2008-02-04 11:44:10 +0000
commit9689c616200a54b57096d8ec684a0212a40bc05d (patch)
treecadc8134e2d9feef46f9a44ce58e093fd2179e40 /packages/binutils/binutils-2.17/501-avr32-fix-pool-alignment.patch
parent2aef2ca43fe188f0c8c1209e535f0ca7a20b7809 (diff)
binutils* 2.17: fix avr32
Diffstat (limited to 'packages/binutils/binutils-2.17/501-avr32-fix-pool-alignment.patch')
-rw-r--r--packages/binutils/binutils-2.17/501-avr32-fix-pool-alignment.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/binutils/binutils-2.17/501-avr32-fix-pool-alignment.patch b/packages/binutils/binutils-2.17/501-avr32-fix-pool-alignment.patch
new file mode 100644
index 0000000000..bd519a1e69
--- /dev/null
+++ b/packages/binutils/binutils-2.17/501-avr32-fix-pool-alignment.patch
@@ -0,0 +1,26 @@
+Index: a/gas/config/tc-avr32.c
+===================================================================
+--- a/gas/config/tc-avr32.c (revision 31496)
++++ b/gas/config/tc-avr32.c (revision 32014)
+@@ -3092,6 +3092,8 @@
+
+ /* Make sure the constant pool is properly aligned */
+ frag_align_code(2, 0);
++ if (bfd_get_section_alignment(stdoutput, pool->section) < 2)
++ bfd_set_section_alignment(stdoutput, pool->section, 2);
+
+ /* Assume none of the entries are discarded, and that we need the
+ maximum amount of alignment. But we're not going to allocate
+Index: a/bfd/configure.in
+===================================================================
+--- a/bfd/configure.in (revision 31496)
++++ b/bfd/configure.in (revision 32014)
+@@ -8,7 +8,7 @@
+ AC_CANONICAL_TARGET
+ AC_ISC_POSIX
+
+-AM_INIT_AUTOMAKE(bfd, 2.17.atmel.1.2.0)
++AM_INIT_AUTOMAKE(bfd, 2.17.atmel.1.2.1)
+
+ dnl These must be called before AM_PROG_LIBTOOL, because it may want
+ dnl to call AC_CHECK_PROG.