summaryrefslogtreecommitdiff
path: root/packages/apr/apr-util
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-02-07 22:49:55 +0100
committerKoen Kooi <koen@openembedded.org>2009-02-07 22:49:55 +0100
commit642961d27edc80096227c3ad2e31d5a4ab21b756 (patch)
tree45db68c6ee9af89858c512d728f8732fde7ad217 /packages/apr/apr-util
parentf9380580de7f50adf8c12e7bf72d37465e7f6406 (diff)
apr + apr-util: merge from poky
Diffstat (limited to 'packages/apr/apr-util')
-rw-r--r--packages/apr/apr-util/configfix.patch49
-rw-r--r--packages/apr/apr-util/configure_fixes.patch24
-rw-r--r--packages/apr/apr-util/configure_fixes.patch.old25
3 files changed, 81 insertions, 17 deletions
diff --git a/packages/apr/apr-util/configfix.patch b/packages/apr/apr-util/configfix.patch
new file mode 100644
index 0000000000..a8953e5244
--- /dev/null
+++ b/packages/apr/apr-util/configfix.patch
@@ -0,0 +1,49 @@
+Index: apr-util-1.3.4/apu-config.in
+===================================================================
+--- apr-util-1.3.4.orig/apu-config.in 2009-01-12 17:08:06.000000000 +0000
++++ apr-util-1.3.4/apu-config.in 2009-01-12 17:09:00.000000000 +0000
+@@ -134,14 +134,7 @@
+ exit 0
+ ;;
+ --includes)
+- if test "$location" = "installed"; then
+ flags="$flags -I$includedir $INCLUDES"
+- elif test "$location" = "source"; then
+- flags="$flags -I$APU_SOURCE_DIR/include $INCLUDES"
+- else
+- # this is for VPATH builds
+- flags="$flags -I$APU_BUILD_DIR/include -I$APU_SOURCE_DIR/include $INCLUDES"
+- fi
+ ;;
+ --ldflags)
+ flags="$flags $LDFLAGS"
+@@ -155,28 +148,10 @@
+ exit 0
+ ;;
+ --link-ld)
+- if test "$location" = "installed"; then
+- ### avoid using -L if libdir is a "standard" location like /usr/lib
+ flags="$flags -L$libdir -l$APRUTIL_LIBNAME"
+- else
+- flags="$flags -L$APU_BUILD_DIR -l$APRUTIL_LIBNAME"
+- fi
+ ;;
+ --link-libtool)
+- # If the LA_FILE exists where we think it should be, use it. If we're
+- # installed and the LA_FILE does not exist, assume to use -L/-l
+- # (the LA_FILE may not have been installed). If we're building ourselves,
+- # we'll assume that at some point the .la file be created.
+- if test -f "$LA_FILE"; then
+- flags="$flags $LA_FILE"
+- elif test "$location" = "installed"; then
+- ### avoid using -L if libdir is a "standard" location like /usr/lib
+- # Since the user is specifying they are linking with libtool, we
+- # *know* that -R will be recognized by libtool.
+- flags="$flags -L$libdir -R$libdir -l$APRUTIL_LIBNAME"
+- else
+- flags="$flags $LA_FILE"
+- fi
++ flags="$flags -l$APRUTIL_LIBNAME"
+ ;;
+ --apu-la-file)
+ if test -f "$LA_FILE"; then
diff --git a/packages/apr/apr-util/configure_fixes.patch b/packages/apr/apr-util/configure_fixes.patch
index 7c6fa6a4d2..0b2a0903e1 100644
--- a/packages/apr/apr-util/configure_fixes.patch
+++ b/packages/apr/apr-util/configure_fixes.patch
@@ -1,6 +1,8 @@
---- /tmp/configure.in 2009-02-06 16:34:14.000000000 +0100
-+++ apr-util-1.2.12/configure.in 2009-02-06 16:34:38.000000000 +0100
-@@ -8,13 +8,13 @@
+Index: apr-util-1.3.4/configure.in
+===================================================================
+--- apr-util-1.3.4.orig/configure.in
++++ apr-util-1.3.4/configure.in
+@@ -8,14 +8,14 @@ AC_INIT(export_vars.sh.in)
AC_CONFIG_HEADER(include/private/apu_config.h)
AC_CONFIG_AUX_DIR(build)
@@ -11,6 +13,7 @@
-sinclude(build/find_apr.m4)
-sinclude(build/dbm.m4)
-sinclude(build/dbd.m4)
+-sinclude(build/dso.m4)
+#sinclude(build/apu-conf.m4)
+#sinclude(build/apu-iconv.m4)
+#sinclude(build/apu-hints.m4)
@@ -18,20 +21,7 @@
+#sinclude(build/find_apr.m4)
+#sinclude(build/dbm.m4)
+#sinclude(build/dbd.m4)
++#sinclude(build/dso.m4)
dnl Generate ./config.nice for reproducing runs of configure
dnl
-@@ -45,10 +45,10 @@
- # against installed versions of libapr instead of those just
- # built.
- case $host in
--*-apple-darwin*) LT_NO_INSTALL="" ;;
--*) LT_NO_INSTALL="-no-install" ;;
-+*-apple-darwin*) LV_NO_INSTALL="" ;;
-+*) LV_NO_INSTALL="-no-install" ;;
- esac
--AC_SUBST(LT_NO_INSTALL)
-+AC_SUBST(LV_NO_INSTALL)
-
- dnl
- dnl compute the top directory of the build
diff --git a/packages/apr/apr-util/configure_fixes.patch.old b/packages/apr/apr-util/configure_fixes.patch.old
new file mode 100644
index 0000000000..16f88b3bba
--- /dev/null
+++ b/packages/apr/apr-util/configure_fixes.patch.old
@@ -0,0 +1,25 @@
+Index: apr-util-1.2.12/configure.in
+===================================================================
+--- apr-util-1.2.12.orig/configure.in 2008-03-08 19:15:00.000000000 +0000
++++ apr-util-1.2.12/configure.in 2008-03-08 19:15:13.000000000 +0000
+@@ -8,13 +8,13 @@
+ AC_CONFIG_HEADER(include/private/apu_config.h)
+ AC_CONFIG_AUX_DIR(build)
+
+-sinclude(build/apu-conf.m4)
+-sinclude(build/apu-iconv.m4)
+-sinclude(build/apu-hints.m4)
+-sinclude(build/apr_common.m4)
+-sinclude(build/find_apr.m4)
+-sinclude(build/dbm.m4)
+-sinclude(build/dbd.m4)
++#sinclude(build/apu-conf.m4)
++#sinclude(build/apu-iconv.m4)
++#sinclude(build/apu-hints.m4)
++#sinclude(build/apr_common.m4)
++#sinclude(build/find_apr.m4)
++#sinclude(build/dbm.m4)
++#sinclude(build/dbd.m4)
+
+ dnl Generate ./config.nice for reproducing runs of configure
+ dnl