summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am27
1 files changed, 23 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bfeafff..12f084c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,12 +1,31 @@
+## Process this file with automake to produce Makefile.in
AUTOMAKE_OPTIONS = gnu
AM_CFLAGS = -Wall
-bin_PROGRAMS = mts-id-eeprom hashpwd
+bin_PROGRAMS = mts-id-eeprom
+sbin_PROGRAMS = mts-hashpwd
+mts_hashpwd_SOURCES = hashpwd.cpp
mts_id_eeprom_SOURCES = eeprom_main.c
-hashpwd_SOURCES = hashpwd.cpp
noinst_HEADERS = eeprom.h
-hashpwd_LDADD = -lcrypto
-
+mts_hashpwd_LDADD = -lcrypto
+sbin_SCRIPTS = ubpasswd.sh
EXTRA_DIST =
+SUFFIXES = .sh
+
+.sh:
+ $(shbin_verbose) cp $< $@.tmp
+ $(AM_V_at) chmod 0744 $@.tmp
+ $(AM_V_at) mv -f $@.tmp $@
+
+# Since this is Yocto we just make it work by moving
+# the sbin stuff to /sbin, and set permissions
+# on the script for root.
+install-exec-hook:
+ cd $(DESTDIR)$(sbindir) && mkdir ../../sbin && \
+ mv ubpasswd.sh ../../sbin/mts-ubpasswd && \
+ chmod 0744 ../../sbin/mts-ubpasswd
+ cd $(DESTDIR)$(sbindir) && \
+ mv mts-hashpwd ../../sbin/mts-hashpwd
+ rmdir $(DESTDIR)$(sbindir)