summaryrefslogtreecommitdiff
path: root/recipes-kernel/rs9113
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/rs9113')
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb52
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.5.5.bb (renamed from recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb)11
-rw-r--r--recipes-kernel/rs9113/rs9113.inc11
-rw-r--r--recipes-kernel/rs9113/rs9113_1.4.3.bb26
-rw-r--r--recipes-kernel/rs9113/rs9113_1.5.5.bb (renamed from recipes-kernel/rs9113/rs9113_1.5.0.bb)7
5 files changed, 23 insertions, 84 deletions
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb b/recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb
deleted file mode 100644
index f2f2319..0000000
--- a/recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb
+++ /dev/null
@@ -1,52 +0,0 @@
-DESCRIPTION = "USB Driver for Redpine RS9113"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
-PACKAGE_ARCH = "mtcdt"
-PROVIDES = "rs9113-from-src"
-
-inherit module
-
-SRCREV = "${AUTOREV}"
-
-SRC_URI = " \
- git://git@${MTS_INTERNAL_GIT}/mlinux/meta-rs9113.git;protocol=ssh;branch=${PV};destsuffix=meta/ \
- git://git@${MTS_INTERNAL_GIT}/mlinux/Redpine.git;protocol=ssh;branch=${PV} \
-"
-SRCXX_URI = " \
- git://git@${MTS_INTERNAL_GIT}/mlinux/Redpine.git;protocol=ssh;branch=${PV};name=machine \
- git://git@${MTS_INTERNAL_GIT}/mlinux/meta-rs9113.git;protocol=ssh;branch=${PV};name=meta \
-"
-
-S = "${WORKDIR}/git/source/host"
-M = "${WORKDIR}/meta"
-
-EXTRA_OEMAKE = " KERNELDIR=${STAGING_KERNEL_DIR} \
- CROSS_COMPILE=${TARGET_PREFIX} \
- ARCH=arm \
- WLAN_COMPILE_FLAGS='' \
- V=1 \
- "
-
-FILES_${PN} = "/opt/rs9113 ${sbindir}"
-FILES_${PN}-dbg = "/opt/rs9113/.debug/"
-
-PARALLEL_MAKE = ""
-
-do_configure() {
- cp ${M}/mtcdt/defconfig .config
-}
-
-do_compile () {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- oe_runmake
-}
-
-do_install() {
- install -m 0755 -d ${D}/opt/rs9113
- cp -r ${S}/release/* ${D}/opt/rs9113/
- rm -rf ${D}/opt/rs9113/flash ${D}/opt/rs9113/certs ${D}/opt/rs9113/*zigb*
- install -m 0755 -d ${D}${sbindir}
- install -m 0755 ${M}/rs9113_load_modules.sh ${D}${sbindir}/
- install -m 0755 ${M}/rs9113_remove_modules.sh ${D}${sbindir}/
-}
-
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb b/recipes-kernel/rs9113/rs9113-from-src_1.5.5.bb
index 7d93952..57b17a3 100644
--- a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.5.5.bb
@@ -4,6 +4,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2
PACKAGE_ARCH = "mtcdt"
PROVIDES = "rs9113-from-src"
PR = "${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}"
+INHIBIT_PACKAGE_STRIP = "1"
inherit module
@@ -33,6 +34,10 @@ FILES_${PN}-dbg = "/opt/rs9113/.debug/"
PARALLEL_MAKE = ""
+# Avoid QA Issue: No GNU_HASH in the elf binary
+INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP_${PN}-dev = "ldflags"
+
do_configure() {
cp ${M}/mtcdt/defconfig .config
}
@@ -51,12 +56,18 @@ do_patch () {
cd ${WORKDIR}/git
echo "patches" ${M}/patches/*
for f in ${M}/patches/* ; do
+ # If no patches, * is not expanded.
+ # Do not try to use "*" as a patch file.
+ if ! [[ -r ${f} ]] ; then
+ continue
+ fi
echo "Patching with ${f}"
patch -p1 < ${f}
done
}
do_install() {
+ echo D is ${D}
install -m 0755 -d ${D}/opt/rs9113
cp -r ${S}/release/* ${D}/opt/rs9113/
rm -rf ${D}/opt/rs9113/flash ${D}/opt/rs9113/certs ${D}/opt/rs9113/*zigb*
diff --git a/recipes-kernel/rs9113/rs9113.inc b/recipes-kernel/rs9113/rs9113.inc
index 1a238e1..1bf5768 100644
--- a/recipes-kernel/rs9113/rs9113.inc
+++ b/recipes-kernel/rs9113/rs9113.inc
@@ -1,10 +1,15 @@
inherit update-rc.d
DR = "${DL_DIR}/rs9113-ipk"
+FILESEXTRAPATHS_append := "${DR}:"
INITSCRIPT_NAME = "rs9113"
INITSCRIPT_PARAMS = "start 50 S ."
+# Avoid QA Issue: No GNU_HASH in the elf binary
+INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP_${PN}-dev = "ldflags"
+
python do_fetch_prepend () {
# d.setVar('BB_STRICT_CHECKSUM',False)
DR = d.getVar("DR",True)
@@ -62,9 +67,9 @@ do_install () {
bbnote "pwd,ls: $(pwd) $(ls) WORKDIR is ${WORKDIR}"
(
cd ${WORKDIR}
- find etc -print0 | cpio -0 -pdum ${D}
- find usr -print0 | cpio -0 -pdum ${D}
- find opt -print0 | cpio -0 -pdum ${D}
+ find etc -print0 | cpio --owner root:root -0 -pdum ${D}
+ find usr -print0 | cpio --owner root:root -0 -pdum ${D}
+ find opt -print0 | cpio --owner root:root -0 -pdum ${D}
)
install -d ${D}/opt/rs9113/init.d
install -d ${D}${sysconfdir}/init.d/
diff --git a/recipes-kernel/rs9113/rs9113_1.4.3.bb b/recipes-kernel/rs9113/rs9113_1.4.3.bb
deleted file mode 100644
index fe47e2d..0000000
--- a/recipes-kernel/rs9113/rs9113_1.4.3.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-require rs9113.inc
-DESCRIPTION = "USB Driver for Redpine RS9113"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
-PACKAGE_ARCH = "mtcdt"
-PROVIDES = "rs9113"
-FILES_${PN} = "/opt/rs9113 ${sbindir} ${sysconfdir}"
-
-# This bitbake recipe requires SSH_AUTH_SOCK to be set if ssh key pass
-# phrases are used. SSH_AUTH_SOCK is set by a keyserver,
-# such as gnome-keyring-daemon or ssh-keyagent.
-
-# NOTE: rs9113 binary is built with Jenkin's job using rs9113-from-src_${PV}.bb
-# To update this, manually copy ipk from Jenkin's job to
-# git://git@${MTS_INTERNAL_GIT}/mlinux/ipk.git;protocol=ssh;branch=${PV}
-#
-PR = "r0"
-SRC_URI = " \
- file://rs9113/rs9113.init \
- file://rs9113/rs9113.default \
- file://rs9113/wpa_supplicant \
- file://rs9113-ipk/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk \
-"
-SRCREV = "${AUTOREV}"
-SRC_URI[md5sum] = "ff2238e0fb52b1627e76ca366fc83919"
-SRC_URI[sha256sum] = "e303c5bc2e89e0c36303642d2677eadb2f4a9e2e0bb9a8622883abd97fe6e742"
diff --git a/recipes-kernel/rs9113/rs9113_1.5.0.bb b/recipes-kernel/rs9113/rs9113_1.5.5.bb
index fbfb706..b68ab40 100644
--- a/recipes-kernel/rs9113/rs9113_1.5.0.bb
+++ b/recipes-kernel/rs9113/rs9113_1.5.5.bb
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2
PACKAGE_ARCH = "mtcdt"
PROVIDES = "rs9113"
FILES_${PN} = "/opt/rs9113 ${sbindir} ${sysconfdir}"
+RDEPENDS_${PN} += "perl bash"
# This bitbake recipe requires SSH_AUTH_SOCK to be set if ssh key pass
# phrases are used. SSH_AUTH_SOCK is set by a keyserver,
@@ -19,9 +20,9 @@ SRC_URI = " \
file://rs9113/rs9113.init \
file://rs9113/rs9113.default \
file://rs9113/wpa_supplicant \
- file://rs9113-ipk/rs9113-from-src_${PV}-${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}.0_mtcdt.ipk \
+ file://rs9113-ipk/rs9113-from-src_${PV}-${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}.0_mtcdt.ipk;name=binaries \
"
SRCREV = "${AUTOREV}"
# For some reason the md5sum and sha256sum are ignored
-SRC_URI[md5sum] = "def9fd10a77cae9df9bcb2e20626795e"
-SRC_URI[sha256sum] = "367e942618143d4967273ce44120098a98e2ad1f543a9a404af7082b40c5066e"
+SRC_URI[binaries.md5sum] = "7c0f7badf5a2a3b3dacc790ff0a9ce55"
+SRC_URI[binaries.sha256sum] = "2780d417295999724ada4a08e6a196aaca55324af24b404e0f9b2f2ea7d4d830"