summaryrefslogtreecommitdiff
path: root/recipes-kernel/rs9113/rs9113_1.4.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/rs9113/rs9113_1.4.3.bb')
-rw-r--r--recipes-kernel/rs9113/rs9113_1.4.3.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-kernel/rs9113/rs9113_1.4.3.bb b/recipes-kernel/rs9113/rs9113_1.4.3.bb
new file mode 100644
index 0000000..a2f28c9
--- /dev/null
+++ b/recipes-kernel/rs9113/rs9113_1.4.3.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "USB Driver for Redpine RS9113"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+PACKAGE_ARCH = "mtcdt"
+PROVIDES = "rs9113"
+FILES_${PN} = "/opt/rs9113 ${sbindir} ${sysconfdir}"
+# BB_STRICT_CHECKSUM = "0"
+
+# NOTE: annex-client binary is built with Jenkin's job using annex-client-from-src.bb
+# To update this, manually copy ipk from Jenkin's job to .net/downloads/
+PR = "r0"
+SRC_URI = "http://akbar:8080/job/rs9113/lastSuccessfulBuild/artifact/mlinux/build/tmp/deploy/ipk/mtcdt/rs9113-from-src_${PV}-${PR}.0_${PACKAGE_ARCH}.ipk \
+ file://rs9113/rs9113.init \
+ file://rs9113/rs9113.default \
+ file://rs9113/wpa_supplicant \
+"
+
+M = "${WORKDIR}/rs9113"
+
+python do_fetch_prepend () {
+ d.setVar('BB_STRICT_CHECKSUM',False)
+}
+
+do_install() {
+ bbnote "pwd,ls: $(pwd) $(ls) WORKDIR is ${WORKDIR}"
+ (
+ cd ${WORKDIR}
+ find etc -print0 | cpio -0 -pdum ${D}
+ find usr -print0 | cpio -0 -pdum ${D}
+ find opt -print0 | cpio -0 -pdum ${D}
+ )
+ install -d ${D}/opt/rs9113/init.d
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/default/
+ install -m 0755 ${M}/wpa_supplicant ${D}/opt/rs9113/init.d
+ install -m 0755 ${M}/rs9113.init ${D}${sysconfdir}/init.d/rs9113
+ install -m 0644 ${M}/rs9113.default ${D}${sysconfdir}/default/rs9113
+}
+