summaryrefslogtreecommitdiff
path: root/recipes-kernel/rs9113/rs9113_1.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/rs9113/rs9113_1.3.0.bb')
-rw-r--r--recipes-kernel/rs9113/rs9113_1.3.0.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/recipes-kernel/rs9113/rs9113_1.3.0.bb b/recipes-kernel/rs9113/rs9113_1.3.0.bb
new file mode 100644
index 0000000..80be133
--- /dev/null
+++ b/recipes-kernel/rs9113/rs9113_1.3.0.bb
@@ -0,0 +1,59 @@
+DESCRIPTION = "USB Driver for Redpine RS9113"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+SRCREV = "${AUTOREV}"
+SRC_URI = " \
+ git://git@gitlab.multitech.net/mlinux/Redpine.git;protocol=ssh;branch=1.3.0 \
+ file://kthread.patch;patch=1;pnum=3 \
+ file://defconfig \
+ file://rs9113_load_modules.sh \
+ file://rs9113_remove_modules.sh \
+ file://rs9113.init \
+ file://rs9113.default \
+"
+
+S = "${WORKDIR}/git/source/host"
+FILESEXTRAPATHS_prepend := "${WORKDIR}/git/patches:"
+
+EXTRA_OEMAKE = " KERNELDIR=${STAGING_KERNEL_DIR} \
+ CROSS_COMPILE=${TARGET_PREFIX} \
+ ARCH=arm \
+ WLAN_COMPILE_FLAGS='' \
+ "
+
+inherit update-rc.d
+INITSCRIPT_NAME = "rs9113"
+INITSCRIPT_PARAMS = "start 00 2 3 4 5 . stop 81 0 6 1 ."
+
+do_configure() {
+ cp ${WORKDIR}/defconfig .config
+}
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake
+}
+
+FILES_${PN} = "/opt/rs9113 ${sbindir} ${sysconfdir}"
+FILES_${PN}-dbg = "/opt/rs9113/.debug/"
+
+PARALLEL_MAKE = ""
+
+do_install() {
+ install -m 0755 -d ${D}/opt/rs9113
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/default/
+ cp -r ${S}/release/* ${D}/opt/rs9113/
+
+ install -m 0755 -d ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/rs9113_load_modules.sh ${D}${sbindir}/
+ install -m 0755 ${WORKDIR}/rs9113_remove_modules.sh ${D}${sbindir}/
+ install -m 0755 ${WORKDIR}/rs9113.init ${D}${sysconfdir}/init.d/rs9113
+ install -m 0644 ${WORKDIR}/rs9113.default ${D}${sysconfdir}/default/rs9113
+}
+
+python do_clean() {
+ bb.note("Skipping clean in rs9113 recipe.")
+}