summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux_3.12.70.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux_3.12.70.bb')
-rw-r--r--recipes-kernel/linux/linux_3.12.70.bb27
1 files changed, 26 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux_3.12.70.bb b/recipes-kernel/linux/linux_3.12.70.bb
index d9d1d1e..a456c14 100644
--- a/recipes-kernel/linux/linux_3.12.70.bb
+++ b/recipes-kernel/linux/linux_3.12.70.bb
@@ -48,12 +48,37 @@ SRC_URI_append_mtcap = "\
file://linux-3.12-add-num_accessory_ports-config-option.patch \
"
+SRC_URI_append_mtr = "\
+ ${COMMON_PATCHES} \
+ file://defconfig \
+ file://linux-3.12-eeprom-setup-mtr.patch \
+ file://linux-3.12-mtr-device-tree.patch \
+ file://linux-3.12-add-num_accessory_ports-config-option.patch \
+ file://linux-3.12-wl12xx-fix-threaded-irq-requested-with-NULL-handler.patch \
+ file://linux-3.12-wl12xx-set-power.patch \
+ file://linux-3.12-wl12xx-fix-boot-in-plt-mode.patch \
+ file://linux-3.12-ledtrig-netdev.patch "
+
+SRC_URI_append_mtrv1 = "\
+ ${COMMON_PATCHES} \
+ file://defconfig \
+ file://linux-3.12-eeprom-setup-mtr.patch \
+ file://linux-3.12-mtrv1-device-tree.patch \
+ file://linux-3.12-add-num_accessory_ports-config-option.patch \
+ file://linux-3.12-wl12xx-fix-threaded-irq-requested-with-NULL-handler.patch \
+ file://linux-3.12-wl12xx-set-power.patch \
+ file://linux-3.12-wl12xx-fix-boot-in-plt-mode.patch \
+ file://linux-3.12-ledtrig-netdev.patch "
+
+
SRC_URI[md5sum] = "84b573a1583079df1e770210daa6c525"
SRC_URI[sha256sum] = "af56c7ba98a0ba0c3722d9ec7106830996610e6fd88e4b0c6b2b92dab88d7653"
-COMPATIBLE_MACHINE = "(mtcdt|mtcap)"
+COMPATIBLE_MACHINE = "(mtcdt|mtcap|mtr|mtrv1)"
DTB_APPEND_mtcdt = "mtcdt"
DTB_APPEND_mtcap = "mtcap"
+DTB_APPEND_mtr = "mtr"
+DTB_APPEND_mtrv1 = "mtrv1"
# disable this on purpose for dev purposes
do_rm_work() {