summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux_3.12.27.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux_3.12.27.bb')
-rw-r--r--recipes-kernel/linux/linux_3.12.27.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux_3.12.27.bb b/recipes-kernel/linux/linux_3.12.27.bb
new file mode 100644
index 0000000..b99ae5b
--- /dev/null
+++ b/recipes-kernel/linux/linux_3.12.27.bb
@@ -0,0 +1,40 @@
+inherit kernel
+# mts class to build dtb and append to kernel image
+inherit linux-append-dtb
+
+PR = "r6"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
+
+DEPENDS += "xz-native bc-native"
+
+SRC_URI = "https://www.kernel.org/pub/linux/kernel/v3.x/linux-${PV}.tar.gz"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+COMMON_PATCHES = " \
+ file://linux-3.12-gpio-expose-pullups.patch \
+ file://linux-3.12-gpio-expose-deglitch.patch \
+ file://linux-3.12-atmel-spi.patch \
+ file://linux-3.12-atmel-mci-force-detect.patch \
+ file://linux-3.12-atmel-pmecc-debug-bitflips.patch \
+ file://linux-3.12-at91sam9_wdt-10second-timeout.patch \
+ file://linux-3.12.27-option-telit.patch \
+ file://linux-3.12-cdc-acm-ignore-exar-devices.patch \
+ file://linux-3.12-release-rfcomm-port-fix.patch \
+ "
+
+SRC_URI_append_mtcdt = "\
+ ${COMMON_PATCHES} \
+ file://defconfig \
+ file://linux-3.12-eeprom-setup-mtcdt.patch \
+ file://linux-3.12-mtcdt-device-tree.patch \
+ file://linux-3.12-add-num_accessory_ports-config-option.patch \
+ "
+
+SRC_URI[md5sum] = "2f05332bfca89ae1348ae454af2f5ffb"
+SRC_URI[sha256sum] = "2014c55257dda311779359d6b42931079a687c154777cc528c44e25f262194cd"
+
+COMPATIBLE_MACHINE = "(mtcdt)"
+DTB_APPEND_mtcdt = "mtcdt"