summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-at91_4.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-at91_4.9.bb')
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-at91_4.9.bb b/recipes-kernel/linux/linux-at91_4.9.bb
index 28d6a14..10e9152 100644
--- a/recipes-kernel/linux/linux-at91_4.9.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.bb
@@ -30,6 +30,7 @@ SRC_URI_append_mtcdt = "\
file://defconfig \
file://linux-4.9-mtcdt-device-tree.patch \
file://linux-4.9-add-num_accessory_ports-config-option.patch \
+ file://950-0090-OF-DT-Overlay-configfs-interface.patch \
"
DTB_APPEND_mtcdt = "mtcdt"
@@ -101,10 +102,10 @@ pkg_postinst_kernel-image-uimage-inst() {
fi
}
-# Install dtc and fixdep to build any device tree overlays in other recipes/modules.
+# The 4.9 kernel dtc will not work with overlays, so don't install dtc and fixdep
do_install_append() {
- install -D -m 0755 scripts/dtc/dtc ${STAGING_DIR_NATIVE}${USRBINPATH_class-native}/dtc
- install -D -m 0755 scripts/basic/fixdep ${STAGING_DIR_NATIVE}${USRBINPATH_class-native}/fixdep
+ #install -D -m 0755 scripts/dtc/dtc ${STAGING_DIR_NATIVE}${USRBINPATH_class-native}/dtc
+ #install -D -m 0755 scripts/basic/fixdep ${STAGING_DIR_NATIVE}${USRBINPATH_class-native}/fixdep
install -d -m 0755 ${D}${includedir}/linux
cp -a ${STAGING_KERNEL_DIR}/include/dt-bindings ${D}${includedir}/linux/
install -d -m 0755 ${STAGING_DIR_TARGET}/${includedir}/linux