summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch')
-rw-r--r--recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch560
1 files changed, 0 insertions, 560 deletions
diff --git a/recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch b/recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch
deleted file mode 100644
index a846bc5..0000000
--- a/recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch
+++ /dev/null
@@ -1,560 +0,0 @@
-diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/mtr.dts linux-4.9.87/arch/arm/boot/dts/mtr.dts
---- linux-4.9.87.orig/arch/arm/boot/dts/mtr.dts 1969-12-31 18:00:00.000000000 -0600
-+++ linux-4.9.87/arch/arm/boot/dts/mtr.dts 2019-01-03 15:17:51.799576663 -0600
-@@ -0,0 +1,283 @@
-+/*
-+ * DTS file for Multi-Tech Systems mtr Hardware
-+ *
-+ * Copyright (C) 2016 by Multi-Tech Systems,
-+ *
-+ * Licensed under GPLv2 or later.
-+ */
-+
-+/dts-v1/;
-+#include "at91sam9g25.dtsi"
-+#include "at91sam9x5ek.dtsi"
-+
-+/ {
-+ model = "Multi-Tech Systems MTR";
-+ compatible = "atmel,at91sam9g25ek", "atmel,at91sam9x5ek", "atmel,at91sam9x5", "atmel,at91sam9";
-+ aliases {
-+ serial1 = &uart0;
-+ };
-+
-+ chosen {
-+ bootargs = "mem=128M console=ttyS0,115200 root=/dev/mtdblock8 ro rootfstype=jffs2";
-+ };
-+
-+ memory {
-+ reg = <0x20000000 0x8000000>;
-+ };
-+
-+ clocks {
-+ #address-cells = <1>;
-+ #size-cells = <1>;
-+ ranges;
-+
-+ main_clock: clock@0 {
-+ compatible = "atmel,osc", "fixed-clock";
-+ clock-frequency = <12000000>;
-+ };
-+ };
-+
-+ ahb {
-+ apb {
-+ /delete-node/ spi@f0004000;
-+ macb0: ethernet@f802c000 {
-+ phy-mode = "mii";
-+ status = "okay";
-+ };
-+
-+ mmc0: mmc@f0008000 {
-+ pinctrl-names = "default";
-+ pinctrl-0 = <
-+ &pinctrl_board_mmc0
-+ &pinctrl_mmc0_slot0_clk_cmd_dat0
-+ &pinctrl_mmc0_slot0_dat1_3>;
-+ status = "okay";
-+ always_present;
-+ cd-permanent;
-+ slot@0 {
-+ compatible = "ti,wl1271";
-+ reg = <2>; /* Card function */
-+ bus-width = <4>;
-+ non-removeable;
-+ status = "okay";
-+ interrupt-parent = <&pioA>;
-+ interrupts = <26 IRQ_TYPE_EDGE_RISING>; /* PA26 - REQUIRED */
-+ ref-clock-frequency = <38400000>; /* 2 = 38.4MHz */
-+ platform-quirks = <0x1>; /* 1 = Edge IRQ */
-+ slot-id = <0>; /* Atmel MCI driver fix */
-+ };
-+ };
-+
-+ pinctrl@fffff400 {
-+ mmc0 {
-+ pinctrl_board_mmc0: mmc0-board {
-+ atmel,pins =
-+ <AT91_PIOA 26 AT91_PERIPH_GPIO AT91_PINCTRL_DEGLITCH /* PA26 gpio A int pin deglitch (external PU) */
-+ AT91_PIOD 15 AT91_PERIPH_GPIO AT91_PINCTRL_PULL_UP_DEGLITCH>; /* PD15 gpio CD pin pull up and deglitch */
-+ };
-+ };
-+
-+ nand {
-+ pinctrl_nand: nand-0 {
-+ atmel,pins =
-+ <AT91_PIOD 0 AT91_PERIPH_A AT91_PINCTRL_PULL_UP /* PD0 periph A Read Enable */
-+ AT91_PIOD 1 AT91_PERIPH_A AT91_PINCTRL_PULL_UP /* PD1 periph A Write Enable */
-+ AT91_PIOD 2 AT91_PERIPH_A AT91_PINCTRL_PULL_UP /* PD2 periph A Address Latch Enable */
-+ AT91_PIOD 3 AT91_PERIPH_A AT91_PINCTRL_PULL_UP /* PD3 periph A Command Latch Enable */
-+ AT91_PIOD 4 AT91_PERIPH_GPIO AT91_PINCTRL_PULL_UP /* PD4 gpio Chip Enable pin pull_up */
-+ AT91_PIOC 31 AT91_PERIPH_GPIO AT91_PINCTRL_PULL_UP /* PC31 gpio RDY/BUSY pin pull_up */
-+ AT91_PIOD 6 AT91_PERIPH_A AT91_PINCTRL_PULL_UP /* PD6 periph A Data bit 0 */
-+ AT91_PIOD 7 AT91_PERIPH_A AT91_PINCTRL_PULL_UP /* PD7 periph A Data bit 1 */
-+ AT91_PIOD 8 AT91_PERIPH_A AT91_PINCTRL_PULL_UP /* PD8 periph A Data bit 2 */
-+ AT91_PIOD 9 AT91_PERIPH_A AT91_PINCTRL_PULL_UP /* PD9 periph A Data bit 3 */
-+ AT91_PIOD 10 AT91_PERIPH_A AT91_PINCTRL_PULL_UP /* PD10 periph A Data bit 4 */
-+ AT91_PIOD 11 AT91_PERIPH_A AT91_PINCTRL_PULL_UP /* PD11 periph A Data bit 5 */
-+ AT91_PIOD 12 AT91_PERIPH_A AT91_PINCTRL_PULL_UP /* PD12 periph A Data bit 6 */
-+ AT91_PIOD 13 AT91_PERIPH_A AT91_PINCTRL_PULL_UP>; /* PD13 periph A Data bit 7 */
-+ };
-+
-+ /delete-node/ nand_16bits-0;
-+ };
-+
-+ /delete-node/ spi1;
-+
-+ /*
-+ * Pin A23 will be left floating when the power goes off on the radio.
-+ * We need to pull it down to ensure it is low during radio power-off.
-+ * pinctrl is loaded during the call to platform_device_register() in mts-io.
-+ * If we need to customize this for various hardware revisions, these can
-+ * be loaded as overlays prior to loading the mts-io module, overwriting the
-+ * atmel,pins section.
-+ */
-+ mts_io {
-+ pinctrl_mts_io: mts_io-0 {
-+ atmel,pins =
-+ <AT91_PIOA 21 AT91_PERIPH_GPIO AT91_PINCTRL_PULL_UP /* PA21 GPIO pull-up radio-power */
-+ AT91_PIOA 22 AT91_PERIPH_GPIO AT91_PINCTRL_PULL_UP /* PA22 GPIO pull-up radio-reset */
-+ AT91_PIOA 23 AT91_PERIPH_GPIO AT91_PINCTRL_PULL_DOWN>; /* PA23 GPIO pull-down radio-monitor */
-+ };
-+ };
-+
-+ 1wire_cm {
-+ pinctrl_1wire_cm: 1wire_cm-0 {
-+ atmel,pins = <AT91_PIOB 18 AT91_PERIPH_GPIO AT91_PINCTRL_MULTI_DRIVE>; /* PB18 multidrive, conflicts with led */
-+ };
-+ };
-+ };
-+
-+ rtc@fffffeb0 {
-+ status = "okay";
-+ };
-+
-+ dbgu: serial@fffff200 {
-+ status = "okay";
-+ atmel,use-dma-rx;
-+ atmel,use-dma-tx;
-+ };
-+
-+ spi@f0000000 {
-+ /delete-node/ m25p80@0;
-+ };
-+
-+ /delete-node/ serial@f801c000;
-+
-+ uart0: serial@f8040000 {
-+ status = "okay";
-+ atmel,use-dma-rx;
-+ atmel,use-dma-tx;
-+ dmas = <&dma0 1 AT91_DMA_CFG_PER_ID(11)>,
-+ <&dma0 1 (AT91_DMA_CFG_PER_ID(12) | AT91_DMA_CFG_FIFOCFG_ASAP)>;
-+ dma-names = "tx", "rx";
-+ };
-+
-+ usb2: gadget@f803c000 {
-+ atmel,vbus-gpio = <&pioB 16 GPIO_ACTIVE_HIGH>;
-+ status = "okay";
-+ };
-+ watchdog@fffffe40 {
-+ status = "okay";
-+ };
-+ };
-+
-+ nand0: nand@40000000 {
-+ nand-bus-width = <8>;
-+ nand-ecc-mode = "hw";
-+ atmel,has-pmecc; /* Enable PMECC */
-+ atmel,pmecc-sector-size = <512>;
-+ status = "okay";
-+ reg = < 0x40000000 0x10000000
-+ 0xffffe000 0x600 /* PMECC Registers */
-+ 0xffffe600 0x200 /* PMECC Error Location Registers */
-+ 0x00100000 0x100000 /* PMECC looup table in ROM code */
-+ >;
-+ atmel,pmecc-lookup-table-offset = <0x8000 0x10000>;
-+ gpios = < &pioC 31 GPIO_ACTIVE_HIGH
-+ &pioD 4 GPIO_ACTIVE_HIGH
-+ 0
-+ >;
-+ atmel,pmecc-cap = <4>;
-+ atmel,nand-has-dma;
-+
-+ nand@0 {
-+ label = "NANDFlash";
-+ reg = <0x0 0x10000000>;
-+ };
-+ at91bootstrap@0 {
-+ label = "at91bootstrap";
-+ reg = <0x0 0x40000>;
-+ };
-+ uboot@40000 {
-+ label = "u-Boot";
-+ reg = <0x40000 0x80000>;
-+ };
-+ ubootconfig0@c0000 {
-+ label = "u-Boot Config";
-+ reg = <0xc0000 0xa0000>;
-+ };
-+ ubootconfig1@160000 {
-+ label = "u-Boot Redundant Config";
-+ reg = <0x160000 0xa0000>;
-+ };
-+ uImage@200000 {
-+ label = "uImage";
-+ reg = <0x200000 0x600000>;
-+ };
-+ config0@800000 {
-+ label = "Config";
-+ reg = <0x800000 0x800000>;
-+ };
-+ config1@1000000 {
-+ label = "OEM Config";
-+ reg = <0x1000000 0x800000>;
-+ };
-+ rootfs@1800000 {
-+ label = "Rootfs";
-+ reg = <0x1800000 0xe800000>;
-+ };
-+ };
-+
-+ usb0: ohci@00600000 {
-+ status = "okay";
-+ num-ports = <3>;
-+ };
-+
-+ usb1: ehci@00700000 {
-+ status = "okay";
-+ };
-+ };
-+
-+ leds {
-+ compatible = "gpio-leds";
-+
-+ pc21 {
-+ label = "led-status";
-+ gpios = <&pioC 21 GPIO_ACTIVE_LOW>;
-+ linux,default-trigger = "default-on";
-+ };
-+ pc15 {
-+ label = "led-b";
-+ gpios = <&pioC 15 GPIO_ACTIVE_LOW>;
-+ };
-+ pc20 {
-+ label = "led-c";
-+ gpios = <&pioC 20 GPIO_ACTIVE_LOW>;
-+ };
-+ pc19 {
-+ label = "led-d";
-+ gpios = <&pioC 19 GPIO_ACTIVE_LOW>;
-+ };
-+ pc18 {
-+ label = "led-e";
-+ gpios = <&pioC 18 GPIO_ACTIVE_LOW>;
-+ };
-+ pc17 {
-+ label = "led-f";
-+ gpios = <&pioC 17 GPIO_ACTIVE_LOW>;
-+ };
-+ };
-+
-+ i2c-gpio-0 {
-+ status = "okay";
-+
-+ id_eeprom@56 {
-+ compatible = "atmel,24c04";
-+ reg = <0x56>;
-+ pagesize = <16>;
-+ status = "okay";
-+ };
-+ };
-+
-+ 1wire_cm {
-+ compatible = "w1-gpio";
-+ gpios = <&pioB 18 GPIO_ACTIVE_HIGH>;
-+ linux,open-drain;
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&pinctrl_1wire_cm>;
-+ status = "okay";
-+ };
-+ mts-io-0 {
-+ status = "okay";
-+ compatible = "mts,mts-io";
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&pinctrl_mts_io>;
-+ };
-+};
-diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/at91sam9x5cm.dtsi linux-4.9.87/arch/arm/boot/dts/at91sam9x5cm.dtsi
---- linux-4.9.87.orig/arch/arm/boot/dts/at91sam9x5cm.dtsi 2019-01-03 15:21:25.339570341 -0600
-+++ linux-4.9.87/arch/arm/boot/dts/at91sam9x5cm.dtsi 2019-01-03 15:17:51.911576659 -0600
-@@ -43,48 +43,8 @@
- atmel,has-pmecc; /* Enable PMECC */
- atmel,pmecc-cap = <2>;
- atmel,pmecc-sector-size = <512>;
-- nand-on-flash-bbt;
-+ /* nand-on-flash-bbt; */
- status = "okay";
--
-- at91bootstrap@0 {
-- label = "at91bootstrap";
-- reg = <0x0 0x40000>;
-- };
--
-- uboot@40000 {
-- label = "u-boot";
-- reg = <0x40000 0x80000>;
-- };
--
-- ubootenv@c0000 {
-- label = "U-Boot Env";
-- reg = <0xc0000 0x140000>;
-- };
--
-- kernel@200000 {
-- label = "kernel";
-- reg = <0x200000 0x600000>;
-- };
--
-- rootfs@800000 {
-- label = "rootfs";
-- reg = <0x800000 0x1f800000>;
-- };
-- };
-- };
--
-- leds {
-- compatible = "gpio-leds";
--
-- pb18 {
-- label = "pb18";
-- gpios = <&pioB 18 GPIO_ACTIVE_LOW>;
-- linux,default-trigger = "heartbeat";
-- };
--
-- pd21 {
-- label = "pd21";
-- gpios = <&pioD 21 GPIO_ACTIVE_HIGH>;
- };
- };
-
-@@ -96,5 +56,4 @@
- pinctrl-0 = <&pinctrl_1wire_cm>;
- status = "okay";
- };
--
- };
-diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/at91sam9x5ek.dtsi linux-4.9.87/arch/arm/boot/dts/at91sam9x5ek.dtsi
---- linux-4.9.87.orig/arch/arm/boot/dts/at91sam9x5ek.dtsi 2019-01-03 15:21:25.339570341 -0600
-+++ linux-4.9.87/arch/arm/boot/dts/at91sam9x5ek.dtsi 2019-01-03 15:17:51.911576659 -0600
-@@ -25,23 +25,11 @@
- &pinctrl_mmc0_slot0_clk_cmd_dat0
- &pinctrl_mmc0_slot0_dat1_3>;
- status = "okay";
-+ /* external micro SD slot */
- slot@0 {
- reg = <0>;
- bus-width = <4>;
-- cd-gpios = <&pioD 15 GPIO_ACTIVE_HIGH>;
-- };
-- };
--
-- mmc1: mmc@f000c000 {
-- pinctrl-0 = <
-- &pinctrl_board_mmc1
-- &pinctrl_mmc1_slot0_clk_cmd_dat0
-- &pinctrl_mmc1_slot0_dat1_3>;
-- status = "okay";
-- slot@0 {
-- reg = <0>;
-- bus-width = <4>;
-- cd-gpios = <&pioD 14 GPIO_ACTIVE_HIGH>;
-+ cd-gpios = <&pioA 1 GPIO_ACTIVE_HIGH>;
- };
- };
-
-@@ -58,25 +46,12 @@
- usb2: gadget@f803c000 {
- pinctrl-names = "default";
- pinctrl-0 = <&pinctrl_board_usb2>;
-- atmel,vbus-gpio = <&pioB 16 GPIO_ACTIVE_HIGH>;
-- status = "okay";
-- };
--
-- i2c0: i2c@f8010000 {
-- status = "okay";
--
-- wm8731: wm8731@1a {
-- compatible = "wm8731";
-- reg = <0x1a>;
-- };
-- };
--
-- adc0: adc@f804c000 {
-- atmel,adc-ts-wires = <4>;
-- atmel,adc-ts-pressure-threshold = <10000>;
-+ /* atmel,vbus-gpio = <&pioB 16 GPIO_ACTIVE_HIGH>; mtcdt: no vbus-gpio */
- status = "okay";
- };
-
-+ /* A/D convertor is unusable on Conduit */
-+
- pinctrl@fffff400 {
- camera_sensor {
- pinctrl_pck0_as_isi_mck: pck0_as_isi_mck-0 {
-@@ -118,7 +93,7 @@
- };
-
- spi0: spi@f0000000 {
-- status = "disabled"; /* conflict with mmc1 */
-+ status = "okay";
- cs-gpios = <&pioA 14 0>, <0>, <0>, <0>;
- m25p80@0 {
- compatible = "atmel,at25df321a";
-@@ -131,37 +106,20 @@
- status = "okay";
- };
-
-- ssc0: ssc@f0010000 {
-- status = "okay";
-- };
- };
-
- usb0: ohci@00600000 {
- status = "okay";
- num-ports = <3>;
-- atmel,vbus-gpio = <0 /* &pioD 18 GPIO_ACTIVE_LOW *//* Activate to have access to port A */
-- &pioD 19 GPIO_ACTIVE_LOW
-- &pioD 20 GPIO_ACTIVE_LOW
-- >;
-+ //mtcdt: no vbus-gpio
-+ // atmel,vbus-gpio = <0 /* &pioD 18 GPIO_ACTIVE_LOW *//* Activate to have access to port A */
-+ // &pioD 19 GPIO_ACTIVE_LOW
-+ // &pioD 20 GPIO_ACTIVE_LOW
-+ // >;
- };
-
- usb1: ehci@00700000 {
- status = "okay";
- };
- };
--
-- sound {
-- compatible = "atmel,sam9x5-wm8731-audio";
--
-- atmel,model = "wm8731 @ AT91SAM9X5EK";
--
-- atmel,audio-routing =
-- "Headphone Jack", "RHPOUT",
-- "Headphone Jack", "LHPOUT",
-- "LLINEIN", "Line In Jack",
-- "RLINEIN", "Line In Jack";
--
-- atmel,ssc-controller = <&ssc0>;
-- atmel,audio-codec = <&wm8731>;
-- };
- };
-
-diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/Makefile linux-4.9.87/arch/arm/boot/dts/Makefile
---- linux-4.9.87.orig/arch/arm/boot/dts/Makefile 2019-01-03 15:21:25.339570341 -0600
-+++ linux-4.9.87/arch/arm/boot/dts/Makefile 2019-01-03 15:17:51.911576659 -0600
-@@ -43,7 +43,8 @@
- at91sam9g25ek.dtb \
- at91sam9g35ek.dtb \
- at91sam9x25ek.dtb \
-- at91sam9x35ek.dtb
-+ at91sam9x35ek.dtb \
-+ mtr.dtb
- dtb-$(CONFIG_SOC_SAM_V7) += \
- at91-kizbox2.dtb \
- at91-sama5d2_ptc_ek.dtb \
-diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/at91sam9x5.dtsi linux-4.9.87/arch/arm/boot/dts/at91sam9x5.dtsi
---- linux-4.9.87.orig/arch/arm/boot/dts/at91sam9x5.dtsi 2019-01-03 15:21:25.339570341 -0600
-+++ linux-4.9.87/arch/arm/boot/dts/at91sam9x5.dtsi 2019-01-03 15:17:51.911576659 -0600
-@@ -32,9 +32,6 @@
- gpio3 = &pioD;
- tcb0 = &tcb0;
- tcb1 = &tcb1;
-- i2c0 = &i2c0;
-- i2c1 = &i2c1;
-- i2c2 = &i2c2;
- ssc0 = &ssc0;
- pwm0 = &pwm0;
- };
-@@ -963,50 +960,7 @@
- status = "disabled";
- };
-
-- i2c0: i2c@f8010000 {
-- compatible = "atmel,at91sam9x5-i2c";
-- reg = <0xf8010000 0x100>;
-- interrupts = <9 IRQ_TYPE_LEVEL_HIGH 6>;
-- dmas = <&dma0 1 AT91_DMA_CFG_PER_ID(7)>,
-- <&dma0 1 AT91_DMA_CFG_PER_ID(8)>;
-- dma-names = "tx", "rx";
-- #address-cells = <1>;
-- #size-cells = <0>;
-- pinctrl-names = "default";
-- pinctrl-0 = <&pinctrl_i2c0>;
-- clocks = <&twi0_clk>;
-- status = "disabled";
-- };
--
-- i2c1: i2c@f8014000 {
-- compatible = "atmel,at91sam9x5-i2c";
-- reg = <0xf8014000 0x100>;
-- interrupts = <10 IRQ_TYPE_LEVEL_HIGH 6>;
-- dmas = <&dma1 1 AT91_DMA_CFG_PER_ID(5)>,
-- <&dma1 1 AT91_DMA_CFG_PER_ID(6)>;
-- dma-names = "tx", "rx";
-- #address-cells = <1>;
-- #size-cells = <0>;
-- pinctrl-names = "default";
-- pinctrl-0 = <&pinctrl_i2c1>;
-- clocks = <&twi1_clk>;
-- status = "disabled";
-- };
--
-- i2c2: i2c@f8018000 {
-- compatible = "atmel,at91sam9x5-i2c";
-- reg = <0xf8018000 0x100>;
-- interrupts = <11 IRQ_TYPE_LEVEL_HIGH 6>;
-- dmas = <&dma0 1 AT91_DMA_CFG_PER_ID(9)>,
-- <&dma0 1 AT91_DMA_CFG_PER_ID(10)>;
-- dma-names = "tx", "rx";
-- #address-cells = <1>;
-- #size-cells = <0>;
-- pinctrl-names = "default";
-- pinctrl-0 = <&pinctrl_i2c2>;
-- clocks = <&twi2_clk>;
-- status = "disabled";
-- };
-+ /* /delete_node/ command does not work. */
-
- uart0: serial@f8040000 {
- compatible = "atmel,at91sam9260-usart";
-diff --git a/arch/arm/boot/dts/at91sam9x5ek.dtsi b/arch/arm/boot/dts/at91sam9x5ek.dtsi
-index d3fa60aa..0fcaa00a 100644
---- a/arch/arm/boot/dts/at91sam9x5ek.dtsi
-+++ b/arch/arm/boot/dts/at91sam9x5ek.dtsi
-@@ -19,20 +19,6 @@
-
- ahb {
- apb {
-- mmc0: mmc@f0008000 {
-- pinctrl-0 = <
-- &pinctrl_board_mmc0
-- &pinctrl_mmc0_slot0_clk_cmd_dat0
-- &pinctrl_mmc0_slot0_dat1_3>;
-- status = "okay";
-- /* external micro SD slot */
-- slot@0 {
-- reg = <0>;
-- bus-width = <4>;
-- cd-gpios = <&pioA 1 GPIO_ACTIVE_HIGH>;
-- };
-- };
--
- dbgu: serial@fffff200 {
- status = "okay";
- };