summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-mtcap-device-tree.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-mtcap-device-tree.patch')
-rw-r--r--recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-mtcap-device-tree.patch38
1 files changed, 28 insertions, 10 deletions
diff --git a/recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-mtcap-device-tree.patch b/recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-mtcap-device-tree.patch
index 474f606..9c00b0f 100644
--- a/recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-mtcap-device-tree.patch
+++ b/recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-mtcap-device-tree.patch
@@ -1,8 +1,7 @@
-Index: linux-3.12.27/arch/arm/boot/dts/mtcap.dts
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.12.27/arch/arm/boot/dts/mtcap.dts 2015-01-13 13:58:20.766078428 -0600
-@@ -0,0 +1,210 @@
+diff -Naru linux-3.12.27.orig/arch/arm/boot/dts/mtcap.dts linux-3.12.27/arch/arm/boot/dts/mtcap.dts
+--- linux-3.12.27.orig/arch/arm/boot/dts/mtcap.dts 1969-12-31 18:00:00.000000000 -0600
++++ linux-3.12.27/arch/arm/boot/dts/mtcap.dts 2017-02-24 14:31:20.750798116 -0600
+@@ -0,0 +1,230 @@
+/*
+ * DTS file for Multi-Tech Systems MTCAP Hardware
+ */
@@ -44,7 +43,27 @@ Index: linux-3.12.27/arch/arm/boot/dts/mtcap.dts
+ status = "okay";
+ };
+
++ mmc0: mmc@f0008000 {
++ pinctrl-names = "default";
++ pinctrl-0 = <
++ /* &pinctrl_board_mmc0 */
++ &pinctrl_mmc0_slot0_clk_cmd_dat0
++ &pinctrl_mmc0_slot0_dat1_3>;
++ status = "okay";
++ slot@0 {
++ reg = <0>;
++ bus-width = <4>;
++ };
++ };
++
+ pinctrl@fffff400 {
++ mmc0 {
++ pinctrl_board_mmc0: mmc0-board {
++ atmel,pins =
++ <AT91_PIOA 4 AT91_PERIPH_GPIO AT91_PINCTRL_PULL_UP_DEGLITCH>; /* PA4 gpio pin pull up and deglitch - WIFI enable */
++ };
++ };
++
+ nand {
+ pinctrl_nand: nand-0 {
+ atmel,pins =
@@ -213,10 +232,9 @@ Index: linux-3.12.27/arch/arm/boot/dts/mtcap.dts
+ };
+ };
+};
-Index: linux-3.12.27/arch/arm/boot/dts/Makefile
-===================================================================
---- linux-3.12.27.orig/arch/arm/boot/dts/Makefile 2014-08-26 07:12:26.000000000 -0500
-+++ linux-3.12.27/arch/arm/boot/dts/Makefile 2015-01-13 13:58:20.766078428 -0600
+diff -Naru linux-3.12.27.orig/arch/arm/boot/dts/Makefile linux-3.12.27/arch/arm/boot/dts/Makefile
+--- linux-3.12.27.orig/arch/arm/boot/dts/Makefile 2017-02-24 14:25:30.983064241 -0600
++++ linux-3.12.27/arch/arm/boot/dts/Makefile 2017-02-24 14:26:50.424821432 -0600
@@ -35,6 +35,7 @@
dtb-$(CONFIG_ARCH_AT91) += at91sam9g35ek.dtb
dtb-$(CONFIG_ARCH_AT91) += at91sam9x25ek.dtb
@@ -224,4 +242,4 @@ Index: linux-3.12.27/arch/arm/boot/dts/Makefile
+dtb-$(CONFIG_ARCH_AT91) += mtcap.dtb
# sama5d3
dtb-$(CONFIG_ARCH_AT91) += sama5d31ek.dtb
- dtb-$(CONFIG_ARCH_AT91) += sama5d33ek.dtb
+ dtb-$(CONFIG_ARCH_AT91) += sama5d33ek.dtb \ No newline at end of file