summaryrefslogtreecommitdiff
path: root/recipes-bsp/multitech/u-boot-linux-utils/uboot_configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/multitech/u-boot-linux-utils/uboot_configure.patch')
-rw-r--r--recipes-bsp/multitech/u-boot-linux-utils/uboot_configure.patch18
1 files changed, 10 insertions, 8 deletions
diff --git a/recipes-bsp/multitech/u-boot-linux-utils/uboot_configure.patch b/recipes-bsp/multitech/u-boot-linux-utils/uboot_configure.patch
index e7a7fe0..d8f5223 100644
--- a/recipes-bsp/multitech/u-boot-linux-utils/uboot_configure.patch
+++ b/recipes-bsp/multitech/u-boot-linux-utils/uboot_configure.patch
@@ -1,11 +1,11 @@
-commit 0de7b48ba5bfca360d7c1840e9415f8a8177eede
+commit 591d0dab81465e5e0df5b5ba6b70e2ec74f25bbc
Author: John Klug <john.klug@multitech.com>
-Date: Fri Apr 7 16:33:13 2017 -0500
+Date: Tue Apr 11 17:35:38 2017 -0500
- Defaults for u-boot-linux-utils + debug turned on
+ Allow a DEFAULT ENV file, and get the MTD_SIZE from CONFIG_ENV_SIZE in uboot
diff --git a/configure.in b/configure.in
-index 8fdc9ef..85998a9 100644
+index 8fdc9ef..8f6a1db 100644
--- a/configure.in
+++ b/configure.in
@@ -15,12 +15,15 @@ required header missing]))
@@ -16,13 +16,15 @@ index 8fdc9ef..85998a9 100644
+AC_DEFINE([DEBUG], 1, [set to 1 to enable debug])
AC_DEFINE([MTD_ENV1], "/dev/mtd3", [set to the first u-boot env mtd])
AC_DEFINE([MTD_ENV2], "/dev/mtd4", [set to the second (redundant) u-boot env mtd])
- AC_DEFINE([MTD_SIZE], 0x20000, [size of u-boot env mtd])
+-AC_DEFINE([MTD_SIZE], 0x20000, [size of u-boot env mtd])
-AC_DEFINE([DEFAULT_ENV], ["bootargs=mem=64M console=ttyS0,115200 root=/dev/mtdblock8 ro rootfstype=jffs2\0" "bootcmd=nboot.jffs2 ${loadaddr} 0 ${kernel_addr}; bootm ${loadaddr}\0" "bootdelay=3\0" "baudrate=115200\0" "ethaddr=00:D0:A0:02:0D:E1\0" "ipaddr=192.168.2.1\0" "serverip=192.168.2.2\0" "netmask=255.255.255.0\0" "hostname=AT91SAM9G20\0" "loadaddr=0x21400000\0" "kernel_addr=0x000A0000\0" "\0"]
+-, [default env if corrupt])
+
-+AC_DEFINE([DEFAULT_ENV], ["baudrate=115200\0" "bootargs=mem=256M console=ttyS0,115200 root=/dev/mtdblock8 ro rootfstype=jffs2\0" "bootcmd=nboot.jffs2 ${loadaddr} 0 ${kernel_addr}; bootm ${loadaddr}\0" "bootdelay=0\0" "ethact=macb0\0" "hostname=AT91SAM9G25\0" "ipaddr=192.168.2.1\0" "kernel_addr=0x200000\0" "loadaddr=0x22000000\0" "serverip=192.168.2.2\0" "netmask=255.255.255.0\0" "stderr=serial\0" "stdin=serial\0" "stdout=serial\0"]
- , [default env if corrupt])
-
+AC_DEFINE([MAC_PATH],["/sys/devices/platform/mts-io/mac-eth"], [MAC_PATH for defining ethaddr= in boot environment])
+
++AC_DEFINE_UNQUOTED([DEFAULT_ENV],
++ [$(cat ../DEFAULT_ENV.cfg | tr -d '\n')],
++ [default environment values])
+
AC_OUTPUT([Makefile src/Makefile])