summaryrefslogtreecommitdiff
path: root/recipes-bsp/multitech/mtac/serial-enable-tx-enable.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/multitech/mtac/serial-enable-tx-enable.patch')
-rw-r--r--recipes-bsp/multitech/mtac/serial-enable-tx-enable.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-bsp/multitech/mtac/serial-enable-tx-enable.patch b/recipes-bsp/multitech/mtac/serial-enable-tx-enable.patch
new file mode 100644
index 0000000..095c518
--- /dev/null
+++ b/recipes-bsp/multitech/mtac/serial-enable-tx-enable.patch
@@ -0,0 +1,49 @@
+diff --git a/configure.ac b/configure.ac
+index 8e49919..6855328 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,4 +1,4 @@
+-AC_INIT([mtac], [4.0.6])
++AC_INIT([mtac], [4.0.8])
+ AM_INIT_AUTOMAKE
+ AM_CONFIG_HEADER([config.h])
+
+diff --git a/machine/sam9g25_gpio.h b/machine/sam9g25_gpio.h
+index 3848576..eaeb42b 100644
+--- a/machine/sam9g25_gpio.h
++++ b/machine/sam9g25_gpio.h
+@@ -22,4 +22,9 @@
+ #define M_AP2_NRESET AT91_PIN_PB13
+ #define M_AP2_NINT1 AT91_PIN_PB17
+ #define M_AP2_NINT2 AT91_PIN_PB18
++
++// Special control pins for serial interface
++#define M_AP1_ENABLE_TX_ENABLE AT91_PIN_PC31
++#define M_AP2_ENABLE_TX_ENABLE AT91_PIN_PC30
++
+ #endif /* SAM9G25_MFSER_GPIO_H */
+diff --git a/machine/ti43x_gpio.h b/machine/ti43x_gpio.h
+index 734998d..3f27e95 100644
+--- a/machine/ti43x_gpio.h
++++ b/machine/ti43x_gpio.h
+@@ -22,4 +22,10 @@
+ #define M_AP2_NRESET OMAP_GPIO(5,29)
+ #define M_AP2_NINT1 OMAP_GPIO(3,17)
+ #define M_AP2_NINT2 OMAP_GPIO(3,18)
++
++// Special control pins for serial interface
++// which don't exist on the TI platform.
++#define M_AP1_ENABLE_TX_ENABLE 0
++#define M_AP2_ENABLE_TX_ENABLE 0
++
+ #endif /* TI MTCDT3-BB */
+diff --git a/mtac.c b/mtac.c
+index 2fefc0e..b7b59cd 100644
+--- a/mtac.c
++++ b/mtac.c
+@@ -1,4 +1,4 @@
+-#define DRIVER_VERSION "v4.0.5"
++#define DRIVER_VERSION "v4.0.8"
+ #define DRIVER_AUTHOR "Multi-Tech"
+ #define DRIVER_DESC "MTS driver to supervise MTAC slots"
+ #define DRIVER_NAME "mtac-slots"