summaryrefslogtreecommitdiff
path: root/recipes-bsp/multitech/mtac-xdot_1.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/multitech/mtac-xdot_1.1.0.bb')
-rw-r--r--recipes-bsp/multitech/mtac-xdot_1.1.0.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/recipes-bsp/multitech/mtac-xdot_1.1.0.bb b/recipes-bsp/multitech/mtac-xdot_1.1.0.bb
index 8fc75d6..23033b5 100644
--- a/recipes-bsp/multitech/mtac-xdot_1.1.0.bb
+++ b/recipes-bsp/multitech/mtac-xdot_1.1.0.bb
@@ -6,7 +6,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = "virtual/kernel mtac mts-io"
RDEPENDS_${PN} = "kernel-module-mtac"
-INC_PR = "r0"
+INC_PR = "r1"
SRCREV = "${PV}"
@@ -14,6 +14,7 @@ PR = "${INC_PR}.0-${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}"
SRC_URI = " \
git://git.multitech.net/mtac-xdot.git;protocol=git \
+ file://xdot-util \
"
S = "${WORKDIR}/git"
@@ -32,14 +33,20 @@ do_compile () {
oe_runmake
}
-PACKAGES = "kernel-module-${PN}"
+
+PACKAGES = "kernel-module-${PN} ${PN}-util"
FILES_kernel-module-${PN} = "${base_libdir}/modules/${KERNEL_VERSION}/extra/mtac_xdot.ko"
+FILES_${PN}-util += "${sbindir}/xdot-util"
+
PARALLEL_MAKE = ""
fakeroot do_install () {
install -m 0755 -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
# use cp instead of install so the driver doesn't get stripped
cp ${S}/mtac_xdot.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
+
+ install -m 0755 -d ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/xdot-util ${D}${sbindir}/xdot-util
}