summaryrefslogtreecommitdiff
path: root/recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb')
-rw-r--r--recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb16
1 files changed, 10 insertions, 6 deletions
diff --git a/recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb b/recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb
index 93272fb..a023a4e 100644
--- a/recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb
+++ b/recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb
@@ -5,13 +5,16 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
inherit update-rc.d
INITSCRIPT_NAME = "${PN}"
-INITSCRIPT_PARAMS = "start 40 S ."
-DEPENDS = "dtc-native"
+# mt-dt-overlay must start before mts-io
+# because the gpio-leds driver will not load
+# after mts-io.
+INITSCRIPT_PARAMS = "start 39 S ."
+DEPENDS = "dtc-native linux-at91"
RDEPENDS_${PN} = "bash"
# For now, just mtcap
-COMPATIBLE_MACHINE = "(mtcap|mtrv1)"
+COMPATIBLE_MACHINE = "(mtcap|mtrv1|mtcdt)"
# By using an overlay, we should be able to support multiple pinouts
# using the same image. The overlays go into /lib/dtoverlays.
@@ -22,14 +25,15 @@ COMPATIBLE_MACHINE = "(mtcap|mtrv1)"
dt_dir = "/lib/dtoverlays"
-PR = "r1"
+PR = "r2"
+# git://git.multitech.net/mt-dt-overlay.git;protocol=git
SRC_URI = " \
- git://git.multitech.net/mt-dt-overlay.git;protocol=git \
+ git://git@gitlab.multitech.net/mirrors/mt-dt-overlay.git;protocol=ssh;branch=MTCDT-0.2 \
file://init \
"
-SRCREV = "${PV}"
+SRCREV = "${AUTOREV}"
DEPENDS = "virtual/kernel u-boot-mkimage-native"