summaryrefslogtreecommitdiff
path: root/recipes-bsp/multitech/get-eeprom-device-config_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/multitech/get-eeprom-device-config_1.0.0.bb')
-rw-r--r--recipes-bsp/multitech/get-eeprom-device-config_1.0.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/multitech/get-eeprom-device-config_1.0.0.bb b/recipes-bsp/multitech/get-eeprom-device-config_1.0.0.bb
new file mode 100644
index 0000000..821f560
--- /dev/null
+++ b/recipes-bsp/multitech/get-eeprom-device-config_1.0.0.bb
@@ -0,0 +1,23 @@
+# Script to copy the EEPROM to /run/config
+PR = "r1"
+DESCRIPTION = "EEPROM copyting tool"
+HOMEPAGE = "http://www.multitech.net/"
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.GPLv2;md5=751419260aa954499f7abaabaa882bbe"
+RDEPENDS_${PN} =+ "bash"
+
+SRCREV = "${PV}"
+
+SRC_URI = "file://${PN}.sh"
+
+PARALLEL_MAKE = ""
+
+
+fakeroot do_install_append() {
+ # install MTCAP mts-io init script
+ install -d 0755 ${D}${base_sbindir}
+ install -m 0755 ${WORKDIR}/${PN}.sh ${D}${base_sbindir}/${PN}
+}
+