summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/rs9113/rs9113.inc9
-rw-r--r--recipes-kernel/rs9113/rs9113_1.6.0.bb2
2 files changed, 3 insertions, 8 deletions
diff --git a/recipes-kernel/rs9113/rs9113.inc b/recipes-kernel/rs9113/rs9113.inc
index 891bc9c..2774b76 100644
--- a/recipes-kernel/rs9113/rs9113.inc
+++ b/recipes-kernel/rs9113/rs9113.inc
@@ -36,13 +36,9 @@ python do_fetch_prepend () {
PV = gitversion
PV += "-"
try:
- PV += d.getVar("MLINUX_KERNEL_VERSION",True)
+ PV += d.getVar("PR",True)
except TypeError:
- bb.fatal("MLINUX_KERNEL_VERSION missing from conf/local.conf, usually put there by setup.sh")
- try:
- PV += d.getVar("MLINUX_KERNEL_EXTRA_VERSION",True)
- except TypeError:
- bb.fatal("MLINUX_KERNEL_EXTRA_VERSION missing from conf/local.conf, usually put there by setup.sh")
+ bb.fatal("PR is missing from recipe")
bb.note("PV is " + PV)
@@ -87,4 +83,3 @@ python do_cleanall_prepend () {
bb.note("About to delete " + DR)
os.system("/bin/rm -rf " + DR)
}
-
diff --git a/recipes-kernel/rs9113/rs9113_1.6.0.bb b/recipes-kernel/rs9113/rs9113_1.6.0.bb
index 5e4b4bb..666d06f 100644
--- a/recipes-kernel/rs9113/rs9113_1.6.0.bb
+++ b/recipes-kernel/rs9113/rs9113_1.6.0.bb
@@ -21,7 +21,7 @@ SRC_URI = " \
file://rs9113/rs9113.init \
file://rs9113/rs9113.default \
file://rs9113/wpa_supplicant \
- file://rs9113-ipk/rs9113-from-src_${PV}-${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}.0_mtcdt.ipk;name=binaries \
+ file://rs9113-ipk/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk;name=binaries \
"
SRCREV = "${AUTOREV}"
# For some reason the md5sum and sha256sum are ignored