summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/machine/mtcdt.conf2
-rw-r--r--recipes-bsp/multitech/mts-io_1.5.4.bb (renamed from recipes-bsp/multitech/mts-io_1.5.3.bb)0
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb56
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb9
-rw-r--r--recipes-kernel/rs9113/rs9113_1.4.3.bb39
-rw-r--r--recipes-kernel/rs9113/rs9113_1.5.0.bb55
6 files changed, 155 insertions, 6 deletions
diff --git a/conf/machine/mtcdt.conf b/conf/machine/mtcdt.conf
index d5efa67..8bca79a 100644
--- a/conf/machine/mtcdt.conf
+++ b/conf/machine/mtcdt.conf
@@ -38,3 +38,5 @@ UBOOT_LOADADDRESS = "0x20008000"
PREFERRED_VERSION_lora-gateway = '1.7.0mts'
PREFERRED_VERSION_lora-packet-forwarder = '1.4.1'
+
+PREFERRED_VERSION_rs9113 = '1.4.3'
diff --git a/recipes-bsp/multitech/mts-io_1.5.3.bb b/recipes-bsp/multitech/mts-io_1.5.4.bb
index 85b3de1..85b3de1 100644
--- a/recipes-bsp/multitech/mts-io_1.5.3.bb
+++ b/recipes-bsp/multitech/mts-io_1.5.4.bb
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb b/recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb
new file mode 100644
index 0000000..a7f2eee
--- /dev/null
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb
@@ -0,0 +1,56 @@
+DESCRIPTION = "USB Driver for Redpine RS9113"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+PACKAGE_ARCH = "mtcdt"
+PROVIDES = "rs9113-from-src"
+
+inherit module
+
+SRCREV = "${AUTOREV}"
+
+SRC_URI = " \
+ git://git@${MTS_INTERNAL_GIT}/mlinux/meta-rs9113.git;protocol=ssh;branch=${PV};destsuffix=meta/ \
+ git://git@${MTS_INTERNAL_GIT}/mlinux/Redpine.git;protocol=ssh;branch=${PV} \
+"
+SRCXX_URI = " \
+ git://git@${MTS_INTERNAL_GIT}/mlinux/Redpine.git;protocol=ssh;branch=${PV};name=machine \
+ git://git@${MTS_INTERNAL_GIT}/mlinux/meta-rs9113.git;protocol=ssh;branch=${PV};name=meta \
+"
+
+S = "${WORKDIR}/git/source/host"
+M = "${WORKDIR}/meta"
+
+EXTRA_OEMAKE = " KERNELDIR=${STAGING_KERNEL_DIR} \
+ CROSS_COMPILE=${TARGET_PREFIX} \
+ ARCH=arm \
+ WLAN_COMPILE_FLAGS='' \
+ V=1 \
+ "
+
+inherit update-rc.d
+INITSCRIPT_NAME = "rs9113"
+INITSCRIPT_PARAMS = "start 00 2 3 4 5 . stop 81 0 6 1 ."
+
+FILES_${PN} = "/opt/rs9113 ${sbindir}"
+FILES_${PN}-dbg = "/opt/rs9113/.debug/"
+
+PARALLEL_MAKE = ""
+
+do_configure() {
+ cp ${M}/mtcdt/defconfig .config
+}
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake
+}
+
+do_install() {
+ install -m 0755 -d ${D}/opt/rs9113
+ cp -r ${S}/release/* ${D}/opt/rs9113/
+ rm -rf ${D}/opt/rs9113/flash ${D}/opt/rs9113/certs ${D}/opt/rs9113/*zigb*
+ install -m 0755 -d ${D}${sbindir}
+ install -m 0755 ${M}/rs9113_load_modules.sh ${D}${sbindir}/
+ install -m 0755 ${M}/rs9113_remove_modules.sh ${D}${sbindir}/
+}
+
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb b/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
index a7f2eee..c7d6490 100644
--- a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
@@ -45,6 +45,15 @@ do_compile () {
oe_runmake
}
+do_patch () {
+ cd ${WORKDIR}/git
+ echo "patches" ${M}/patches/*
+ for f in ${M}/patches/* ; do
+ echo "Patching with ${f}"
+ patch -p1 < ${f}
+ done
+}
+
do_install() {
install -m 0755 -d ${D}/opt/rs9113
cp -r ${S}/release/* ${D}/opt/rs9113/
diff --git a/recipes-kernel/rs9113/rs9113_1.4.3.bb b/recipes-kernel/rs9113/rs9113_1.4.3.bb
new file mode 100644
index 0000000..a2f28c9
--- /dev/null
+++ b/recipes-kernel/rs9113/rs9113_1.4.3.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "USB Driver for Redpine RS9113"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+PACKAGE_ARCH = "mtcdt"
+PROVIDES = "rs9113"
+FILES_${PN} = "/opt/rs9113 ${sbindir} ${sysconfdir}"
+# BB_STRICT_CHECKSUM = "0"
+
+# NOTE: annex-client binary is built with Jenkin's job using annex-client-from-src.bb
+# To update this, manually copy ipk from Jenkin's job to .net/downloads/
+PR = "r0"
+SRC_URI = "http://akbar:8080/job/rs9113/lastSuccessfulBuild/artifact/mlinux/build/tmp/deploy/ipk/mtcdt/rs9113-from-src_${PV}-${PR}.0_${PACKAGE_ARCH}.ipk \
+ file://rs9113/rs9113.init \
+ file://rs9113/rs9113.default \
+ file://rs9113/wpa_supplicant \
+"
+
+M = "${WORKDIR}/rs9113"
+
+python do_fetch_prepend () {
+ d.setVar('BB_STRICT_CHECKSUM',False)
+}
+
+do_install() {
+ bbnote "pwd,ls: $(pwd) $(ls) WORKDIR is ${WORKDIR}"
+ (
+ cd ${WORKDIR}
+ find etc -print0 | cpio -0 -pdum ${D}
+ find usr -print0 | cpio -0 -pdum ${D}
+ find opt -print0 | cpio -0 -pdum ${D}
+ )
+ install -d ${D}/opt/rs9113/init.d
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/default/
+ install -m 0755 ${M}/wpa_supplicant ${D}/opt/rs9113/init.d
+ install -m 0755 ${M}/rs9113.init ${D}${sysconfdir}/init.d/rs9113
+ install -m 0644 ${M}/rs9113.default ${D}${sysconfdir}/default/rs9113
+}
+
diff --git a/recipes-kernel/rs9113/rs9113_1.5.0.bb b/recipes-kernel/rs9113/rs9113_1.5.0.bb
index a2f28c9..98bd1eb 100644
--- a/recipes-kernel/rs9113/rs9113_1.5.0.bb
+++ b/recipes-kernel/rs9113/rs9113_1.5.0.bb
@@ -8,20 +8,53 @@ FILES_${PN} = "/opt/rs9113 ${sbindir} ${sysconfdir}"
# NOTE: annex-client binary is built with Jenkin's job using annex-client-from-src.bb
# To update this, manually copy ipk from Jenkin's job to .net/downloads/
+# git://git@${MTS_INTERNAL_GIT}/mlinux/ipk.git;protocol=ssh;branch=${PV}
+#
PR = "r0"
-SRC_URI = "http://akbar:8080/job/rs9113/lastSuccessfulBuild/artifact/mlinux/build/tmp/deploy/ipk/mtcdt/rs9113-from-src_${PV}-${PR}.0_${PACKAGE_ARCH}.ipk \
+SRC_URI = " \
file://rs9113/rs9113.init \
file://rs9113/rs9113.default \
file://rs9113/wpa_supplicant \
+ file://rs9113-ipk/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk \
"
+# file://rs9113/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk
-M = "${WORKDIR}/rs9113"
+SRCREV = "${AUTOREV}"
+DR = "${DL_DIR}/rs9113-ipk"
+
+# os.system("export SSH_AUTH_SOCK=${SSH_AUTH_SOCK};git archive --remote=git@${MTS_INTERNAL_GIT}:mlinux/ipk.git ${PV} | tar -x -C ${WORKDIR} rs9113/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk")
python do_fetch_prepend () {
d.setVar('BB_STRICT_CHECKSUM',False)
+ DR = d.getVar("DR",True)
+ bb.note("DR is " + DR)
+
+ try:
+ os.mkdir(DR,0755)
+ except OSError:
+ pass
+ ex = "export SSH_AUTH_SOCK=" + d.getVar("SSH_AUTH_SOCK",True)
+ bb.note("export is " + ex)
+
+ gt = "git archive -v --remote=git@"
+ try:
+ gt += d.getVar("MTS_INTERNAL_GIT")
+ except TypeError:
+ bb.fatal("MTS_INTERNAL_GIT must be in BB_ENV_EXTRAWHITE")
+
+ PV = d.getVar("PV",True)
+ bb.note("PV is " + PV)
+ gt += ":mlinux/ipk.git " + PV
+ bb.note("git is " + gt)
+ PR = d.getVar("PR",True)
+ tar = "tar -vx --strip-components 1 -C " + DR + " rs9113/rs9113-from-src_"
+ tar += PV + "-" + PR + ".0_mtcdt.ipk"
+ bb.note("tar is " + tar)
+ os.system(ex + ";" + gt + "|" + tar)
}
-do_install() {
+MR = "${WORKDIR}/rs9113"
+do_install () {
bbnote "pwd,ls: $(pwd) $(ls) WORKDIR is ${WORKDIR}"
(
cd ${WORKDIR}
@@ -32,8 +65,18 @@ do_install() {
install -d ${D}/opt/rs9113/init.d
install -d ${D}${sysconfdir}/init.d/
install -d ${D}${sysconfdir}/default/
- install -m 0755 ${M}/wpa_supplicant ${D}/opt/rs9113/init.d
- install -m 0755 ${M}/rs9113.init ${D}${sysconfdir}/init.d/rs9113
- install -m 0644 ${M}/rs9113.default ${D}${sysconfdir}/default/rs9113
+ install -m 0755 ${MR}/wpa_supplicant ${D}/opt/rs9113/init.d
+ install -m 0755 ${MR}/rs9113.init ${D}${sysconfdir}/init.d/rs9113
+ install -m 0644 ${MR}/rs9113.default ${D}${sysconfdir}/default/rs9113
+}
+
+# echo rm -f ${M}/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk
+python do_cleanall_prepend () {
+ bb.note("In do_clean_prepend")
+ DR = d.getVar("DR",True)
+ bb.note("About to delete " + DR)
+ os.system("/bin/rm -rf " + DR)
}
+#
+#