summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb4
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb4
-rw-r--r--recipes-kernel/rs9113/rs9113.inc5
3 files changed, 5 insertions, 8 deletions
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb b/recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb
index a7f2eee..f2f2319 100644
--- a/recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb
@@ -27,10 +27,6 @@ EXTRA_OEMAKE = " KERNELDIR=${STAGING_KERNEL_DIR} \
V=1 \
"
-inherit update-rc.d
-INITSCRIPT_NAME = "rs9113"
-INITSCRIPT_PARAMS = "start 00 2 3 4 5 . stop 81 0 6 1 ."
-
FILES_${PN} = "/opt/rs9113 ${sbindir}"
FILES_${PN}-dbg = "/opt/rs9113/.debug/"
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb b/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
index c7d6490..c2ece5b 100644
--- a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
@@ -27,10 +27,6 @@ EXTRA_OEMAKE = " KERNELDIR=${STAGING_KERNEL_DIR} \
V=1 \
"
-inherit update-rc.d
-INITSCRIPT_NAME = "rs9113"
-INITSCRIPT_PARAMS = "start 00 2 3 4 5 . stop 81 0 6 1 ."
-
FILES_${PN} = "/opt/rs9113 ${sbindir}"
FILES_${PN}-dbg = "/opt/rs9113/.debug/"
diff --git a/recipes-kernel/rs9113/rs9113.inc b/recipes-kernel/rs9113/rs9113.inc
index e4dbb2c..d58012f 100644
--- a/recipes-kernel/rs9113/rs9113.inc
+++ b/recipes-kernel/rs9113/rs9113.inc
@@ -1,5 +1,10 @@
+inherit update-rc.d
+
DR = "${DL_DIR}/rs9113-ipk"
+INITSCRIPT_NAME = "rs9113"
+INITSCRIPT_PARAMS = "start 50 S ."
+
python do_fetch_prepend () {
d.setVar('BB_STRICT_CHECKSUM',False)
DR = d.getVar("DR",True)