summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/machine/mtcap.conf (renamed from conf/machine/mtp.conf)6
-rw-r--r--conf/machine/mtcdt.conf2
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb2
-rw-r--r--recipes-bsp/multitech/mts-id-eeprom_0.2.9.bb (renamed from recipes-bsp/multitech/mts-id-eeprom_0.2.6.bb)0
-rw-r--r--recipes-bsp/multitech/mts-io.inc15
-rwxr-xr-xrecipes-bsp/multitech/mts-io/lora-led-updater12
-rw-r--r--recipes-bsp/multitech/mts-io/mts-io.mtcap.init62
-rw-r--r--recipes-bsp/multitech/mts-io/mts-io.mtp.init36
-rw-r--r--recipes-bsp/multitech/mts-io_1.5.1.bb (renamed from recipes-bsp/multitech/mts-io_1.3.3.bb)0
-rw-r--r--recipes-bsp/u-boot/u-boot_2012.10.bb2
-rw-r--r--recipes-kernel/linux/linux-3.12.27/mtcap/defconfig (renamed from recipes-kernel/linux/linux-3.12.27/mtp/defconfig)2
-rw-r--r--recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-eeprom-setup-mtcdt.patch (renamed from recipes-kernel/linux/linux-3.12.27/mtp/linux-3.12-eeprom-setup-mtcdt.patch)0
-rw-r--r--recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-mtcap-device-tree.patch (renamed from recipes-kernel/linux/linux-3.12.27/mtp/linux-3.12-mtp-device-tree.patch)10
-rw-r--r--recipes-kernel/linux/linux_3.12.27.bb8
14 files changed, 97 insertions, 60 deletions
diff --git a/conf/machine/mtp.conf b/conf/machine/mtcap.conf
index 020f594..18343bd 100644
--- a/conf/machine/mtp.conf
+++ b/conf/machine/mtcap.conf
@@ -1,14 +1,12 @@
#@TYPE: Machine
-#@Name: MTP
-#@DESCRIPTION: Machine configuration for the MTP hardware
+#@Name: MTCAP
+#@DESCRIPTION: Machine configuration for the MTCAP hardware
require conf/machine/include/tune-arm926ejs.inc
MACHINE_FEATURES = "ext2 ext3 usbhost usbgadget ppp"
PREFERRED_PROVIDER_virtual/kernel = "linux"
PREFERRED_VERSION_linux = "3.12.27"
-PREFERRED_VERSION_mts-io ?= "1.3.3"
-PREFERRED_VERSION_mts-id-eeprom ?= "0.2.6"
MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "kernel-module-vizzini"
PREFERRED_VERSION_kernel-module-vizzini ?= "1.1"
diff --git a/conf/machine/mtcdt.conf b/conf/machine/mtcdt.conf
index 570d89d..d5efa67 100644
--- a/conf/machine/mtcdt.conf
+++ b/conf/machine/mtcdt.conf
@@ -7,8 +7,6 @@ require conf/machine/include/tune-arm926ejs.inc
MACHINE_FEATURES = "ext2 ext3 usbhost usbgadget ppp"
PREFERRED_PROVIDER_virtual/kernel = "linux"
PREFERRED_VERSION_linux = "3.12.27"
-PREFERRED_VERSION_mts-io ?= "1.3.3"
-PREFERRED_VERSION_mts-id-eeprom ?= "0.2.6"
MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "kernel-module-vizzini"
PREFERRED_VERSION_kernel-module-vizzini ?= "1.1"
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb b/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb
index ea003c3..1858d49 100644
--- a/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb
+++ b/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb
@@ -14,7 +14,7 @@ SRC_URI = "git://github.com/linux4sam/at91bootstrap \
S = "${WORKDIR}/git"
SRC_URI_append_mtcdt = " file://at91bootstrap-3.5.3-mtcdt.patch "
-SRC_URI_append_mtp = " file://at91bootstrap-3.5.3-mtcdt.patch "
+SRC_URI_append_mtcap = " file://at91bootstrap-3.5.3-mtcdt.patch "
# generate a bootstrap file padded with the header needed for 4-bit PMECC
# The padded file can be flashed via u-boot without any need to set the PMECC header using SAM-BA
diff --git a/recipes-bsp/multitech/mts-id-eeprom_0.2.6.bb b/recipes-bsp/multitech/mts-id-eeprom_0.2.9.bb
index ccf3521..ccf3521 100644
--- a/recipes-bsp/multitech/mts-id-eeprom_0.2.6.bb
+++ b/recipes-bsp/multitech/mts-id-eeprom_0.2.9.bb
diff --git a/recipes-bsp/multitech/mts-io.inc b/recipes-bsp/multitech/mts-io.inc
index 6d77e34..ca179c8 100644
--- a/recipes-bsp/multitech/mts-io.inc
+++ b/recipes-bsp/multitech/mts-io.inc
@@ -7,15 +7,16 @@ LIC_FILES_CHKSUM = "file://io-module/COPYING;md5=94d55d512a9ba36caa9b7df079bae19
file://io-tool/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
"
DEPENDS = "virtual/kernel"
-INC_PR = "r7"
+INC_PR = "r8"
SRCREV = "${PV}"
SRC_URI = " \
git://git.multitech.net/mts-io.git;protocol=git \
file://led-status_heartbeat_trigger \
+ file://lora-led-updater \
file://mts-io.init \
- file://mts-io.mtp.init \
+ file://mts-io.mtcap.init \
file://radio-reset.init \
file://radio-reset.default \
"
@@ -46,6 +47,7 @@ FILES_${PN} = "${base_libdir}/modules/${KERNEL_VERSION}/extra/mts_io.ko"
FILES_${PN} += "${sysconfdir}"
FILES_${PN} += "${libdir}/mts-io-sysfs*"
FILES_${PN} += "${sbindir}/mts-io-sysfs"
+FILES_${PN}_append_mtcap += "${sbindir}/lora-led-updater"
INITSCRIPT_NAME = "mts-io"
INITSCRIPT_PARAMS = "start 39 S ."
@@ -85,10 +87,11 @@ fakeroot do_install () {
install -m 0644 ${WORKDIR}/radio-reset.default ${D}${sysconfdir}/default/radio-reset
}
-fakeroot do_install_append_mtp() {
- # install MTP mts-io init script
- install -m 0755 ${WORKDIR}/mts-io.mtp.init ${D}${sysconfdir}/init.d/mts-io
+fakeroot do_install_append_mtcap() {
+ # install MTCAP mts-io init script
+ install -m 0755 ${WORKDIR}/mts-io.mtcap.init ${D}${sysconfdir}/init.d/mts-io
+ install -m 0755 ${WORKDIR}/lora-led-updater ${D}${sbindir}/lora-led-updater
- # disable radio-reset for the mtp hardware
+ # disable radio-reset for the mtcap hardware
sed -i 's/ENABLED="yes"/ENABLED="no"/g' ${D}${sysconfdir}/default/radio-reset
}
diff --git a/recipes-bsp/multitech/mts-io/lora-led-updater b/recipes-bsp/multitech/mts-io/lora-led-updater
new file mode 100755
index 0000000..637ee2e
--- /dev/null
+++ b/recipes-bsp/multitech/mts-io/lora-led-updater
@@ -0,0 +1,12 @@
+#!/bin/bash
+
+while true; do
+ fuser /dev/spidev0.0 > /dev/null
+ if [ $? == 0 ]; then
+ mts-io-sysfs store led-lora 1
+ else
+ mts-io-sysfs store led-lora 0
+ fi
+ sleep 5
+done
+
diff --git a/recipes-bsp/multitech/mts-io/mts-io.mtcap.init b/recipes-bsp/multitech/mts-io/mts-io.mtcap.init
new file mode 100644
index 0000000..02d5834
--- /dev/null
+++ b/recipes-bsp/multitech/mts-io/mts-io.mtcap.init
@@ -0,0 +1,62 @@
+#!/bin/bash
+
+lora_init() {
+ # reset lora chip
+ mts-io-sysfs store lora/reset 1
+ mts-io-sysfs store lora/reset 0
+ usleep 100000
+ mts-io-sysfs store lora/reset 1
+
+ #Initialize FPGA
+ # usleep 100000
+ # mts-io-sysfs store lora/creset 1
+ # mts-io-sysfs store lora/creset 0
+ # while [ "$(mts-io-sysfs show lora/cdone)" == "0" ]; do
+ # usleep 10
+ # done
+ # mts-io-sysfs store lora/creset 1
+}
+
+eth_init() {
+ # reset eth phy
+ mts-io-sysfs store eth-reset 1
+ mts-io-sysfs store eth-reset 0
+ usleep 100000
+ mts-io-sysfs store eth-reset 1
+}
+
+cell_init() {
+ # remove /dev/modem_at[0,1] symlinks
+ rm -f /dev/modem_at[0,1]
+
+ # power down the cellular chip gracefully
+ mts-io-sysfs store radio-power 0
+
+ # power up the cellular chip
+ mts-io-sysfs store radio-power 1
+}
+
+start_lora_led_updater() {
+ lora-led-updater &
+}
+
+case $1 in
+ start)
+ echo "Loading mts-io module"
+ modprobe mts_io
+ lora_init
+ eth_init
+ cell_init &
+ start_lora_led_updater
+ ;;
+
+ stop)
+ echo "Unloading mts-io module"
+ modprobe -r mts_io
+ ;;
+
+ *)
+ echo "Usage: $0 {start|stop}"
+ exit 2
+ ;;
+esac
diff --git a/recipes-bsp/multitech/mts-io/mts-io.mtp.init b/recipes-bsp/multitech/mts-io/mts-io.mtp.init
deleted file mode 100644
index d8f8564..0000000
--- a/recipes-bsp/multitech/mts-io/mts-io.mtp.init
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/bash
-
-lora_init() {
- # reset lora chip
- mts-io-sysfs store lora-reset 0
-}
-
-cell_init() {
- # remove /dev/modem_at[0,1] symlinks
- rm -f /dev/modem_at[0,1]
-
- # power down the cellular chip gracefully
- mts-io-sysfs store radio-power 0
-
- # power up the cellular chip
- mts-io-sysfs store radio-power 1
-}
-
-case $1 in
- start)
- echo "Loading mts-io module"
- modprobe mts_io
- lora_init
- cell_init &
- ;;
-
- stop)
- echo "Unloading mts-io module"
- modprobe -r mts_io
- ;;
-
- *)
- echo "Usage: $0 {start|stop}"
- exit 2
- ;;
-esac
diff --git a/recipes-bsp/multitech/mts-io_1.3.3.bb b/recipes-bsp/multitech/mts-io_1.5.1.bb
index 85b3de1..85b3de1 100644
--- a/recipes-bsp/multitech/mts-io_1.3.3.bb
+++ b/recipes-bsp/multitech/mts-io_1.5.1.bb
diff --git a/recipes-bsp/u-boot/u-boot_2012.10.bb b/recipes-bsp/u-boot/u-boot_2012.10.bb
index aa3576f..47f6ea2 100644
--- a/recipes-bsp/u-boot/u-boot_2012.10.bb
+++ b/recipes-bsp/u-boot/u-boot_2012.10.bb
@@ -18,7 +18,7 @@ SRC_URI = "git://github.com/linux4sam/u-boot-at91.git;branch=u-boot-2012.10-at91
SRC_URI += "file://u-boot-2010.06-macb-autoneg-timeout.patch"
SRC_URI_append_mtcdt = " file://u-boot-2012.10-mtcdt.patch"
-SRC_URI_append_mtp = " file://u-boot-2012.10-mtcdt.patch"
+SRC_URI_append_mtcap = " file://u-boot-2012.10-mtcdt.patch"
TARGET_LDFLAGS = ""
diff --git a/recipes-kernel/linux/linux-3.12.27/mtp/defconfig b/recipes-kernel/linux/linux-3.12.27/mtcap/defconfig
index 3a8ef54..155ff82 100644
--- a/recipes-kernel/linux/linux-3.12.27/mtp/defconfig
+++ b/recipes-kernel/linux/linux-3.12.27/mtcap/defconfig
@@ -616,7 +616,7 @@ CONFIG_NETFILTER_XT_TARGET_HL=m
# CONFIG_NETFILTER_XT_TARGET_HMARK is not set
# CONFIG_NETFILTER_XT_TARGET_IDLETIMER is not set
# CONFIG_NETFILTER_XT_TARGET_LED is not set
-# CONFIG_NETFILTER_XT_TARGET_LOG is not set
+CONFIG_NETFILTER_XT_TARGET_LOG=y
CONFIG_NETFILTER_XT_TARGET_MARK=y
CONFIG_NETFILTER_XT_TARGET_NETMAP=y
# CONFIG_NETFILTER_XT_TARGET_NFLOG is not set
diff --git a/recipes-kernel/linux/linux-3.12.27/mtp/linux-3.12-eeprom-setup-mtcdt.patch b/recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-eeprom-setup-mtcdt.patch
index 4075005..4075005 100644
--- a/recipes-kernel/linux/linux-3.12.27/mtp/linux-3.12-eeprom-setup-mtcdt.patch
+++ b/recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-eeprom-setup-mtcdt.patch
diff --git a/recipes-kernel/linux/linux-3.12.27/mtp/linux-3.12-mtp-device-tree.patch b/recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-mtcap-device-tree.patch
index 27e8df2..474f606 100644
--- a/recipes-kernel/linux/linux-3.12.27/mtp/linux-3.12-mtp-device-tree.patch
+++ b/recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-mtcap-device-tree.patch
@@ -1,17 +1,17 @@
-Index: linux-3.12.27/arch/arm/boot/dts/mtp.dts
+Index: linux-3.12.27/arch/arm/boot/dts/mtcap.dts
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.12.27/arch/arm/boot/dts/mtp.dts 2015-01-13 13:58:20.766078428 -0600
++++ linux-3.12.27/arch/arm/boot/dts/mtcap.dts 2015-01-13 13:58:20.766078428 -0600
@@ -0,0 +1,210 @@
+/*
-+ * DTS file for Multi-Tech Systems MTP Hardware
++ * DTS file for Multi-Tech Systems MTCAP Hardware
+ */
+
+/dts-v1/;
+#include "at91sam9g25.dtsi"
+
+/ {
-+ model = "Multi-Tech Systems MTP";
++ model = "Multi-Tech Systems MTCAP";
+ compatible = "atmel,at91sam9g25ek", "atmel,at91sam9x5ek", "atmel,at91sam9x5", "atmel,at91sam9";
+
+ chosen {
@@ -221,7 +221,7 @@ Index: linux-3.12.27/arch/arm/boot/dts/Makefile
dtb-$(CONFIG_ARCH_AT91) += at91sam9g35ek.dtb
dtb-$(CONFIG_ARCH_AT91) += at91sam9x25ek.dtb
dtb-$(CONFIG_ARCH_AT91) += at91sam9x35ek.dtb
-+dtb-$(CONFIG_ARCH_AT91) += mtp.dtb
++dtb-$(CONFIG_ARCH_AT91) += mtcap.dtb
# sama5d3
dtb-$(CONFIG_ARCH_AT91) += sama5d31ek.dtb
dtb-$(CONFIG_ARCH_AT91) += sama5d33ek.dtb
diff --git a/recipes-kernel/linux/linux_3.12.27.bb b/recipes-kernel/linux/linux_3.12.27.bb
index 5a238e1..074ac48 100644
--- a/recipes-kernel/linux/linux_3.12.27.bb
+++ b/recipes-kernel/linux/linux_3.12.27.bb
@@ -36,20 +36,20 @@ SRC_URI_append_mtcdt = "\
file://linux-3.12-add-num_accessory_ports-config-option.patch \
"
-SRC_URI_append_mtp = "\
+SRC_URI_append_mtcap = "\
${COMMON_PATCHES} \
file://defconfig \
file://linux-3.12-eeprom-setup-mtcdt.patch \
- file://linux-3.12-mtp-device-tree.patch \
+ file://linux-3.12-mtcap-device-tree.patch \
file://linux-3.12-add-num_accessory_ports-config-option.patch \
"
SRC_URI[md5sum] = "2f05332bfca89ae1348ae454af2f5ffb"
SRC_URI[sha256sum] = "2014c55257dda311779359d6b42931079a687c154777cc528c44e25f262194cd"
-COMPATIBLE_MACHINE = "(mtcdt|mtp)"
+COMPATIBLE_MACHINE = "(mtcdt|mtcap)"
DTB_APPEND_mtcdt = "mtcdt"
-DTB_APPEND_mtp = "mtp"
+DTB_APPEND_mtcap = "mtcap"
# disable this on purpose for dev purposes
do_rm_work() {