summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorJeff Hatch <jhatch@multitech.com>2017-04-13 09:55:58 -0500
committerJeff Hatch <jhatch@multitech.com>2017-04-13 09:55:58 -0500
commit96f5e2f331c7548d08b104cc4931618084730cb9 (patch)
tree316cd72ca13c743395c3adbc8c2d3e6929951321 /recipes-kernel
parent7463028c890f133fe70f1566b5e795ec08bd8f2e (diff)
downloadmeta-multitech-96f5e2f331c7548d08b104cc4931618084730cb9.tar.gz
meta-multitech-96f5e2f331c7548d08b104cc4931618084730cb9.tar.bz2
meta-multitech-96f5e2f331c7548d08b104cc4931618084730cb9.zip
Add usb-serial-simple driver for telit module firmware upgrade support
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-3.12.27/mtcdt/defconfig2
-rw-r--r--recipes-kernel/linux/linux-3.12.27/mtcdt/linux-3.12-usb-serial-simple-telit.patch30
-rw-r--r--recipes-kernel/linux/linux_3.12.27.bb1
3 files changed, 32 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-3.12.27/mtcdt/defconfig b/recipes-kernel/linux/linux-3.12.27/mtcdt/defconfig
index 5639eb4..bfa0e38 100644
--- a/recipes-kernel/linux/linux-3.12.27/mtcdt/defconfig
+++ b/recipes-kernel/linux/linux-3.12.27/mtcdt/defconfig
@@ -2004,7 +2004,7 @@ CONFIG_USB_STORAGE=m
#
CONFIG_USB_SERIAL=m
CONFIG_USB_SERIAL_GENERIC=y
-# CONFIG_USB_SERIAL_SIMPLE is not set
+CONFIG_USB_SERIAL_SIMPLE=m
CONFIG_USB_SERIAL_AIRCABLE=m
CONFIG_USB_SERIAL_ARK3116=m
CONFIG_USB_SERIAL_BELKIN=m
diff --git a/recipes-kernel/linux/linux-3.12.27/mtcdt/linux-3.12-usb-serial-simple-telit.patch b/recipes-kernel/linux/linux-3.12.27/mtcdt/linux-3.12-usb-serial-simple-telit.patch
new file mode 100644
index 0000000..b00ca28
--- /dev/null
+++ b/recipes-kernel/linux/linux-3.12.27/mtcdt/linux-3.12-usb-serial-simple-telit.patch
@@ -0,0 +1,30 @@
+diff --git a/drivers/usb/class/cdc-acm.c b/drivers/usb/class/cdc-acm.c
+index 3be47c2..4608e7f 100644
+--- a/drivers/usb/class/cdc-acm.c
++++ b/drivers/usb/class/cdc-acm.c
+@@ -1727,6 +1727,11 @@ static const struct usb_device_id acm_ids[] = {
+ {USB_DEVICE(0x04e2, 0x1414),
+ .driver_info = IGNORE_DEVICE,
+ },
++ /* Telit flashing
++ */
++ {USB_DEVICE(0x058b, 0x0041),
++ .driver_info = IGNORE_DEVICE,
++ },
+
+ /* control interfaces without any protocol set */
+ { USB_INTERFACE_INFO(USB_CLASS_COMM, USB_CDC_SUBCLASS_ACM,
+diff --git a/drivers/usb/serial/usb-serial-simple.c b/drivers/usb/serial/usb-serial-simple.c
+index 147f019..2008329 100644
+--- a/drivers/usb/serial/usb-serial-simple.c
++++ b/drivers/usb/serial/usb-serial-simple.c
+@@ -48,6 +48,7 @@ DEVICE(funsoft, FUNSOFT_IDS);
+
+ /* Infineon Flashloader driver */
+ #define FLASHLOADER_IDS() \
++ { USB_DEVICE_INTERFACE_CLASS(0x058b, 0x0041, USB_CLASS_CDC_DATA) }, \
+ { USB_DEVICE(0x8087, 0x0716) }
+ DEVICE(flashloader, FLASHLOADER_IDS);
+
+--
+2.8.2 \ No newline at end of file
diff --git a/recipes-kernel/linux/linux_3.12.27.bb b/recipes-kernel/linux/linux_3.12.27.bb
index e266d41..5f1851d 100644
--- a/recipes-kernel/linux/linux_3.12.27.bb
+++ b/recipes-kernel/linux/linux_3.12.27.bb
@@ -37,6 +37,7 @@ SRC_URI_append_mtcdt = "\
file://linux-3.12-eeprom-setup-mtcdt.patch \
file://linux-3.12-mtcdt-device-tree.patch \
file://linux-3.12-add-num_accessory_ports-config-option.patch \
+ file://linux-3.12-usb-serial-simple-telit.patch \
"
SRC_URI_append_mtcap = "\