summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-11-13 16:38:47 -0600
committerJohn Klug <john.klug@multitech.com>2018-11-13 16:38:47 -0600
commit2711101dd81828fd112b8da289a03e7c25b3f279 (patch)
tree4f050e401936fa6230835a9d7736606900ceda27 /recipes-kernel
parent2a7a1ac551426ec5601ae0b94b170a9db5171b7f (diff)
downloadmeta-multitech-2711101dd81828fd112b8da289a03e7c25b3f279.tar.gz
meta-multitech-2711101dd81828fd112b8da289a03e7c25b3f279.tar.bz2
meta-multitech-2711101dd81828fd112b8da289a03e7c25b3f279.zip
ATAG Required to set kernel cmd line, new LOADADDR in kernel recipe per Mike N
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-at91-4.9/mtcdt/defconfig7
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.bb2
2 files changed, 6 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-at91-4.9/mtcdt/defconfig b/recipes-kernel/linux/linux-at91-4.9/mtcdt/defconfig
index 76770b1..783cff4 100644
--- a/recipes-kernel/linux/linux-at91-4.9/mtcdt/defconfig
+++ b/recipes-kernel/linux/linux-at91-4.9/mtcdt/defconfig
@@ -440,8 +440,11 @@ CONFIG_USE_OF=y
# CONFIG_ATAGS is not set
CONFIG_ZBOOT_ROM_TEXT=0x0
CONFIG_ZBOOT_ROM_BSS=0x0
-# CONFIG_ARM_APPENDED_DTB is not set
-CONFIG_CMDLINE="console=ttyS0,115200 initrd=0x21100000,25165824 root=/dev/ram0 rw"
+CONFIG_ARM_APPENDED_DTB=y
+CONFIG_ARM_ATAG_DTB_COMPAT=y
+CONFIG_ARM_ATAG_DTB_COMPAT_CMDLINE_FROM_BOOTLOADER=y
+# CONFIG_ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEND is not set
+CONFIG_CMDLINE=""
CONFIG_KEXEC=y
# CONFIG_CRASH_DUMP is not set
CONFIG_AUTO_ZRELADDR=y
diff --git a/recipes-kernel/linux/linux-at91_4.9.bb b/recipes-kernel/linux/linux-at91_4.9.bb
index 73aeaaf..c3b1074 100644
--- a/recipes-kernel/linux/linux-at91_4.9.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.bb
@@ -11,7 +11,7 @@ inherit linux-append-dtb
RDEPENDS_kernel-base=""
FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
-KERNEL_EXTRA_ARGS ="LOADADDR=0x22000000"
+KERNEL_EXTRA_ARGS ="LOADADDR=0x20008000"
PV = "4.9+git${SRCPV}"