summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-11-13 16:38:47 -0600
committerJohn Klug <john.klug@multitech.com>2019-07-03 11:22:01 -0500
commit7320eedff18bb0d71a91f63a9d985bbafa74c08f (patch)
tree610b772b2c16170eb9d23f37ecbc2f223afbd94e /recipes-kernel
parente3ee0ea9dcf3cafb4562e9207d83f93a7d6ba771 (diff)
downloadmeta-multitech-7320eedff18bb0d71a91f63a9d985bbafa74c08f.tar.gz
meta-multitech-7320eedff18bb0d71a91f63a9d985bbafa74c08f.tar.bz2
meta-multitech-7320eedff18bb0d71a91f63a9d985bbafa74c08f.zip
ATAG Required to set kernel cmd line, new LOADADDR in kernel recipe per Mike N
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-at91-4.9/mtcdt/defconfig7
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.bb2
2 files changed, 6 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-at91-4.9/mtcdt/defconfig b/recipes-kernel/linux/linux-at91-4.9/mtcdt/defconfig
index 76770b1..783cff4 100644
--- a/recipes-kernel/linux/linux-at91-4.9/mtcdt/defconfig
+++ b/recipes-kernel/linux/linux-at91-4.9/mtcdt/defconfig
@@ -440,8 +440,11 @@ CONFIG_USE_OF=y
# CONFIG_ATAGS is not set
CONFIG_ZBOOT_ROM_TEXT=0x0
CONFIG_ZBOOT_ROM_BSS=0x0
-# CONFIG_ARM_APPENDED_DTB is not set
-CONFIG_CMDLINE="console=ttyS0,115200 initrd=0x21100000,25165824 root=/dev/ram0 rw"
+CONFIG_ARM_APPENDED_DTB=y
+CONFIG_ARM_ATAG_DTB_COMPAT=y
+CONFIG_ARM_ATAG_DTB_COMPAT_CMDLINE_FROM_BOOTLOADER=y
+# CONFIG_ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEND is not set
+CONFIG_CMDLINE=""
CONFIG_KEXEC=y
# CONFIG_CRASH_DUMP is not set
CONFIG_AUTO_ZRELADDR=y
diff --git a/recipes-kernel/linux/linux-at91_4.9.bb b/recipes-kernel/linux/linux-at91_4.9.bb
index 73aeaaf..c3b1074 100644
--- a/recipes-kernel/linux/linux-at91_4.9.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.bb
@@ -11,7 +11,7 @@ inherit linux-append-dtb
RDEPENDS_kernel-base=""
FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
-KERNEL_EXTRA_ARGS ="LOADADDR=0x22000000"
+KERNEL_EXTRA_ARGS ="LOADADDR=0x20008000"
PV = "4.9+git${SRCPV}"