summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorBrandon Bayer <bbayer@multitech.com>2016-11-01 15:53:15 -0500
committerBrandon Bayer <bbayer@multitech.com>2016-11-01 15:53:15 -0500
commitde22fe2e10f6c1acdf8e5bddd7834f5d7fc168d7 (patch)
tree56c6fc3c9a8740eee83ea8d2fc6843b351e2fe4a /recipes-kernel
parent17546fcb10af43ef4e9aef70ecff341848501278 (diff)
downloadmeta-multitech-de22fe2e10f6c1acdf8e5bddd7834f5d7fc168d7.tar.gz
meta-multitech-de22fe2e10f6c1acdf8e5bddd7834f5d7fc168d7.tar.bz2
meta-multitech-de22fe2e10f6c1acdf8e5bddd7834f5d7fc168d7.zip
mtcap: rename machine type mtp to mtcap
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-3.12.27/mtcap/defconfig (renamed from recipes-kernel/linux/linux-3.12.27/mtp/defconfig)0
-rw-r--r--recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-eeprom-setup-mtcdt.patch (renamed from recipes-kernel/linux/linux-3.12.27/mtp/linux-3.12-eeprom-setup-mtcdt.patch)0
-rw-r--r--recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-mtcap-device-tree.patch (renamed from recipes-kernel/linux/linux-3.12.27/mtp/linux-3.12-mtp-device-tree.patch)10
-rw-r--r--recipes-kernel/linux/linux_3.12.27.bb8
4 files changed, 9 insertions, 9 deletions
diff --git a/recipes-kernel/linux/linux-3.12.27/mtp/defconfig b/recipes-kernel/linux/linux-3.12.27/mtcap/defconfig
index 155ff82..155ff82 100644
--- a/recipes-kernel/linux/linux-3.12.27/mtp/defconfig
+++ b/recipes-kernel/linux/linux-3.12.27/mtcap/defconfig
diff --git a/recipes-kernel/linux/linux-3.12.27/mtp/linux-3.12-eeprom-setup-mtcdt.patch b/recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-eeprom-setup-mtcdt.patch
index 4075005..4075005 100644
--- a/recipes-kernel/linux/linux-3.12.27/mtp/linux-3.12-eeprom-setup-mtcdt.patch
+++ b/recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-eeprom-setup-mtcdt.patch
diff --git a/recipes-kernel/linux/linux-3.12.27/mtp/linux-3.12-mtp-device-tree.patch b/recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-mtcap-device-tree.patch
index 27e8df2..474f606 100644
--- a/recipes-kernel/linux/linux-3.12.27/mtp/linux-3.12-mtp-device-tree.patch
+++ b/recipes-kernel/linux/linux-3.12.27/mtcap/linux-3.12-mtcap-device-tree.patch
@@ -1,17 +1,17 @@
-Index: linux-3.12.27/arch/arm/boot/dts/mtp.dts
+Index: linux-3.12.27/arch/arm/boot/dts/mtcap.dts
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.12.27/arch/arm/boot/dts/mtp.dts 2015-01-13 13:58:20.766078428 -0600
++++ linux-3.12.27/arch/arm/boot/dts/mtcap.dts 2015-01-13 13:58:20.766078428 -0600
@@ -0,0 +1,210 @@
+/*
-+ * DTS file for Multi-Tech Systems MTP Hardware
++ * DTS file for Multi-Tech Systems MTCAP Hardware
+ */
+
+/dts-v1/;
+#include "at91sam9g25.dtsi"
+
+/ {
-+ model = "Multi-Tech Systems MTP";
++ model = "Multi-Tech Systems MTCAP";
+ compatible = "atmel,at91sam9g25ek", "atmel,at91sam9x5ek", "atmel,at91sam9x5", "atmel,at91sam9";
+
+ chosen {
@@ -221,7 +221,7 @@ Index: linux-3.12.27/arch/arm/boot/dts/Makefile
dtb-$(CONFIG_ARCH_AT91) += at91sam9g35ek.dtb
dtb-$(CONFIG_ARCH_AT91) += at91sam9x25ek.dtb
dtb-$(CONFIG_ARCH_AT91) += at91sam9x35ek.dtb
-+dtb-$(CONFIG_ARCH_AT91) += mtp.dtb
++dtb-$(CONFIG_ARCH_AT91) += mtcap.dtb
# sama5d3
dtb-$(CONFIG_ARCH_AT91) += sama5d31ek.dtb
dtb-$(CONFIG_ARCH_AT91) += sama5d33ek.dtb
diff --git a/recipes-kernel/linux/linux_3.12.27.bb b/recipes-kernel/linux/linux_3.12.27.bb
index 5a238e1..074ac48 100644
--- a/recipes-kernel/linux/linux_3.12.27.bb
+++ b/recipes-kernel/linux/linux_3.12.27.bb
@@ -36,20 +36,20 @@ SRC_URI_append_mtcdt = "\
file://linux-3.12-add-num_accessory_ports-config-option.patch \
"
-SRC_URI_append_mtp = "\
+SRC_URI_append_mtcap = "\
${COMMON_PATCHES} \
file://defconfig \
file://linux-3.12-eeprom-setup-mtcdt.patch \
- file://linux-3.12-mtp-device-tree.patch \
+ file://linux-3.12-mtcap-device-tree.patch \
file://linux-3.12-add-num_accessory_ports-config-option.patch \
"
SRC_URI[md5sum] = "2f05332bfca89ae1348ae454af2f5ffb"
SRC_URI[sha256sum] = "2014c55257dda311779359d6b42931079a687c154777cc528c44e25f262194cd"
-COMPATIBLE_MACHINE = "(mtcdt|mtp)"
+COMPATIBLE_MACHINE = "(mtcdt|mtcap)"
DTB_APPEND_mtcdt = "mtcdt"
-DTB_APPEND_mtp = "mtp"
+DTB_APPEND_mtcap = "mtcap"
# disable this on purpose for dev purposes
do_rm_work() {