summaryrefslogtreecommitdiff
path: root/recipes-kernel/rs9113/rs9113_1.5.0.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2016-11-10 19:07:42 -0600
committerJohn Klug <john.klug@multitech.com>2016-11-10 19:07:42 -0600
commite27bfd67df0d435dfe06424373a0036029dc1c02 (patch)
tree4e54df16318e6be38ac7ff5c91b62f060a937d6c /recipes-kernel/rs9113/rs9113_1.5.0.bb
parent669f722c8f65748dbc7ce516cdb0284710390365 (diff)
downloadmeta-multitech-e27bfd67df0d435dfe06424373a0036029dc1c02.tar.gz
meta-multitech-e27bfd67df0d435dfe06424373a0036029dc1c02.tar.bz2
meta-multitech-e27bfd67df0d435dfe06424373a0036029dc1c02.zip
Move MTC written code into .net (eventually).
Diffstat (limited to 'recipes-kernel/rs9113/rs9113_1.5.0.bb')
-rw-r--r--recipes-kernel/rs9113/rs9113_1.5.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-kernel/rs9113/rs9113_1.5.0.bb b/recipes-kernel/rs9113/rs9113_1.5.0.bb
new file mode 100644
index 0000000..1e770e9
--- /dev/null
+++ b/recipes-kernel/rs9113/rs9113_1.5.0.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "USB Driver for Redpine RS9113"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+PACKAGE_ARCH = "mtcdt"
+PROVIDES = "rs9113"
+FILES_${PN} = "/opt/rs9113 ${sbindir} ${sysconfdir}"
+
+# NOTE: annex-client binary is built with Jenkin's job using annex-client-from-src.bb
+# To update this, manually copy ipk from Jenkin's job to .net/downloads/
+PR = "r0"
+SRC_URI = "http://akbar:8080/job/rs9113/lastSuccessfulBuild/artifact/mlinux/build/tmp/deploy/ipk/mtcdt/rs9113-from-src_${PV}-${PR}.0_${PACKAGE_ARCH}.ipk \
+ file://rs9113/rs9113.init \
+ file://rs9113/rs9113.default \
+ file://rs9113/wpa_supplicant \
+"
+
+SRC_URI[md5sum] = "3e2a36fc3fb32164820863fcde02c787"
+SRC_URI[sha256sum] = "f676c3f0814563ff1bb0f982dcd1fb55bd50b571594992000bbfad7bdec08a3a"
+
+M = "${WORKDIR}/rs9113"
+
+do_install() {
+ bbnote "pwd,ls: $(pwd) $(ls) WORKDIR is ${WORKDIR}"
+ (
+ cd ${WORKDIR}
+ find etc -print0 | cpio -0 -pdum ${D}
+ find usr -print0 | cpio -0 -pdum ${D}
+ find opt -print0 | cpio -0 -pdum ${D}
+ )
+ install -d ${D}/opt/rs9113/init.d
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/default/
+ install -m 0755 ${M}/wpa_supplicant ${D}/opt/rs9113/init.d
+ install -m 0755 ${M}/rs9113.init ${D}${sysconfdir}/init.d/rs9113
+ install -m 0644 ${M}/rs9113.default ${D}${sysconfdir}/default/rs9113
+} \ No newline at end of file