summaryrefslogtreecommitdiff
path: root/recipes-kernel/rs9113/rs9113-from-src_1.6.0.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-02-05 16:26:17 -0600
committerJohn Klug <john.klug@multitech.com>2019-02-05 16:27:53 -0600
commitcf1bf26d7c89caca047bb9f26703ec69d045754e (patch)
tree97c45e45a59b67bf07154345d09ea654d6e81d63 /recipes-kernel/rs9113/rs9113-from-src_1.6.0.bb
parenteeb363bcc5318dc214cef5754ca7dce7f196fc00 (diff)
downloadmeta-multitech-cf1bf26d7c89caca047bb9f26703ec69d045754e.tar.gz
meta-multitech-cf1bf26d7c89caca047bb9f26703ec69d045754e.tar.bz2
meta-multitech-cf1bf26d7c89caca047bb9f26703ec69d045754e.zip
Remove perl dependency4.1.64.1.54.1.4
Diffstat (limited to 'recipes-kernel/rs9113/rs9113-from-src_1.6.0.bb')
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.6.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.6.0.bb b/recipes-kernel/rs9113/rs9113-from-src_1.6.0.bb
index cd7c72c..46a348e 100644
--- a/recipes-kernel/rs9113/rs9113-from-src_1.6.0.bb
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.6.0.bb
@@ -3,7 +3,7 @@ LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
PROVIDES = "rs9113-from-src"
# r1 is the new firmware, 1.6.24.0, so upgrades will work.
-PR = "r1.${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}"
+PR = "r2.${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}"
INHIBIT_PACKAGE_STRIP = "1"
BB_STRICT_CHECKSUM = "0"
inherit module
@@ -76,5 +76,9 @@ do_install() {
install -m 0755 -d ${D}${sbindir}
install -m 0755 ${M}/rs9113_load_modules.sh ${D}${sbindir}/
install -m 0755 ${M}/rs9113_remove_modules.sh ${D}${sbindir}/
+ # New patch makes p2commands.sh a bash script.
+ cd ${D}/opt/rs9113/
+ mv p2pcommands.pl p2pcommands.sh
+ ln -sf p2pcommands.sh p2pcommands.pl
}