summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-12-17 13:00:05 -0600
committerJohn Klug <john.klug@multitech.com>2018-12-17 13:00:05 -0600
commit9e46981d8f55914dac767daec71763e222b9c686 (patch)
tree5bbe7e20bff4766b0be583e8b588998898960bf7 /recipes-kernel/linux
parentb393a9251e20219a2b7af93a4020d3cf02b2c499 (diff)
downloadmeta-multitech-9e46981d8f55914dac767daec71763e222b9c686.tar.gz
meta-multitech-9e46981d8f55914dac767daec71763e222b9c686.tar.bz2
meta-multitech-9e46981d8f55914dac767daec71763e222b9c686.zip
Fix the stack trace problem because of the generic compatiblity in the SPI in device tree
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-at91-4.9/linux-4.9-spidev_squack.patch11
-rw-r--r--recipes-kernel/linux/linux-at91-4.9/mtcdt/linux-4.9-mtcdt-device-tree.patch6
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.bb1
3 files changed, 15 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-at91-4.9/linux-4.9-spidev_squack.patch b/recipes-kernel/linux/linux-at91-4.9/linux-4.9-spidev_squack.patch
new file mode 100644
index 0000000..bad1743
--- /dev/null
+++ b/recipes-kernel/linux/linux-at91-4.9/linux-4.9-spidev_squack.patch
@@ -0,0 +1,11 @@
+diff -Naru linux-4.9.87.orig/drivers/spi/spidev.c linux-4.9.87/drivers/spi/spidev.c
+--- linux-4.9.87.orig/drivers/spi/spidev.c 2018-12-13 14:17:40.000000000 -0600
++++ linux-4.9.87/drivers/spi/spidev.c 2018-12-17 10:13:53.752668552 -0600
+@@ -696,6 +696,7 @@
+ static const struct of_device_id spidev_dt_ids[] = {
+ { .compatible = "rohm,dh2228fv" },
+ { .compatible = "lineartechnology,ltc2488" },
++ { .compatible = "mts,mtac" },
+ {},
+ };
+ MODULE_DEVICE_TABLE(of, spidev_dt_ids);
diff --git a/recipes-kernel/linux/linux-at91-4.9/mtcdt/linux-4.9-mtcdt-device-tree.patch b/recipes-kernel/linux/linux-at91-4.9/mtcdt/linux-4.9-mtcdt-device-tree.patch
index 1b60f2a..4c27284 100644
--- a/recipes-kernel/linux/linux-at91-4.9/mtcdt/linux-4.9-mtcdt-device-tree.patch
+++ b/recipes-kernel/linux/linux-at91-4.9/mtcdt/linux-4.9-mtcdt-device-tree.patch
@@ -96,7 +96,7 @@ diff -aNru linux-4.9-orig/arch/arm/boot/dts/mtcdt.dts linux-4.9/arch/arm/boot/dt
+ reg = <1>;
+ };
+ ap1-spi@2 {
-+ compatible = "spidev";
++ compatible = "mts,mtac";
+ spi-max-frequency = <2000000>;
+ reg = <2>;
+ };
@@ -124,7 +124,7 @@ diff -aNru linux-4.9-orig/arch/arm/boot/dts/mtcdt.dts linux-4.9/arch/arm/boot/dt
+ reg = <1>;
+ };
+ ap2-spi@2 {
-+ compatible = "spidev";
++ compatible = "mts,mtac";
+ spi-max-frequency = <2000000>;
+ reg = <2>;
+ };
@@ -518,4 +518,4 @@ diff -aNru linux-4.9-orig/arch/arm/boot/dts/at91sam9x5.dtsi linux-4.9/arch/arm/b
+ /* /delete_node/ command does not work. */
uart0: serial@f8040000 {
- compatible = "atmel,at91sam9260-usart"; \ No newline at end of file
+ compatible = "atmel,at91sam9260-usart";
diff --git a/recipes-kernel/linux/linux-at91_4.9.bb b/recipes-kernel/linux/linux-at91_4.9.bb
index 243bdd0..d4f0331 100644
--- a/recipes-kernel/linux/linux-at91_4.9.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.bb
@@ -34,6 +34,7 @@ SRC_URI_append_mtcdt = "\
file://linux-4.9-add-num_accessory_ports-config-option.patch \
file://950-0090-OF-DT-Overlay-configfs-interface.patch \
file://linux-4.9-at91_gpio_set_single_ended.patch \
+ file://linux-4.9-spidev_squack.patch \
"
DTB_APPEND_mtcdt = "mtcdt"