summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-at91_4.9.87.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-01-18 11:35:58 -0600
committerJohn Klug <john.klug@multitech.com>2019-07-03 11:22:01 -0500
commitee5563d579c419be229f3651ed13e58898ca4222 (patch)
treebfb5b8157f6ea9aa8403c127edcd0420a261e889 /recipes-kernel/linux/linux-at91_4.9.87.bb
parenteaeb623b3dd5fd67d764ae0d06e5d3a9d9b7170c (diff)
downloadmeta-multitech-ee5563d579c419be229f3651ed13e58898ca4222.tar.gz
meta-multitech-ee5563d579c419be229f3651ed13e58898ca4222.tar.bz2
meta-multitech-ee5563d579c419be229f3651ed13e58898ca4222.zip
Add *.inc files with modules to autoload on boot.
Diffstat (limited to 'recipes-kernel/linux/linux-at91_4.9.87.bb')
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.87.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-at91_4.9.87.bb b/recipes-kernel/linux/linux-at91_4.9.87.bb
index 9cb6711..adbe4d9 100644
--- a/recipes-kernel/linux/linux-at91_4.9.87.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.87.bb
@@ -1,3 +1,8 @@
+# AUTOLOADs are in inc files now.
+require driver.inc
+require crypto.inc
+require net.inc
+
SECTION = "kernel"
DESCRIPTION = "Linux kernel for Atmel ARM SoCs (aka AT91)"
SUMMARY = "Linux kernel for Atmel ARM SoCs (aka AT91)"
@@ -29,7 +34,9 @@ SRC_URI = "https://github.com/linux4sam/linux-at91/archive/${SAMV}.tar.gz"
SRC_URI[md5sum] = "09002b6b7e5a654d65ddf3fcc9574add"
SRC_URI[sha256sum] = "eaff5fdba506bef95ca57db1a53e19b6807bc9b090f97d3348b1712708c32d4e"
-COMMON_PATCHES = "file://linux-4.9-pps-gpio.patch \
+COMMON_PATCHES = " \
+ file://defconfig \
+ file://linux-4.9-pps-gpio.patch \
file://EXTRAVERSION.patch \
"
@@ -38,7 +45,6 @@ COMMON_PATCHES = "file://linux-4.9-pps-gpio.patch \
SRC_URI_append_mtcdt = "\
${COMMON_PATCHES} \
- file://defconfig \
file://linux-4.9-mtcdt-device-tree.patch \
file://linux-4.9-add-num_accessory_ports-config-option.patch \
file://950-0090-OF-DT-Overlay-configfs-interface.patch \
@@ -83,7 +89,6 @@ kernel_do_configure_append() {
cd ${S}; git status; cd -
}
-KERNEL_MODULE_AUTOLOAD += "atmel_usba_udc g_serial"
KERNEL_MODULE_PACKAGE_SUFFIX=""
COMPATIBLE_MACHINE = "(mtcdt|mtrv1)"