summaryrefslogtreecommitdiff
path: root/recipes-devtools/mtd/mtd-utils-static_git.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-01-09 16:24:35 -0600
committerJohn Klug <john.klug@multitech.com>2019-01-09 16:24:35 -0600
commit37c738883638d835f1f6dc00b0486a64788ecde7 (patch)
treef4a1a59d3aa0093d8149622b2673b6313c60e970 /recipes-devtools/mtd/mtd-utils-static_git.bb
parent2d68c47e6847da77565ac55dd54407c32551094b (diff)
downloadmeta-multitech-37c738883638d835f1f6dc00b0486a64788ecde7.tar.gz
meta-multitech-37c738883638d835f1f6dc00b0486a64788ecde7.tar.bz2
meta-multitech-37c738883638d835f1f6dc00b0486a64788ecde7.zip
Move mtd-utils to version 2.0.2
Diffstat (limited to 'recipes-devtools/mtd/mtd-utils-static_git.bb')
-rw-r--r--recipes-devtools/mtd/mtd-utils-static_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-devtools/mtd/mtd-utils-static_git.bb b/recipes-devtools/mtd/mtd-utils-static_git.bb
new file mode 100644
index 0000000..d3ba77e
--- /dev/null
+++ b/recipes-devtools/mtd/mtd-utils-static_git.bb
@@ -0,0 +1,25 @@
+# Recipe to produce a static nandwrite for flashing
+# the root file system after it has been mounted
+# read-only, and erased on the flash.
+# nanderase has already loaded its libraries before
+# the root file system has been erased, so it
+# does not need to be static.
+require recipes-devtools/mtd/mtd-utils_git.bb
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/mtd-utils:"
+
+PR = "r0"
+
+PACKAGES = "${PN} ${PN}-dbg"
+
+# build static version of nandwrite for flash upgrading
+CFLAGS += "-static"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ${B}/nandwrite.static ${D}${bindir}/
+}
+
+do_compile_append() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o nandwrite.static nand-utils/nandwrite.o libmtd.a
+} \ No newline at end of file