summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-04-07 18:58:12 -0500
committerJohn Klug <john.klug@multitech.com>2017-04-24 11:43:22 -0500
commit8dd4b86bfa8ede7c5e7110fc1c92ec9a14d31e17 (patch)
tree75492f04978cc0b82e8a62aa8c7909b4e11ccde0 /recipes-bsp
parent93749ef11a9a4fb41a0d16d60a91b02a4708ecf3 (diff)
downloadmeta-multitech-8dd4b86bfa8ede7c5e7110fc1c92ec9a14d31e17.tar.gz
meta-multitech-8dd4b86bfa8ede7c5e7110fc1c92ec9a14d31e17.tar.bz2
meta-multitech-8dd4b86bfa8ede7c5e7110fc1c92ec9a14d31e17.zip
Update configure
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/multitech/u-boot-linux-utils/dbg.patch15
-rw-r--r--recipes-bsp/multitech/u-boot-linux-utils/uboot_configure.patch28
2 files changed, 28 insertions, 15 deletions
diff --git a/recipes-bsp/multitech/u-boot-linux-utils/dbg.patch b/recipes-bsp/multitech/u-boot-linux-utils/dbg.patch
deleted file mode 100644
index af81220..0000000
--- a/recipes-bsp/multitech/u-boot-linux-utils/dbg.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-# Set the debug flag for the build so we can monitor
-# what is going on.
-diff --git a/configure.in b/configure.in
-index 8fdc9ef..7a2eb01 100644
---- a/configure.in
-+++ b/configure.in
-@@ -15,7 +15,7 @@ required header missing]))
-
- AC_CHECK_LIB([z], [crc32], [], AC_MSG_ERROR([libz is required]))
-
--AC_DEFINE([DEBUG], 0, [set to 1 to enable debug])
-+AC_DEFINE([DEBUG], 1, [set to 1 to enable debug])
- AC_DEFINE([MTD_ENV1], "/dev/mtd3", [set to the first u-boot env mtd])
- AC_DEFINE([MTD_ENV2], "/dev/mtd4", [set to the second (redundant) u-boot env mtd])
- AC_DEFINE([MTD_SIZE], 0x20000, [size of u-boot env mtd])
diff --git a/recipes-bsp/multitech/u-boot-linux-utils/uboot_configure.patch b/recipes-bsp/multitech/u-boot-linux-utils/uboot_configure.patch
new file mode 100644
index 0000000..e7a7fe0
--- /dev/null
+++ b/recipes-bsp/multitech/u-boot-linux-utils/uboot_configure.patch
@@ -0,0 +1,28 @@
+commit 0de7b48ba5bfca360d7c1840e9415f8a8177eede
+Author: John Klug <john.klug@multitech.com>
+Date: Fri Apr 7 16:33:13 2017 -0500
+
+ Defaults for u-boot-linux-utils + debug turned on
+
+diff --git a/configure.in b/configure.in
+index 8fdc9ef..85998a9 100644
+--- a/configure.in
++++ b/configure.in
+@@ -15,12 +15,15 @@ required header missing]))
+
+ AC_CHECK_LIB([z], [crc32], [], AC_MSG_ERROR([libz is required]))
+
+-AC_DEFINE([DEBUG], 0, [set to 1 to enable debug])
++AC_DEFINE([DEBUG], 1, [set to 1 to enable debug])
+ AC_DEFINE([MTD_ENV1], "/dev/mtd3", [set to the first u-boot env mtd])
+ AC_DEFINE([MTD_ENV2], "/dev/mtd4", [set to the second (redundant) u-boot env mtd])
+ AC_DEFINE([MTD_SIZE], 0x20000, [size of u-boot env mtd])
+-AC_DEFINE([DEFAULT_ENV], ["bootargs=mem=64M console=ttyS0,115200 root=/dev/mtdblock8 ro rootfstype=jffs2\0" "bootcmd=nboot.jffs2 ${loadaddr} 0 ${kernel_addr}; bootm ${loadaddr}\0" "bootdelay=3\0" "baudrate=115200\0" "ethaddr=00:D0:A0:02:0D:E1\0" "ipaddr=192.168.2.1\0" "serverip=192.168.2.2\0" "netmask=255.255.255.0\0" "hostname=AT91SAM9G20\0" "loadaddr=0x21400000\0" "kernel_addr=0x000A0000\0" "\0"]
++
++AC_DEFINE([DEFAULT_ENV], ["baudrate=115200\0" "bootargs=mem=256M console=ttyS0,115200 root=/dev/mtdblock8 ro rootfstype=jffs2\0" "bootcmd=nboot.jffs2 ${loadaddr} 0 ${kernel_addr}; bootm ${loadaddr}\0" "bootdelay=0\0" "ethact=macb0\0" "hostname=AT91SAM9G25\0" "ipaddr=192.168.2.1\0" "kernel_addr=0x200000\0" "loadaddr=0x22000000\0" "serverip=192.168.2.2\0" "netmask=255.255.255.0\0" "stderr=serial\0" "stdin=serial\0" "stdout=serial\0"]
+ , [default env if corrupt])
+
++AC_DEFINE([MAC_PATH],["/sys/devices/platform/mts-io/mac-eth"], [MAC_PATH for defining ethaddr= in boot environment])
++
+ AC_OUTPUT([Makefile src/Makefile])
+