summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-02-21 18:48:46 -0600
committerJohn Klug <john.klug@multitech.com>2019-07-03 11:22:01 -0500
commit6eafbe0811207a90d240a397ebc95d477090f224 (patch)
tree19cfe6da34bf2082b027f91be2fd64d5daa38904 /recipes-bsp
parentcccddf0057003df4aa272473bdc5f3955eba4b46 (diff)
downloadmeta-multitech-6eafbe0811207a90d240a397ebc95d477090f224.tar.gz
meta-multitech-6eafbe0811207a90d240a397ebc95d477090f224.tar.bz2
meta-multitech-6eafbe0811207a90d240a397ebc95d477090f224.zip
Move the overlay directory to where the dtoverlay command expects.
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/multitech/mt-dt-overlay.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-bsp/multitech/mt-dt-overlay.bb b/recipes-bsp/multitech/mt-dt-overlay.bb
index e4a3866..8b4fd0e 100644
--- a/recipes-bsp/multitech/mt-dt-overlay.bb
+++ b/recipes-bsp/multitech/mt-dt-overlay.bb
@@ -6,6 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
# "or" more machines in the future
COMPATIBLE_MACHINE = '(mtcdt)'
+dt_dir = "/boot/overlays"
SRC_URI = "git://git@gitlab.multitech.net/focus/mt-dt-overlay.git;protocol=ssh"
@@ -24,15 +25,15 @@ do_compile () {
oe_runmake DTC=/usr/bin/dtc KERNEL_DIR=${STAGING_KERNEL_DIR} KERNEL_BUILD_DIR=${KERNEL_PATH} ${MACHINE}_dtbos
}
-FILES_${PN} = "${base_libdir}"
+FILES_${PN} = "${dt_dir}"
addtask install after do_compile
do_install () {
# Copy files to /lib/dt-overlay/main (mtac cards will be in mtac)
if [ -e ${AT91BOOTSTRAP_MACHINE} ]; then
- install -d ${D}/${base_libdir}/dt-overlay/main
- install ${MACHINE}/*.dtbo ${D}/${base_libdir}/dt-overlay/main
+ install -d ${D}/${dt_dir}
+ install ${MACHINE}/*.dtbo ${D}/${dt_dir}
fi;
}