summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-02-01 17:38:16 -0600
committerJohn Klug <john.klug@multitech.com>2018-02-01 17:38:16 -0600
commitfd128b13421f6abf7591bc853e4f12a1b15864ae (patch)
tree1c3a9e697af5eccf682139a9361b582406b4db45 /recipes-bsp
parent9e7c782b9d519f3124a9a0a61936d76eedf4fef3 (diff)
downloadmeta-multitech-fd128b13421f6abf7591bc853e4f12a1b15864ae.tar.gz
meta-multitech-fd128b13421f6abf7591bc853e4f12a1b15864ae.tar.bz2
meta-multitech-fd128b13421f6abf7591bc853e4f12a1b15864ae.zip
Add the kernel revision to vizzini and mts-io, and make sure to update the package list for modprobe after installing the package
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/multitech/mts-io.inc4
-rw-r--r--recipes-bsp/multitech/mts-io_1.5.16.bb2
2 files changed, 5 insertions, 1 deletions
diff --git a/recipes-bsp/multitech/mts-io.inc b/recipes-bsp/multitech/mts-io.inc
index 950a2b9..f84f859 100644
--- a/recipes-bsp/multitech/mts-io.inc
+++ b/recipes-bsp/multitech/mts-io.inc
@@ -98,3 +98,7 @@ fakeroot do_install_append_mtcap() {
# disable radio-reset for the mtcap hardware
sed -i 's/ENABLED="yes"/ENABLED="no"/g' ${D}${sysconfdir}/default/radio-reset
}
+
+pkg_postins_${PN} () {
+ /sbin/depmod -a
+}
diff --git a/recipes-bsp/multitech/mts-io_1.5.16.bb b/recipes-bsp/multitech/mts-io_1.5.16.bb
index 85b3de1..92937cd 100644
--- a/recipes-bsp/multitech/mts-io_1.5.16.bb
+++ b/recipes-bsp/multitech/mts-io_1.5.16.bb
@@ -1,4 +1,4 @@
require mts-io.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.0-${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}"